User Tools

Site Tools


Sidebar


News:


Cartes du Ciel is free software released under the terms of the
GNU banner GNU General Public License


Hosted by SourceForge.net Support This Project
en:documentation:server_commands

Server Commands

SkyChart can work as a server. It accepts the following commands from a TCP/IP connection:

Connection

You can use any socket library or object to connect to Skychart from your software, or use the commands telnet or netcat from a script.
For examples with various languages, see http://skychart.svn.sourceforge.net/viewvc/skychart/trunk/skychart/sample_client/

The standard port is 3292, this can be changed by the user in the configuration menu. The program can also choose to listen to another random port if the configured port is busy.

Skychart maintains a file with information about the port and it's status.
In Linux and Mac: [User settings]/tmp/tcpport
In Windows: Registry key HKCU\Software\Astro_PC\Ciel\Status\TcpPort

The file (or key) do not exist if Skychart was never run.
It contains 0 if the program is not running, or the server is disabled in the configuration menu.
It contains the listen port if the program is ready to accept a connection.

Main Commands

Command Parameters Comment or GUI Equivalent
NEWCHART chart_name File → New Chart
CLOSECHART chart_name File → Close Chart
SELECTCHART chart_name Window → chart_name
LISTCHART Window
SEARCH object_name Search tool (Main Bar)
GETMSGBOX Returns the status bar content
GETCOORBOX Returns the coordinates shown in the status bar
GETINFOBOX Setup → Display → Labels - Display the chart information in the menu bar
FIND object_class object_name Same as search, but lets you specify the class of object you want: 0=nebula, 1=na, 2=star, 3=star, 4=variable, 5=double, 6=comet, 7=asteroid, 8=planet, 9=constellation, 10=line catalog
SAVE saved_file_name Save the current chart to the specified file
LOAD saved_file_name Load the chart from the file
LOADDEFAULT option_file_name Use this command to load an extract of the configuration file that temporarily replace some option from skychart.ini.
SETCAT path shortname active min max Add or change a Catgen catalog. The fields are the same as in the catalog setup.
SHUTDOWN Close the program
RESET Reload the default chart and options (same as signal HUP)
? No GUI equivalent, list of available commands

Chart Commands

Command Parameters Comment or GUI Equivalent
ZOOM+ View → Zoom in
ZOOM- View → Zoom out
MOVEEAST Keyboard Left arrow
MOVEWEST Keyboard Right arrow
MOVENORTH Keyboard Up arrow
MOVESOUTH Keyboard Down arrow
MOVENORTHEAST Numpad 7 (Ver num off)
MOVENORTHWEST Numpad 9 (Ver num off)
MOVESOUTHEAST Numpad 1 (Ver num off)
MOVESOUTHWEST Numpad 3 (Ver num off)
FLIPX Chart > Tranformation > Mirror Horizontally
FLIPY Chart > Tranformation > Mirror Vertically
SETCURSOR pixX pixY
CENTRECURSOR Right-clic → Center
ZOOM+MOVE Right-clic → Zoom + Move
ZOOM-MOVE Right-clic → Zoom - Move
ROT+ Chart → Tranformation → Rotate Right
ROT- Chart → Tranformation → Rotate Left
SETEQGRID ON/OFF Chart → Lines, Grid → Add Equatorial Grid
SETGRID ON/OFF Chart → Lines, Grid → Show Coordinate Grid
SETSTARMODE 0/1/2 Setup → Display → Display → Star Display
SETNEBMODE 0/1 Setup > Display → Display → Deep Sky Objects Display
SETAUTOSKY ON/OFF Setup → Display → Sky Colour
UNDO Edit → Undo
REDO Edit → Redo
SETPROJ ALTAZ/EQUAT/GALACTIC/ECLIPTIC Chart → Chart Coordinate System
SETFOV 00d00m00s or 00.00 Icon (FOV input fields) or icon (Main Bar)
SETRA RA:00h00m00s or RA:00.00 Icon (RA input fields)
SETDEC DEC:+00d00m00s or DEC:00.00 Icon (DEC input fields)
SETOBS LAT:+00d00m00sLON:+000d00m00sALT:000mOBS:name Setup → Observatory
IDCURSOR
SAVEIMG PNG/JPEG/BMP filename quality File → Save Image…
PRINT PRT/PS/BMP PORTRAIT/LANDSCAPE COLOR/BW filepath Print or export to Postscript or Bitmap,
File → Print and File→ Printer setup
SETNORTH Chart → View Horizon → North
SETSOUTH Chart → View Horizon → South
SETEAST Chart → View Horizon → East
SETWEST Chart → View Horizon → West
SETZENITH Icon (Right Bar)
ALLSKY Icon (Right Bar)
REDRAW Follows a modification command, mandatory to update chart
GETCURSOR
GETEQGRID
GETGRID
GETSTARMODE
GETNEBMODE
GETAUTOSKY
GETPROJ
GETFOV S/F
GETRA S/F S → 17h07m12s
F → 17.11991
GETDEC S/F
GETDATE
GETOBS
SETDATE yyyy-mm-ddThh:mm:ss or “yyyy-mm-dd hh:mm:ss” Setup → Date/Time
SETTZ Etc/GMT Setup → Observatory (Country Timezone)
GETTZ
SETGRIDNUM ON/OFF Setup → Display → Lines - Show Grid Label
SETCONSTLINE ON/OFF Setup → Display → Lines - Show Constellation Figure
SETCONSTBOUNDARY ON/OFF Setup → Display → Lines - Show Constellation Boundary
RESIZE width height Resize the chart
GETRISESET Get rise/transit/set time for the last selected object
MOVESCOPE RA Dec [00.00] Move the telescope cursor to coordinates. RA in decimal hours.
MOVESCOPEH HourAngle Dec [00.00] Same as MOVESCOPE but hourangle instead of RA. Hourangle in decimal hours.
IDCENTER Identify object at chart center
IDSCOPE Identify object at telescope cursor position
SHOWPICTURE ON/OFF Chart → Show objects → Show pictures
SHOWBGIMAGE ON/OFF Show background image
LOADBGIMAGE fits_filename Load new background image FITS file, also force reload of updated file if the name is the same.
LOADCIRCLE file_name Load a list of finder mark, same as right click - Finder circle - Load from file
SETCIRCLE num diameter rotation offset Define a finder circle as in Setup - Display - Finder circle
SETRECTANGLE num width height rotation offset Define a finder rectangle as in Setup - Display - Finder rectangle
SHOWCIRCLE num_list Set a comma separated list of circle to be activated 1,2,…,10
SHOWRECTANGLE num_list Set a comma separated list of rectangle to be activated 1,2,…,10
MARKCENTER ON/OFF Show a mark at the chart center, same as Show mark
GETSCOPERADEC Return current telescope coordinates.
TRACKTELESCOPE ON/OFF Same as menu Telescope / Track telescope.
CONNECTINDI Connect to configured INDI telescope.
DISCONNECTINDI Disconnect the INDI telescope.
SLEWINDI RAhr Dec [in decimal] Slew the INDI telescope to specified coordinates.
ABORTSLEWINDI Abort the current slewing command.
SYNCINDI RAhr Dec [in decimal] Sync the INDI telescope at the specified coordinates.
CONNECTTELESCOPE Connect to the default telescope.
DISCONNECTTELESCOPE Disconnect the default telescope.
SLEW RAhr Dec [in decimal] Slew the default telescope to specified coordinates.
ABORTSLEW Abort the current slewing command.
SYNC RAhr Dec [in decimal] Sync the default telescope at the specified coordinates.
OBSLISTLOAD list_file_name
OBSLISTFIRST
OBSLISTLAST
OBSLISTNEXT
OBSLISTPREV
OBSLISTLIMIT ON/OFF
OBSLISTAIRMASSLIMIT [airmass]
OBSLISTTRANSITLIMIT [hours]
OBSLISTTRANSITSIDE EAST/WEST/BOTH

V2.7 compatibility DDE command

Command Parameters Comment or GUI Equivalent
MOVE obsolete RA: 00h00m00.00s DEC:+00d00m00.0s FOV:+00d00m00s Icon
DATE obsolete, same as SETDATE
OBSL obsolete, same as SETOBS
RFSH obsolete, same as REDRAW
PDSS Same as the menu Chart-Get DSS Image
SBMP obsolete, use SAVEIMG
SGIF obsolete, use SAVEIMG
SJPG obsolete, use SAVEIMG
IDXY X:pixelx Y:pixely
GOXY X:pixelx Y:pixely
ZOM+ obsolete, same as ZOOM+
ZOM- obsolete, same as ZOOM-
STA+ icon (Main Bar)
STA- icon (Main Bar)
NEB+ icon (Main Bar)
NEB- icon (Main Bar)
GREQ obsolete, use SETEQGRID
GRAZ obsolete, use SETGRID
GRNM obsolete, use SETGRIDNUM
CONL obsolete, use SETCONSTLINE
CONB obsolete, use SETCONSTBOUNDARY
EQAZ obsolete, use SETPROJ
en/documentation/server_commands.txt · Last modified: 2014/09/30 07:26 by pch