View Issue Details

IDProjectCategoryView StatusLast Update
0001716CCdciel[All Projects] Generalpublic17-12-12 17:33
Reportertango13Assigned ToPatrick Chevalley 
PrioritynoneSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0001716: Support for Lin-guider
DescriptionHi Patrick,
would it be possible to add Lin-guider support to CCDciel?
Thanks a lot.
TagsNo tags attached.

Activities

Patrick Chevalley

17-05-26 21:32

administrator   ~0003819

Yes, this is probably possible and I will try. But I not use Lin-guider myself so it may take some time to familiarize with.
I also need you for testing.

Do you know any documentation about the communication protocol?
at the moment I only found a program example and the server source code.

tango13

17-05-27 08:55

reporter   ~0003820

Thank you Patrick!
Count on me of course for testing and for any other kind of help I can be useful for.
Unfortunately I don't have any documentation about the comm protocol, apart from the same test program you already found.
Should we talk to Andrew, lin-guider's main developer, for more info?
Thanks again Patrick for your great work and support to the astro community!

Patrick Chevalley

17-10-30 21:22

administrator   ~0004217

Revision 608 implement Lin_guider support:
https://sourceforge.net/p/ccdciel/code/608

I only test with lin_guider using the camera simulator but I cannot test guiding myself because I not have a ST4 cable to my mount.
Connection, start and stop guiding must work but dithering is totally untested because it require a calibration.
Can you try if it work for you ?

tango13

17-10-31 08:05

reporter   ~0004220

Thank you very much Patrick, your work is invaluable!
I will test it as soon as I have some clear skies and time.
Thanks again.

Patrick Chevalley

17-11-01 18:14

administrator   ~0004222

Revision 611 add TCP connection to lin_guider. This work from remote host, even with CCDciel running on Windows.
Unix socket or TCP is selectable in the options.

https://sourceforge.net/p/ccdciel/code/611/

Patrick Chevalley

17-12-12 17:33

administrator   ~0004359

I not think there is more to do here and this interface must be working.

Issue History

Date Modified Username Field Change
17-05-25 17:13 tango13 New Issue
17-05-26 21:32 Patrick Chevalley Assigned To => Patrick Chevalley
17-05-26 21:32 Patrick Chevalley Status new => assigned
17-05-26 21:32 Patrick Chevalley Note Added: 0003819
17-05-27 08:55 tango13 Note Added: 0003820
17-10-28 09:35 Patrick Chevalley Target Version => 1.0
17-10-30 21:22 Patrick Chevalley Status assigned => feedback
17-10-30 21:22 Patrick Chevalley Note Added: 0004217
17-10-31 08:05 tango13 Note Added: 0004220
17-10-31 08:05 tango13 Status feedback => assigned
17-11-01 18:14 Patrick Chevalley Note Added: 0004222
17-12-12 17:33 Patrick Chevalley Status assigned => resolved
17-12-12 17:33 Patrick Chevalley Resolution open => fixed
17-12-12 17:33 Patrick Chevalley Note Added: 0004359