View Issue Details

IDProjectCategoryView StatusLast Update
0001828CCdciel[All Projects] Generalpublic17-11-03 20:53
ReporterhanAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001828: Sequence stop (abort) is not instant
DescriptionI downloaded the latest trunk and I see many improvements. :)

One minor problem is still there, the stop of a sequence. It doesn't stop immediately and keeps on doing activities.

Since i switch between between h-alpha and a simple UV/IR block filter, I have tweak the autofocus exposure times or I'm not happy with the position so i have sometimes to stop the sequence. It is due my poor preperations but still it would be nice to have a instant/immediate stop (abort) of the sequence. Attached my log of this evening. One sequence stop is at the beginning.








TagsNo tags attached.

Activities

han

17-11-02 22:52

reporter  

Log_20171102_210813.log (18,086 bytes)

Patrick Chevalley

17-11-03 09:12

administrator   ~0004224

Many operation are stopped immediately, for example when doing the long exposure, but not the auto-focus it was running when you stop the sequence.
This is a bit complicate and request a lot of testing because we not know exactly what is running at the moment we want to stop, it can be mount slew, check exposure, plate solving or the auto-focus sequence itself.
We also expect to return to the previous focuser position so it cannot be really instantaneous.
This need to add a CancelAutofocus function to manage all this case, and set the sequence led to red only after it is finish.

Patrick Chevalley

17-11-03 20:53

administrator   ~0004225

I have to make change in many part of the program to improve this point, but now it stop in a much quicker way and most important the sequence led remain green until it is really stopped.

This is in revision 616 to 621.

Issue History

Date Modified Username Field Change
17-11-02 22:52 han New Issue
17-11-02 22:52 han File Added: Log_20171102_210813.log
17-11-03 09:12 Patrick Chevalley Status new => assigned
17-11-03 09:12 Patrick Chevalley Target Version => 1.0
17-11-03 09:12 Patrick Chevalley Note Added: 0004224
17-11-03 20:53 Patrick Chevalley Status assigned => resolved
17-11-03 20:53 Patrick Chevalley Resolution open => fixed
17-11-03 20:53 Patrick Chevalley Note Added: 0004225