View Issue Details

IDProjectCategoryView StatusLast Update
0001830CCdciel[All Projects] Generalpublic17-11-09 17:01
ReporterhanAssigned ToPatrick Chevalley 
PrioritynoneSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001830: Temperature compensation working fine, only a tweak suggested
DescriptionI have tested the temperature control intensively in simulation and it works at desired. My problems are caused by slippage of my motor driven focuser fine knob. So I have to update the V-curve every few observing nights to compensate. So I can report code is fine and correct.

While doing so, I have a suggestion to simply the code an almost futile amount having the same functionality.
In procedure Tf_starprofile.doAutofocusVcurve the following line is used four times:

// correct for temperature
if AutofocusVcTemp<>NullCoord then newpos:=newpos+focuser.TempOffset(AutofocusVcTemp,FocuserTemp);

Since temperature is a slow process this could be reduced one for vcsStartL and one for vcsStartR by reusing the calculated temperature offset (stored in a variable).

 
I assume the AutofocusVCtemp<>Nullcoord is required if no temperature measurement or an old V-curve is available.
TagsNo tags attached.

Activities

Patrick Chevalley

17-11-04 18:48

administrator   ~0004226

Thank you, I change the code in rev. 622:
https://sourceforge.net/p/ccdciel/code/622/

Do you think it is possible to make a correction for slippage? at least to request a new curve less frequently.
Maybe store the last focus position and for the next focus operation correct the start position by the difference between this last position and the central position at the time the Vcurve was measured.


han

17-11-04 21:06

reporter   ~0004227

Well that could be an interesting option.

I have high quality Rack & Pinion (geared) 3 inch focuser but decided to connect the motor to the 1:10 fine knob which is not geared but relies on friction. It uses stainless steel bearing balls held in a brass housing and will have no hysteresis but will have a tiny amount slippage over time as a now can confirm. So I have the same problem as people with Crayford focuser which relies on friction rather then the geared Rack & Pinion.

I could be an option "automatic slippage compensation." If the focus is reached satisfactory with a HFD close to the bottom of the V-curve it could calculated the difference of the expected calculated position and found solution and store this offset. See a proposed menu for Crayford focuser (and me)

slippage correction.png (12,883 bytes)
slippage correction.png (12,883 bytes)

Patrick Chevalley

17-11-09 17:01

administrator   ~0004246

I add the slippage option in revision 630.
But I add the option in the Autofocus tab because this is a Vcurve only option and the space you use in the Focuser tab is to set the backlash for the relative position focuser.

https://sourceforge.net/p/ccdciel/code/630

Issue History

Date Modified Username Field Change
17-11-04 12:40 han New Issue
17-11-04 18:48 Patrick Chevalley Assigned To => Patrick Chevalley
17-11-04 18:48 Patrick Chevalley Status new => assigned
17-11-04 18:48 Patrick Chevalley Target Version => 1.0
17-11-04 18:48 Patrick Chevalley Note Added: 0004226
17-11-04 21:06 han File Added: slippage correction.png
17-11-04 21:06 han Note Added: 0004227
17-11-09 17:01 Patrick Chevalley Status assigned => resolved
17-11-09 17:01 Patrick Chevalley Resolution open => fixed
17-11-09 17:01 Patrick Chevalley Note Added: 0004246