View Issue Details

IDProjectCategoryView StatusLast Update
0001835CCdciel[All Projects] Generalpublic17-11-09 22:34
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001835: RA position of solved image varies
DescriptionAfter solving (astrometry.net & PlateSolve2) the images attached in previous reports, the reported apparent position of M110 at mouse pointer is often a little wrong e.g.

M110 at mouse position: 00h 41 51, 41d 47 13
It should be around 00h 41 17, 41d 46 34

It happens both with PlateSolve2 and Astronomy.net. I can't explain it but doesn't seem correct.
TagsNo tags attached.

Activities

han

17-11-06 20:01

reporter  

screen shots.zip (3,465,116 bytes)

han

17-11-06 20:01

reporter   ~0004231

The problem seems to be related to astronomy.net mouse position indication. The center of the solutions are all more or less the same (same sequence). Only the mouse position indicated seems a little wrong. See attached screen shots

han

17-11-06 23:17

reporter   ~0004232

The problem is in the astrometry.net mouse position. Attached a test image of Sh2-135

The brightest star PPM 40324 in attached image is at 22 12 08, 59 30 11 (Apparent)
                    Star position according PlateSolve2 22 12 08, 59 30 30
                    Star position according Astrometry.net 22 15 08, 59 31 02

Also the Y position is indicated reverse. PPM 40324 should be at pixel 76, 334 This is also confirmed by DS9 fits viewer. CCDciel report the star at 79, 1431 where 1431=(height -334)

Sh2-135v3_200s_2x2_20171014_231841 - Copy (10).zip (3,377,067 bytes)

Patrick Chevalley

17-11-07 14:16

administrator   ~0004236

Reverted Y position is because I make it compatible to ASCOM frame (when ASCOM camera is configured) that use inverted Y axis.
But I agree this is confusing when loading a saved image. I change that in rev. 623 to always use FITS coordinate:
https://sourceforge.net/p/ccdciel/code/623/

Using Hipparcos data the Lambda Cephei apparent position is 22h12m08s +59°30'29"
This match the Platesolve2 position and what I get using astrometry.net on Linux.

But if I open on Windows the astrometry.net file solved on Linux I get the same kind of wrong position as you.
This let me think the error is in processing the polynomial coefficients in libccdcielwcs.dll, maybe because of the 32bit compiler.
I try to check in 64bit to be sure.

Patrick Chevalley

17-11-07 14:45

administrator   ~0004237

I confirm it work right if ccdciel and the lib are compiled for windows 64bit.

Also skychart 32bit using the same lib show the image rotated by 90°, definitively a bug in the 32bit lib.

Patrick Chevalley

17-11-08 17:16

administrator   ~0004240

Tested OK in Linux 32bit.
The problem is only with Windows 32bit.

Patrick Chevalley

17-11-08 17:47

administrator   ~0004241

Tested the Win32 version on Linux with Wine and it work correctly!
It an be interesting to test other Windows version to know if the problem is only with Windows 10.

Patrick Chevalley

17-11-09 22:34

administrator   ~0004250

This is fixed by upgrading WCSTOOLS to version 3.9.5
https://sourceforge.net/p/ccdciel/code/634/

The new dll is now available in ccdciel version 0.9.13

Issue History

Date Modified Username Field Change
17-11-06 18:04 han New Issue
17-11-06 20:01 han File Added: screen shots.zip
17-11-06 20:01 han Note Added: 0004231
17-11-06 23:17 han File Added: Sh2-135v3_200s_2x2_20171014_231841 - Copy (10).zip
17-11-06 23:17 han Note Added: 0004232
17-11-07 14:16 Patrick Chevalley Assigned To => Patrick Chevalley
17-11-07 14:16 Patrick Chevalley Status new => assigned
17-11-07 14:16 Patrick Chevalley Target Version => 1.0
17-11-07 14:16 Patrick Chevalley Note Added: 0004236
17-11-07 14:45 Patrick Chevalley Note Added: 0004237
17-11-08 17:16 Patrick Chevalley Note Added: 0004240
17-11-08 17:47 Patrick Chevalley Note Added: 0004241
17-11-09 22:34 Patrick Chevalley Status assigned => resolved
17-11-09 22:34 Patrick Chevalley Resolution open => fixed
17-11-09 22:34 Patrick Chevalley Note Added: 0004250