View Issue Details

IDProjectCategoryView StatusLast Update
0001836CCdciel[All Projects] Generalpublic17-11-14 16:22
ReporterhanAssigned ToPatrick Chevalley 
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001836: Sequence with several objects doesn't change position unless "Use astrometry" is selected.
DescriptionI made attached sequence for NGC7000 and entered four position for a mosaic. I forgot to select "Use astrometry to refine position" The telescope doesn't move but different positions are given. Same in simulation.

See attached sequence

TagsNo tags attached.



17-11-06 23:31


NGC7000 (813 bytes)

Patrick Chevalley

17-11-07 17:00

administrator   ~0004238

I can reproduce the problem only if the plan include "Autofocus before to start".
This case is fixed in revision 625:


17-11-14 00:28

reporter   ~0004270

Last edited: 17-11-14 00:29

View 2 revisions

Problem reoccurs at the second step of the sequence. First step is excecuted but at the second object sequence finishes. Repeat of all objects is ignored. Usiing astrometry for pointing fixes the problem again.

Patrick Chevalley

17-11-14 13:08

administrator   ~0004277

I cannot reproduce the problem using the sequence in the NGC7000 mosaic zip.

Tested on Windows with the Ascom camera and telescope simulator, with CdC also connected to the telescope simulator to check the position. The telescope moved right at the specified coordinates before every exposure.


17-11-14 15:16

reporter   ~0004280

I also can't produce the problem in simulation. I thought had the problem twice last night, so I was convinced it was a problem. Clouds arrived after a brief clear sky and I only continued in a rush to test the software.
Looking into the log, I see a delay of about 20 seconds between finishing the first object and the second step "Start plan 50sec". The 20 seconds delay is caused by autoguider?. It looks like I was confused by the 22 seconds delay after "Plan 50sec finished".

I would suggest two minor tweaks.

1) Instead of writing "Plan 50sec finished", write "Object M31-2, plan 50sec finished. Also instead of "Start plan 50sec", write "Object M31-3, start plan 50sec"
2) Can the 22 seconds delay be avoided?

This topic can be closed anyhow.

2017-11-14T00:01:26.833 Saved file C:\ccdciel\m31-1\m31-1_50s_2x2_20171113_230125.fits
2017-11-14T00:01:26.837 Stop capture
2017-11-14T00:01:27.228 Plan 50sec finished.
2017-11-14T00:01:27.552 Initialize target m31-2
2017-11-14T00:01:27.568 Stop autoguider
2017-11-14T00:01:27.685 Autoguider: Lock Position Lost
2017-11-14T00:01:49.129 Start plan 50sec
2017-11-14T00:01:54.219 Start step Step description
2017-11-14T00:01:54.234 Start capture
2017-11-14T00:01:54.247 Autofocus now

Patrick Chevalley

17-11-14 16:22

administrator   ~0004281

1) I change the message in revision 650 :
This also change the default step description to "Step1", "Step2",...

2) this 22 seconds include:
- the time to stop the autoguider, can take time if the guiding exposure is long.
- the time to slew the telescope, until ascom report the telescope is not busy + 2 second wait.
- a 5 second wait after slew.
in your case the autoguider is not restarted because you do an autofocus on the start of the first step, it is restarted after the autofocus.
if the autoguider is to be restarted this add
- the time to acquire a guide star, start guiding and settle.
- wait 5 second more to be sure it is stable.

I activate again a message when the telescope go to new coordinates, this will give information it do something.:
But I am reluctant to remove the 5 seconds wait as many mount need at least this time to stabilize.

This delay is problematic only if testing in a rush, it as no incidence on a real sequence.
If a real observation for some exceptional event as to go in a rush between the clouds I suggest to use the simple capture tab instead of a sequence.


Issue History

Date Modified Username Field Change
17-11-06 23:31 han New Issue
17-11-06 23:31 han File Added: NGC7000
17-11-07 17:00 Patrick Chevalley Assigned To => Patrick Chevalley
17-11-07 17:00 Patrick Chevalley Status new => resolved
17-11-07 17:00 Patrick Chevalley Resolution open => fixed
17-11-07 17:00 Patrick Chevalley Note Added: 0004238
17-11-14 00:28 han Status resolved => new
17-11-14 00:28 han Resolution fixed => reopened
17-11-14 00:28 han Note Added: 0004270
17-11-14 00:29 han Note Edited: 0004270 View Revisions
17-11-14 13:08 Patrick Chevalley Status new => feedback
17-11-14 13:08 Patrick Chevalley Target Version => 1.0
17-11-14 13:08 Patrick Chevalley Note Added: 0004277
17-11-14 14:58 han Status feedback => assigned
17-11-14 15:16 han Note Added: 0004280
17-11-14 16:22 Patrick Chevalley Status assigned => resolved
17-11-14 16:22 Patrick Chevalley Resolution reopened => fixed
17-11-14 16:22 Patrick Chevalley Note Added: 0004281