View Issue Details

IDProjectCategoryView StatusLast Update
0001842CCdciel[All Projects] Generalpublic17-11-12 23:02
ReporterMattia VergaAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0001842: Changed appdata directory
DescriptionThe appdata file should be moved to 'metainfo' directory.
See attached patch.
TagsNo tags attached.

Activities

Mattia Verga

17-11-12 13:54

reporter  

ccdciel_metadata.patch (4,169 bytes)
diff -U 3 -dHrN -- a/install.sh b/install.sh
--- a/install.sh	2017-08-27 17:14:49.000000000 +0200
+++ b/install.sh	2017-11-12 13:45:46.767723868 +0100
@@ -13,8 +13,8 @@
 install -m 755 -d $destdir
 install -m 755 -d $destdir/bin
 install -m 755 -d $destdir/share
-install -m 755 -d $destdir/share/appdata
 install -m 755 -d $destdir/share/applications
+install -m 755 -d $destdir/share/metainfo
 install -m 755 -d $destdir/share/doc
 install -m 755 -d $destdir/share/doc/ccdciel
 install -m 755 -d $destdir/share/pixmaps
@@ -45,7 +45,7 @@
 install -v -m 644 data/stars/focus_star_8  $destdir/share/ccdciel/data/stars/focus_star_8 
 install -v -m 644 doc/doc_ccdciel_en.pdf $destdir/share/ccdciel/doc/doc_ccdciel_en.pdf
 install -v -m 644 system_integration/Linux/share/applications/ccdciel.desktop $destdir/share/applications/ccdciel.desktop
-install -v -m 644 system_integration/Linux/share/appdata/ccdciel.appdata.xml $destdir/share/appdata/ccdciel.appdata.xml
+install -v -m 644 system_integration/Linux/share/metainfo/ccdciel.appdata.xml $destdir/share/metainfo/ccdciel.appdata.xml
 install -v -m 644 system_integration/Linux/share/doc/ccdciel/changelog $destdir/share/doc/ccdciel/changelog
 install -v -m 644 system_integration/Linux/share/doc/ccdciel/copyright $destdir/share/doc/ccdciel/copyright
 install -v -m 644 system_integration/Linux/share/pixmaps/ccdciel.png $destdir/share/pixmaps/ccdciel.png
diff -U 3 -dHrN -- a/system_integration/Linux/share/appdata/ccdciel.appdata.xml b/system_integration/Linux/share/appdata/ccdciel.appdata.xml
--- a/system_integration/Linux/share/appdata/ccdciel.appdata.xml	2015-12-16 10:48:19.000000000 +0100
+++ b/system_integration/Linux/share/appdata/ccdciel.appdata.xml	1970-01-01 01:00:00.000000000 +0100
@@ -1,28 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<application>
- <id type="desktop">ccdciel.desktop</id>
- <metadata_license>CC0-1.0</metadata_license>
- <project_license>GPL-3.0+</project_license>
- <name>CCDciel</name>
- <summary>CCD capture software for the amateur astronomer</summary>
- <description>
-  <p>
-    A CCD capture software intended for the amateur astronomer.
-  </p>
-  <p>
-    It include all the features required to perform digital imaging CCD observation of celestial objects.
-  </p>
-  <p>
-    Using the standard drivers protocol INDI and ASCOM it can connect and control the CCD camera, 
-    the focuser, the filter wheel and the telescope mount.
-  </p>
- </description>
- <screenshots>
-  <screenshot type="default">
-      <image>http://www.ap-i.net/ccdciel/_media/en/ccdciel.png</image>
-      <caption>The main window of CCDciel</caption>
-  </screenshot>
- </screenshots>
- <url type="homepage">http://www.ap-i.net/ccdciel/</url>
- <updatecontact>pch@ap-i.net</updatecontact>
-</application>
diff -U 3 -dHrN -- a/system_integration/Linux/share/metainfo/ccdciel.appdata.xml b/system_integration/Linux/share/metainfo/ccdciel.appdata.xml
--- a/system_integration/Linux/share/metainfo/ccdciel.appdata.xml	1970-01-01 01:00:00.000000000 +0100
+++ b/system_integration/Linux/share/metainfo/ccdciel.appdata.xml	2015-12-16 10:48:19.000000000 +0100
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<application>
+ <id type="desktop">ccdciel.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0+</project_license>
+ <name>CCDciel</name>
+ <summary>CCD capture software for the amateur astronomer</summary>
+ <description>
+  <p>
+    A CCD capture software intended for the amateur astronomer.
+  </p>
+  <p>
+    It include all the features required to perform digital imaging CCD observation of celestial objects.
+  </p>
+  <p>
+    Using the standard drivers protocol INDI and ASCOM it can connect and control the CCD camera, 
+    the focuser, the filter wheel and the telescope mount.
+  </p>
+ </description>
+ <screenshots>
+  <screenshot type="default">
+      <image>http://www.ap-i.net/ccdciel/_media/en/ccdciel.png</image>
+      <caption>The main window of CCDciel</caption>
+  </screenshot>
+ </screenshots>
+ <url type="homepage">http://www.ap-i.net/ccdciel/</url>
+ <updatecontact>pch@ap-i.net</updatecontact>
+</application>
ccdciel_metadata.patch (4,169 bytes)

Patrick Chevalley

17-11-12 23:02

administrator   ~0004265

Thank you Mattia.

Patch applied in revision 646:
https://sourceforge.net/p/ccdciel/code/646/

Issue History

Date Modified Username Field Change
17-11-12 13:54 Mattia Verga New Issue
17-11-12 13:54 Mattia Verga File Added: ccdciel_metadata.patch
17-11-12 23:02 Patrick Chevalley Assigned To => Patrick Chevalley
17-11-12 23:02 Patrick Chevalley Status new => resolved
17-11-12 23:02 Patrick Chevalley Resolution open => fixed
17-11-12 23:02 Patrick Chevalley Target Version => 1.0
17-11-12 23:02 Patrick Chevalley Note Added: 0004265