View Issue Details

IDProjectCategoryView StatusLast Update
0001845CCdciel[All Projects] Generalpublic17-11-19 15:12
ReporterhanAssigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001845: Trunk 643, exception errors
DescriptionGot this night a few times exception errors which stopped operation until acknowledged. Will investigate tomorrow.
TagsNo tags attached.



17-11-14 11:55

reporter   ~0004274

Did a quick check but could not find anything. Will run next nightly session in the debugger to trace the exceptions.


17-11-18 21:28

reporter   ~0004289

I get several runerror(201) in line 635 in fu_starprofile. See attached. The variables are all fine see watches.

For the rest it is all running fine! Slippage correction works fine. Only the blue background of the sequence I can't hardly see behind my red front. Making bold?

error ccdciel1.png (74,742 bytes)
error ccdciel1.png (74,742 bytes)
error ccdciel0.png (9,829 bytes)
error ccdciel0.png (9,829 bytes)

Patrick Chevalley

17-11-18 22:20

administrator   ~0004290

Error 201 is "range check error" , this appear only in debug and it is trapped by the try...except I add to every function that access the image array. But this must be fixed.

In this row the only thing that can raise a range check is: img[0,j,i0+i]
One possibility is the image frame is smaller than 150.
There is no test in this function that FStarX +/- s/2 is in the image frame because it is alway called after gethfd that do this test.

Yes the active row in the sequence use fixed color and this is not good, I try with bold.

Patrick Chevalley

17-11-18 22:31

administrator   ~0004291

rev 658 use bold font instead of color to mark the current row.


17-11-19 11:17

reporter   ~0004292

Last edited: 17-11-19 11:28

View 3 revisions

I could read in the debugger the value of img[0,j,i0+i] so that is strange. However in simulation I can also read img[0,j,i0+i+100000].

Maybe it has something to do with an occasional drift, I observe during focusing. The focus star sometimes drift near the edge of the window . The scope just moved to the guide star and gears are still settling. This also matches with the unpredictable occurrence.

Adding this to the code img[0,j,i0+i+100000] gives the same error. Running this without the debugger gives an "Range Check Error"

A try & exception or min & max would prevent this error.


17-11-19 15:02

reporter   ~0004293

If drift is the problem during focusing, the other thing you could consider what to do if the star is too close to the border. Beyond there will be an abort since there is a low snr value but if it is partly beyond this could give an wrong focus result. It is very rare so should probably not considered. It would require a check if the measuring box hits the borders.

Patrick Chevalley

17-11-19 15:11

administrator   ~0004294

When the program is compiled in Release mode, reading img[0,j,i0+i+100000] will not raise an exception if the address is still in the process memory. If this is out of the allowed range the try...except show a message in the log but the program is not aborted.

When compiled in Debug mode the compiler add the range checking code to test for this kind of error and the exception is always raised.

If the star is too close to the border the FindStarPos() function safely fail and the auto-focus fail. Same if the star go out of the window.
The solution in this case is to increase the frame size in Preference/Focus.

In revision 660 I add the testing for a valid range and eventually adjust the histogram width when the star is too near the border but still detected by FindStarPos().

Issue History

Date Modified Username Field Change
17-11-14 00:40 han New Issue
17-11-14 11:55 han Note Added: 0004274
17-11-18 21:28 han File Added: error ccdciel0.png
17-11-18 21:28 han File Added: error ccdciel1.png
17-11-18 21:28 han Note Added: 0004289
17-11-18 22:20 Patrick Chevalley Note Added: 0004290
17-11-18 22:31 Patrick Chevalley Note Added: 0004291
17-11-19 11:17 han Note Added: 0004292
17-11-19 11:25 han Note Edited: 0004292 View Revisions
17-11-19 11:28 han Note Edited: 0004292 View Revisions
17-11-19 15:02 han Note Added: 0004293
17-11-19 15:11 Patrick Chevalley Note Added: 0004294
17-11-19 15:12 Patrick Chevalley Status new => resolved
17-11-19 15:12 Patrick Chevalley Resolution open => fixed
17-11-19 15:12 Patrick Chevalley Target Version => 1.0