View Issue Details

IDProjectCategoryView StatusLast Update
0001859CCdciel[All Projects] Generalpublic17-12-08 14:33
ReporterThomas JaegerAssigned ToPatrick Chevalley 
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001859: Unable to rename, copy or delete an existing profile
DescriptionUnder file/devices/setup, it is not possible to rename, copy or delete an existing profile.
Steps To Reproducetry to rename an existing profile


Patrick Chevalley

17-12-06 17:06

administrator   ~0004330

Yes, I must add this options.

For now you can find the profiles in ~/.config/ccdciel/

This is the files ccdciel_*.conf
You can copy with: cp ccdciel_profile1.conf ccdciel_newprofile.conf

Exception is the default profile named ccdciel.conf

Thomas Jaeger

17-12-06 18:08

reporter   ~0004331

Thanks for clarification and acception. Thomas

Patrick Chevalley

17-12-06 18:44

administrator   ~0004332

In fact the "New" button was copying the current profile to the new one.
I do that because all the program configuration (and not only the devices) are stored in the profile.
This make sens because many program options depend on the equipment used.

So revision 727 do the following change:
 - rename the "New" button to "Copy".
 - add a "New" button that create a totally empty configuration.
 - add a "Delete" button.
 - profile list is now sorted in alphabetical order.

Patrick Chevalley

17-12-08 14:33

administrator   ~0004338

Version 0.9.21 is now available with this change.

Issue History

Date Modified Username Field Change
17-12-06 15:15 Thomas Jaeger New Issue
17-12-06 15:15 Thomas Jaeger Tag Attached: profile
17-12-06 17:06 Patrick Chevalley Assigned To => Patrick Chevalley
17-12-06 17:06 Patrick Chevalley Status new => assigned
17-12-06 17:06 Patrick Chevalley Target Version => 1.0
17-12-06 17:06 Patrick Chevalley Note Added: 0004330
17-12-06 18:08 Thomas Jaeger Note Added: 0004331
17-12-06 18:44 Patrick Chevalley Status assigned => resolved
17-12-06 18:44 Patrick Chevalley Resolution open => fixed
17-12-06 18:44 Patrick Chevalley Note Added: 0004332
17-12-08 14:33 Patrick Chevalley Note Added: 0004338