View Issue Details

IDProjectCategoryView StatusLast Update
0001864CCdciel[All Projects] Generalpublic18-01-15 14:57
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritynoneSeveritytrivialReproducibilityalways
Status resolvedResolutionno change required 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001864: V-curve learning bad quality - suggestions
Description- This has low priority -

Please look at my v-curve. CCDciel says it has bad quality. I guess the default V-curve learning settings do not fit well to my equipment (8"f5 Newton ASI1600). There are nine settings in the autofocus tab, well documentated but not fully understood by me.
What should I change to get v-curve focusing work. Any tipps are welcome.

Log of v-curve learning
2017-12-07T17:59:02.009 Take control exposure for 1.0 seconds
2017-12-07T17:59:02.335 ZWO CCD ASI1600MM-Cool: [DEBUG] StartExposure->setexp : 1.000s
2017-12-07T17:59:03.440 ZWO CCD ASI1600MM-Cool: [DEBUG] Uploading file. Ext: fits, Size: 83520, sendImage? Yes, saveImage? No
2017-12-07T17:59:03.625 ZWO CCD ASI1600MM-Cool: [DEBUG] Upload complete
2017-12-07T17:59:04.676 Measurement 3 hfd:7.4 peak:1723.7 snr:36.6
2017-12-07T17:59:04.677 Vcurve n30 pos:191 hfd:7.3 peak:1723.7 snr:36.6
2017-12-07T17:59:04.679 Cannot reach near focus HFD, please increase Half Width or better center the curve.
2017-12-07T17:59:04.915 MoonLite: [INFO] Focuser is moving to position 301
2017-12-07T17:59:09.425 MoonLite: [INFO] Focuser reached requested position.
TagsNo tags attached.

Activities

Thomas Jaeger

17-12-09 13:29

reporter  

Patrick Chevalley

17-12-10 18:57

administrator   ~0004346

The total movement range is not sufficient, you stay too near the focus but this Vcurve method need very defocused image to work.
 
In the message "Cannot reach near focus HFD, please increase Half Width or better center the curve" I must replace "Half Width" by "Max offset" to match the label in the Vcurve window.

Try 200 or 300 for Max offset, so it can reach a HFD of 20.

For the first try you can reduce the "Number of steps" from 30 to 10 to speedup the process.

And in the Preference/Autofocus you can also try to increase n.step from 3 to 5 to better leverage the seeing variation.

Thomas Jaeger

17-12-10 22:17

reporter   ~0004348

Hallo Patrick, thanks for your suggestions. I will try it next time, now it snows here in bavaria and tomorrow it turns to rain.
My focus is at 300, so setting "Max offset" to 300 can be critical. Are there successful autofocus situations with a HFD of 20 with a newton or cassegrain?
I will try a greater offset next time.

Patrick Chevalley

17-12-11 21:56

administrator   ~0004353

Sure, be careful to not set a negative focuser position that will not work.
The program correctly handle a defocused reflector star image with central obstruction.

This V curve is a real one I do with my 150mm F6 Newtonian:
https://www.ap-i.net/ccdciel/_detail/en/documentation/learn_vcurve.png

The HFD of 20 is only an indication, as you can see in above image it work fine for me, but this can also be 15 or 10.

The important point is you get a sufficient linear part in and out of the focus point because this focus method use a linear regression to guess the focus position.
This is not the case in your screenshot, it look like your are zoomed in a narrow area around the focus.

Thomas Jaeger

17-12-11 22:07

reporter   ~0004354

Thank you for clarification. I will give feedback after the next clear night.
Thomas

Thomas Jaeger

17-12-22 18:18

reporter   ~0004368

No clear nights here in germany. Thomas

Thomas Jaeger

17-12-26 09:48

reporter   ~0004369

Hello Patrick,
there were clear skies for a couple of hours last night. So I followed your suggestions and finally I got a sufficient v-curve with long linear parts. Thanks for your intructions.
Manual triggered autofocus worked most of the time. Once again I struggled with HFD settings. Setting "Autofocus tolerance" higher made it work. Issue can be closed.
Thomas

Attachments:
Bildschirmfoto vom 2017-12-25 23-14-53 -> first try with fewer points
V-Curve-Generation- 2017-12-25 23-21-45 -> final curve
V-Curve-Success.log -> manual triggered v-curve autofocus

V-Curve-Success.log (4,660 bytes)

Patrick Chevalley

18-01-15 14:57

administrator   ~0004385

Yes this is a good curve and it must work now.

Now I return at home and can work again on the program. Don't hesitate if you have other questions.

Issue History

Date Modified Username Field Change
17-12-09 13:29 Thomas Jaeger New Issue
17-12-09 13:29 Thomas Jaeger File Added: V-Curve 2017-12-07 18-09-49.png
17-12-10 18:57 Patrick Chevalley Assigned To => Patrick Chevalley
17-12-10 18:57 Patrick Chevalley Status new => feedback
17-12-10 18:57 Patrick Chevalley Note Added: 0004346
17-12-10 22:17 Thomas Jaeger Note Added: 0004348
17-12-10 22:17 Thomas Jaeger Status feedback => assigned
17-12-11 21:56 Patrick Chevalley Note Added: 0004353
17-12-11 22:07 Thomas Jaeger Note Added: 0004354
17-12-22 18:18 Thomas Jaeger Note Added: 0004368
17-12-26 09:48 Thomas Jaeger File Added: V-Curve-Generation- 2017-12-25 23-21-45.png
17-12-26 09:48 Thomas Jaeger File Added: Bildschirmfoto vom 2017-12-25 23-14-53.png
17-12-26 09:48 Thomas Jaeger File Added: V-Curve-Success.log
17-12-26 09:48 Thomas Jaeger Note Added: 0004369
18-01-15 14:57 Patrick Chevalley Status assigned => resolved
18-01-15 14:57 Patrick Chevalley Resolution open => no change required
18-01-15 14:57 Patrick Chevalley Target Version => 1.0
18-01-15 14:57 Patrick Chevalley Note Added: 0004385