View Issue Details

IDProjectCategoryView StatusLast Update
0001865CCdciel[All Projects] Generalpublic17-12-12 10:39
ReportergakellermanAssigned ToPatrick Chevalley 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001865: First AutoFocus image smeared.
DescriptionNot a huge deal but while using autofocus the first image in each group is smeared. I use a relative position focuser on an 11" SCT so I have a fairly large miror to move. Overall it dosen't seem to cause any real issue (I use 3 images per step) however I suspect there is a slight loss of accuracy.

A slight pause after a focuser movement would solve the issue... As long as that change wouldn't effect other types of focusers or users.
TagsNo tags attached.

Activities

Patrick Chevalley

17-12-10 19:05

administrator   ~0004347

There is already a one second wait after the focuser report it finish to move.
I can increase the value a bit or add a setting so everyone can configure what the focuser require.

What is the focusing method you use with the relative focuser? Dynamic or Iterative?
I am interested by feedback on this method as I not use them myself.

gakellerman

17-12-11 01:40

reporter   ~0004350

I use iterative method most of the time. I have had good sucess most of the time, only occationally does it miss achieving reasonable focus.

I tried Dynamic method but it seems to miss reasonable focus quite often (I think the smearing makes the Math errors more prevailent).

Both blurr the first image. I am sure due to having to move the mirror so far is the reason. During the last steps of iterative with small steps (initial steps 1000 and finial steps 200 and backlash comp 200) there is less smearing of the image.

I like the user delay setting idea; so long as it won't complicate things for newer users.

BTW its also confusing that the backlash compensation setting box only being visable while the focuser is connected to ascom is confusing. It should be accessable, like the other focus settings, always.

Patrick Chevalley

17-12-12 10:39

administrator   ~0004356

Thank you for this informations.

The backlash compensation was not show without the focuser because it apply only to relative position focuser and I not want user of absolute focuser think they can set a value here.
But I agree this is confusing, this option is now always displayed but with comment it apply only to relative focuser.

The delay after move option is available in the same preference page.

This changes are in revision 741 and will be available in version 0.9.22 later today.

https://sourceforge.net/p/ccdciel/code/741/

Issue History

Date Modified Username Field Change
17-12-10 13:37 gakellerman New Issue
17-12-10 19:05 Patrick Chevalley Assigned To => Patrick Chevalley
17-12-10 19:05 Patrick Chevalley Status new => feedback
17-12-10 19:05 Patrick Chevalley Note Added: 0004347
17-12-11 01:40 gakellerman Note Added: 0004350
17-12-11 01:40 gakellerman Status feedback => assigned
17-12-12 10:39 Patrick Chevalley Status assigned => resolved
17-12-12 10:39 Patrick Chevalley Resolution open => fixed
17-12-12 10:39 Patrick Chevalley Target Version => 1.0
17-12-12 10:39 Patrick Chevalley Note Added: 0004356