View Issue Details

IDProjectCategoryView StatusLast Update
0001873CCdciel[All Projects] Generalpublic18-01-15 14:40
ReporterThomas JaegerAssigned ToPatrick Chevalley 
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001873: ccdciel tried to slew mount even 'stay at current position is checked'
DescriptionMerry Christmas
 to all developers and users.

After observing the logs of last nights session I found a small inconsistency.

In running plan CCDCiel tried to slew my mount even
- mount is not connected in INDI
- mount disabled in profile settings
- 'stay at the current position for autofocus' is checked

See my comments in logfile in the attachment.
Steps To Reproducesimulator in INDI, not connected
uncheck 'use mount' in profile settings
run a plan with checked 'stay at the current position for autofocus'
set HFD to low that autofocus fails
Additional Informationautofocus
TagsNo tags attached.


Thomas Jaeger

17-12-26 14:05


Plan Issue.log (13,160 bytes)

Patrick Chevalley

18-01-06 11:13

administrator   ~0004374

Yes, at the moment there is a fallback action to always try to move to a focus star if focusing at the current position fail.

This was good for me as I was testing this function and I not want to lost some picture because of bad focus but I agree this can be worst in some case, for example if the focus error is very near the tolerance, as in your case, and if the telescope is not capable to return precisely on the target after the focus.

I will remove that and just let continue as is, with previous focus position.

Patrick Chevalley

18-01-15 14:40

administrator   ~0004383

This is fixed by revision 752:

Issue History

Date Modified Username Field Change
17-12-26 14:05 Thomas Jaeger New Issue
17-12-26 14:05 Thomas Jaeger File Added: Plan Issue.log
18-01-06 11:13 Patrick Chevalley Assigned To => Patrick Chevalley
18-01-06 11:13 Patrick Chevalley Status new => assigned
18-01-06 11:13 Patrick Chevalley Note Added: 0004374
18-01-15 14:40 Patrick Chevalley Status assigned => resolved
18-01-15 14:40 Patrick Chevalley Resolution open => fixed
18-01-15 14:40 Patrick Chevalley Target Version => 1.0
18-01-15 14:40 Patrick Chevalley Note Added: 0004383