View Issue Details

IDProjectCategoryView StatusLast Update
0001878CCdciel[All Projects] Generalpublic18-02-16 17:27
ReporterhanAssigned ToPatrick Chevalley 
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001878: Connect all, include guiding
DescriptionThe "device connect button" connects all ASCOM or INDI devices. The server based PHD2 connection has a separate connection button.

I noticed that I sometimes forget to connect PHD loosing some time, so i'm asking whould it not be better to have a "connect all" button? PHD2 is essential for imaging so in that respect it belongs to the same group as the camera, mount and focusser.
Maybe have in the pull down menu connect a seperate connect all and connect devices.
TagsNo tags attached.

Activities

Patrick Chevalley

18-01-15 11:22

administrator   ~0004378

This imply that PHD2 is started before CCDciel.

Maybe a better option is to add a setting in the Device setup page to set if the autoguider and planetarium must be started with the devices.
In this case I can add an option for the program path and start it if the first connection fail.


han

18-01-15 12:38

reporter   ~0004380

Last edited: 18-01-15 12:55

View 3 revisions

If PHD is not connecting, a red indication at devices could warn the user. So if with devices also guider and planetarium are reported in red/green status, I don't think "PHD not running" is a problem. But executing PHD by CCDciel would be more convenient.

Combining connection of autoguider and planetarium together with devices will be nice.

p.s. I notice my focuser doesn't connect the first time for some reason. Disconnect en reconnect fixes this. Not important but something I will investigate in future.

han

18-02-14 02:18

reporter   ~0004443

Last edited: 18-02-14 02:21

View 2 revisions

After having finally some clear nights since november, I notice again that the guider is the most common cause of loosing time.

You can start the sequence without PHD2 connected but if you start PHD2 later, the sequence is often aborted and you have to go again through a long startup process: slew to object, wait, slew to focus star, wait, astrometry, focus, slew to object, wait, astrometry, slew, wait, start sequence. Sometimes the mount is not stable even after 20 seconds wait time or the wrong faint focus star is selected, so often 15 minutes or more of precious clear sky time are lost.

What I would wish is:

1 If the autoguider tool is selected, one of the first steps of the sequence should be a check if the autoguider server connection is available and if not, make the connection automatically (the user has to start the PHD program). It should not start the sequence unless PHD2 is connected.
2) Do not abort sequence too quickly on any guiding stop/ restart. It could be that the user is trying to find a better focus star or increasing the exposure time or a cloud is passing by. The sequence should warn but keep on running for some limited time (60 sec?) and only abort if guiding is absent too long.

Patrick Chevalley

18-02-14 20:23

administrator   ~0004444

This is a good idea, I implement the two today and also add connection light status in the status bar so they are visible on all the tabs.

But I am waiting for Sourceforge to finish their maintenance so I can commit the code.

Patrick Chevalley

18-02-16 17:27

administrator   ~0004451

the change are in rev 792:
https://sourceforge.net/p/ccdciel/code/792/

I also add a check that camera cooling is active at the start of the sequence because I sometime do this error. It start cooling if this is active in Preference/CCD temperature.

I think there is now enough checking and it is not necessary to change the connection behavior.



Issue History

Date Modified Username Field Change
18-01-15 10:44 han New Issue
18-01-15 11:22 Patrick Chevalley Assigned To => Patrick Chevalley
18-01-15 11:22 Patrick Chevalley Status new => feedback
18-01-15 11:22 Patrick Chevalley Target Version => 1.0
18-01-15 11:22 Patrick Chevalley Note Added: 0004378
18-01-15 12:38 han Note Added: 0004380
18-01-15 12:38 han Status feedback => assigned
18-01-15 12:43 han Note Edited: 0004380 View Revisions
18-01-15 12:55 han Note Edited: 0004380 View Revisions
18-02-14 02:18 han Note Added: 0004443
18-02-14 02:21 han Note Edited: 0004443 View Revisions
18-02-14 20:23 Patrick Chevalley Note Added: 0004444
18-02-16 17:27 Patrick Chevalley Status assigned => resolved
18-02-16 17:27 Patrick Chevalley Resolution open => fixed
18-02-16 17:27 Patrick Chevalley Note Added: 0004451