View Issue Details

IDProjectCategoryView StatusLast Update
0001891CCdciel[All Projects] Generalpublic18-01-31 22:07
ReporterSerg10Assigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001891: Edit FITS header
DescriptionDear Patrick please add in next version ability to edit the FITS header. Not enough entries GAIN OFFSET ISO or other. There is no possibility to edit the entry INSTRUME= 'Unknow CCD' / Instrument used for acquisition. Thank You.
TagsNo tags attached.

Activities

Patrick Chevalley

18-01-31 18:58

administrator   ~0004427

The instrument keyword is initialized from the ASCOM properties Name and SensorName.
At least Name is a mandatory property :
http://www.ascom-standards.org/Help/Developer/html/P_ASCOM_DeviceInterface_ICameraV2_Name.htm

So I not understand why you get the default string 'Unknow CCD'.
What Ascom driver do you use?
Do it pass the Ascom conformity check?

Gain/ISO will be added after I add the capture option to set them:
https://www.ap-i.net/mantis/view.php?id=1874

Serg10

18-01-31 20:52

reporter   ~0004428

Ascom platform version 6.2.0.0, 6.2.0.2774
ASCOM driver QHYCCD ver.3.3, camera QHY8L

Patrick Chevalley

18-01-31 22:07

administrator   ~0004429

I make some limited testing with the driver because I cannot connect a camera, but it look like the "Name" property is not implemented.

So in revision 775 I make a change to use the full driver name in this case, something like "QHY8L-StarSenseSci"
https://sourceforge.net/p/ccdciel/code/775/

As said in previous note I will add the gain information after I implement 0001874 because at the moment I not have the list of the available gain/iso stored in the program.

Please reopen this issue if other FITS keyword are missing or incorrect.

Issue History

Date Modified Username Field Change
18-01-31 17:48 Serg10 New Issue
18-01-31 18:58 Patrick Chevalley Assigned To => Patrick Chevalley
18-01-31 18:58 Patrick Chevalley Status new => feedback
18-01-31 18:58 Patrick Chevalley Target Version => 1.0
18-01-31 18:58 Patrick Chevalley Note Added: 0004427
18-01-31 20:52 Serg10 Note Added: 0004428
18-01-31 20:52 Serg10 Status feedback => assigned
18-01-31 22:07 Patrick Chevalley Status assigned => resolved
18-01-31 22:07 Patrick Chevalley Resolution open => fixed
18-01-31 22:07 Patrick Chevalley Note Added: 0004429