View Issue Details

IDProjectCategoryView StatusLast Update
0001901CCdciel[All Projects] Generalpublic18-02-21 21:24
ReporterSerg10Assigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001901: Sequence error
DescriptionHello, Patrick.
When the sequence is executed and the plan execution time is over for the current object, but the frame is not recognized Astrometry.net then fails. Efforts continue to identify the frame. The task for the new object does not run. For example, the sequence:

<?xml version="1.0" encoding="utf-8"?>
<CONFIG Version="2" ListName="20022018" TargetNum="5" RepeatCount="1">
  <Startup SeqStop="False" SeqStart="False" SeqStopAt="0:00:00" SeqStartAt="0:00:00" SeqStopTwilight="False" SeqStartTwilight="False"/>
  <Targets>
    <Target1 PA="-" RA=" 17h58m31s" Dec="+66d37m45s" Path="" Plan="2_600" Delay="1" EndSet="False" EndTime="1:00:00" Preview="False" FlatBinX="0" FlatBinY="0" FlatCount="0" StartRise="False" StartTime="23:00:00" ObjectName="NGC 6543" FlatFilters="" RepeatCount="1" UpdateCoord="True" PreviewExposure="1" InplaceAutofocus="True" AstrometryPointing="True"/>
    <Target2 PA="-" RA=" 20h35m13s" Dec="+60d12m54s" Path="" Plan="1_600" Delay="1" EndSet="False" EndTime="2:00:00" Preview="False" FlatBinX="0" FlatBinY="0" FlatCount="0" StartRise="False" StartTime="1:00:00" ObjectName="NGC 6946" FlatFilters="" RepeatCount="1" UpdateCoord="True" PreviewExposure="1" InplaceAutofocus="True" AstrometryPointing="True"/>
    <Target3 PA="-" RA=" 20h35m13s" Dec="+60d12m54s" Path="" Plan="2_1200" Delay="1" EndSet="False" EndTime="4:00:00" Preview="False" FlatBinX="0" FlatBinY="0" FlatCount="0" StartRise="False" StartTime="2:00:00" ObjectName="NGC 6946" FlatFilters="" RepeatCount="1" UpdateCoord="True" PreviewExposure="1" InplaceAutofocus="True" AstrometryPointing="True"/>
    <Target4 PA="-" RA=" 20h35m13s" Dec="+60d12m54s" Path="" Plan="1_600" Delay="1" EndSet="False" EndTime="5:00:00" Preview="False" FlatBinX="0" FlatBinY="0" FlatCount="0" StartRise="False" StartTime="4:00:00" ObjectName="NGC 6946" FlatFilters="" RepeatCount="1" UpdateCoord="True" PreviewExposure="1" InplaceAutofocus="True" AstrometryPointing="True"/>
    <Target5 PA="-" RA=" 21h43m21s" Dec="+66d11m43s" Path="" Plan="1_600" Delay="1" EndSet="False" EndTime="6:00:00" Preview="False" FlatBinX="0" FlatBinY="0" FlatCount="0" StartRise="False" StartTime="5:00:00" ObjectName="NGC 7129" FlatFilters="" RepeatCount="1" UpdateCoord="True" PreviewExposure="1" InplaceAutofocus="True" AstrometryPointing="True"/>
  </Targets>
</CONFIG>

At 4:00 and 5:00 did not run the task for the next object, as it was cloudy and the frame has not been solved. This led to the fact that the following objects began to be filmed at the wrong time, when they almost went out of sight.
TagsNo tags attached.

Activities

Serg10

18-02-21 16:33

reporter  

Log_20180220_175028.log (33,078 bytes)

Patrick Chevalley

18-02-21 17:49

administrator   ~0004473

Thank you to report this issue.

The origin of the problem is not related to the the plan execution time but to the fact you not checked "Run unattended" in the Sequence tab below the Start button.

If it is not checked the program expect you are looking at the screen to respond to error condition.
So after the plate solving fail at 01:04:10 it show a prompt on the screen if you want to retry the operation.
This prompt as a 2 minutes timeout before to continue as if you clicked Yes, this is to avoid to cancel something you can easily correct if you are just away to drink a coffee.
At 01:06:10 the timeout expire and it retry the plate solving infinitively.
At 1:59:59 the timer to kill the task is triggered but as we are still in the object initialization phase it do nothing.
It continue to try the plate solving until to cloud go out near 05:00.

I need to do the following changes to make the sequence more resilient:

 - fix the infinite plate solving by aborting the action anyway after 2 or 3 retry.
 - also kill the first slew when the end timer is triggered.
 - maybe it is also good to have the "Run unattended" checked by default when the program start.
 - all of this require a bit more information in the log to make clear what it do.

Patrick Chevalley

18-02-21 18:14

administrator   ~0004474

On another point from your log, the autofocus parameters look wrong as you start the first vcurve measurement almost at the focus position.
I suggest you install the last version 0.9.25 and use the new "focuser calibration" wizard.
https://www.ap-i.net/ccdciel/en/documentation/focuser_calibration

Serg10

18-02-21 20:35

reporter   ~0004475

Thank You.

Patrick Chevalley

18-02-21 21:24

administrator   ~0004476

This infinite retries problem is fixed in revision 815:
https://sourceforge.net/p/ccdciel/code/815/

I make new version 0.9.26 with this change soon.

Issue History

Date Modified Username Field Change
18-02-21 16:33 Serg10 New Issue
18-02-21 16:33 Serg10 File Added: Log_20180220_175028.log
18-02-21 17:49 Patrick Chevalley Assigned To => Patrick Chevalley
18-02-21 17:49 Patrick Chevalley Status new => assigned
18-02-21 17:49 Patrick Chevalley Target Version => 1.0
18-02-21 17:49 Patrick Chevalley Note Added: 0004473
18-02-21 18:14 Patrick Chevalley Note Added: 0004474
18-02-21 20:35 Serg10 Note Added: 0004475
18-02-21 21:24 Patrick Chevalley Status assigned => resolved
18-02-21 21:24 Patrick Chevalley Resolution open => fixed
18-02-21 21:24 Patrick Chevalley Note Added: 0004476