View Issue Details

IDProjectCategoryView StatusLast Update
0001907CCdciel[All Projects] Generalpublic18-02-25 23:28
ReporterThomas JaegerAssigned ToPatrick Chevalley 
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version 
Target Version1.0Fixed in Version 
Summary0001907: New focuser calibration tool
DescriptionI would simply give feedback to the new "focuser calibration tool". I let ccdciel control my almost new motorfocuser (DIY) with this tool. I had worked without problems.

Than I switched to v-curve learning and it failed, because the "v" was not centered. I manually focused and started v-curve learning again with success. I am going to reproduce it again. I think there is no bug. You have to do nothing.

After that, CCDCiel did M36, NGC2174 and M96 with v-curve autofocus without any problems. I like it.

I missed to do a screenshoot of a new appearing graphic showing the v-curve focusing. I did not saw it, because the sequence tab had window focus. If you are in the mood, some annotation at this graphic could be usefull.


Tagsautofocus, focuser calibration


Thomas Jaeger

18-02-24 12:09


Patrick Chevalley

18-02-24 14:18

administrator   ~0004493

Thank you very much for this informations, this is very useful for me to see how it work with a different focuser.

The v curve was not centered because when you close the wizard it use the wizard starting focuser position as the center point.
And we see on your second screenshot that the start point is not centered, it is near hfd=5.5 but on the left there is a point with hfd=4.

I can improve that to use the measured minimum hfd position instead, the program as all the necessary data and this can help to have a better first measurement.

I already do some improvement in the graph show when focusing. Now it has axis label, show values at the mouse cursor position and a button let you pin the graph so it not close when the focus is completed.

Thomas Jaeger

18-02-24 15:58

reporter   ~0004494

That's great. Have a short look at the last three images I did with CCDciel.

M36-RGB_DBE_HTSTR_PPC.jpg (315,305 bytes)
M36-RGB_DBE_HTSTR_PPC.jpg (315,305 bytes)
NGC2174-PS-v1-HOO.jpg (272,302 bytes)
NGC2174-PS-v1-HOO.jpg (272,302 bytes)

Patrick Chevalley

18-02-24 23:24

administrator   ~0004497

Congratulation for this nice images!
This is good to see how all this curves and numbers help to get fine images.

You can see my last image here
But I have to open a bug report for the weather we get this winter :(

Patrick Chevalley

18-02-25 23:28

administrator   ~0004503

I make this improvement in revision 841. With this change your first Vcurve must have been fine.

Issue History

Date Modified Username Field Change
18-02-24 12:09 Thomas Jaeger New Issue
18-02-24 12:09 Thomas Jaeger File Added: Bildschirmfoto vom 2018-02-21 19-53-08.png
18-02-24 12:09 Thomas Jaeger File Added: Bildschirmfoto vom 2018-02-21 19-54-18.png
18-02-24 12:09 Thomas Jaeger File Added: Bildschirmfoto vom 2018-02-21 19-54-27.png
18-02-24 12:09 Thomas Jaeger Tag Attached: autofocus
18-02-24 12:09 Thomas Jaeger Tag Attached: focuser calibration
18-02-24 14:18 Patrick Chevalley Assigned To => Patrick Chevalley
18-02-24 14:18 Patrick Chevalley Status new => assigned
18-02-24 14:18 Patrick Chevalley Target Version => 1.0
18-02-24 14:18 Patrick Chevalley Note Added: 0004493
18-02-24 15:58 Thomas Jaeger File Added: M1-HaOIIIOIII---Ha-als-Lum.jpg
18-02-24 15:58 Thomas Jaeger File Added: M36-RGB_DBE_HTSTR_PPC.jpg
18-02-24 15:58 Thomas Jaeger File Added: NGC2174-PS-v1-HOO.jpg
18-02-24 15:58 Thomas Jaeger Note Added: 0004494
18-02-24 23:24 Patrick Chevalley Note Added: 0004497
18-02-25 23:28 Patrick Chevalley Status assigned => resolved
18-02-25 23:28 Patrick Chevalley Resolution open => fixed
18-02-25 23:28 Patrick Chevalley Note Added: 0004503