View Issue Details

IDProjectCategoryView StatusLast Update
0001914CCdciel[All Projects] Generalpublic18-03-24 15:44
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001914: V curve learning. Too big step initialy
DescriptionI downloaded and compiled the latest version today . The V-curve learning behaves strange. Pos 25800 is too far off.

2018-03-18T22:11:20.215 Start learning V curve
2018-03-18T22:11:20.215 From: 28700 to 31200 by 294
2018-03-18T22:11:20.215 Focuser temperature: -2.6
2018-03-18T22:11:20.761 ASCOM.USB_Focus.Focuser: Focuser move to 28700 - 400 Backlash compensation
2018-03-18T22:11:38.919 ASCOM.USB_Focus.Focuser: Focuser move to 28700
2018-03-18T22:11:55.143 Take control exposure for 15.0 seconds
2018-03-18T22:11:56.079 Camera frame x=970 y=672 width=404 height=400
2018-03-18T22:12:12.927 Measurement 1 hfd:48.0 peak:332.2 snr:10.7
2018-03-18T22:12:12.927 Vcurve n0 pos:25800 hfd:48.0 peak:332.2 snr:10.7 <=================Strange !!!!!!!!!!!!!!!!!!!
2018-03-18T22:12:12.927 ASCOM.USB_Focus.Focuser: Focuser move to 28994
2018-03-18T22:12:33.316 Take control exposure for 15.0 seconds
2018-03-18T22:12:50.648 Measurement 1 hfd:22.3 peak:1384.4 snr:30.9
2018-03-18T22:12:50.991 Vcurve n1 pos:28994 hfd:22.3 peak:1384.4 snr:30.9
2018-03-18T22:12:51.007 ASCOM.USB_Focus.Focuser: Focuser move to 29288
2018-03-18T22:12:54.189 Take control exposure for 15.0 seconds
2018-03-18T22:13:11.380 Measurement 1 hfd:19.5 peak:2096.0 snr:40.2
2018-03-18T22:13:11.380 Vcurve n2 pos:29288 hfd:19.5 peak:2096.0 snr:40.2
2018-03-18T22:13:11.380 ASCOM.USB_Focus.Focuser: Focuser move to 29582
2018-03-18T22:13:14.251 Take control exposure for 15.0 seconds
2018-03-18T22:13:31.114 Measurement 1 hfd:17.1 peak:3169.4 snr:51.5
2018-03-18T22:13:31.114 Vcurve n3 pos:29582 hfd:17.1 peak:3169.4 snr:51.5
2018-03-18T22:13:31.114 ASCOM.USB_Focus.Focuser: Focuser move to 29876
2018-03-18T22:13:34.187 Take control exposure for 15.0 seconds
2018-03-18T22:13:51.316 Measurement 1 hfd:14.4 peak:4865.7 snr:65.7
2018-03-18T22:13:51.316 Vcurve n4 pos:29876 hfd:14.4 peak:4865.7 snr:65.7
2018-03-18T22:13:51.316 ASCOM.USB_Focus.Focuser: Focuser move to 30170
2018-03-18T22:13:54.218 Take control exposure for 15.0 seconds
2018-03-18T22:14:11.518 Measurement 1 hfd:11.9 peak:8305.3 snr:87.9
2018-03-18T22:14:11.518 Vcurve n5 pos:30170 hfd:11.9 peak:8305.3 snr:87.9
2018-03-18T22:14:11.534 ASCOM.USB_Focus.Focuser: Focuser move to 30464
2018-03-18T22:14:14.513 Take control exposure for 15.0 seconds
2018-03-18T22:14:32.251 Measurement 1 hfd:9.7 peak:14569.4 snr:118.2
2018-03-18T22:14:32.251 Vcurve n6 pos:30464 hfd:9.7 peak:14569.4 snr:118.2
2018-03-18T22:14:32.266 ASCOM.USB_Focus.Focuser: Focuser move to 30758
2018-03-18T22:14:35.246 Take control exposure for 15.0 seconds
2018-03-18T22:14:52.624 Measurement 1 hfd:7.0 peak:37113.3 snr:191.1
2018-03-18T22:14:52.624 Vcurve n7 pos:30758 hfd:7.0 peak:37113.3 snr:191.1
2018-03-18T22:14:52.624 ASCOM.USB_Focus.Focuser: Focuser move to 31052
2018-03-18T22:14:55.619 Take control exposure for 15.0 seconds
2018-03-18T22:15:13.076 Measurement 1 hfd:5.0 peak:62349.5 snr:248.5
2018-03-18T22:15:13.325 Vcurve n8 pos:31052 hfd:5.0 peak:62349.5 snr:248.5
2018-03-18T22:15:13.325 ASCOM.USB_Focus.Focuser: Focuser move to 31346
2018-03-18T22:15:16.492 Take control exposure for 15.0 seconds
2018-03-18T22:15:33.933 Measurement 1 hfd:3.2 peak:65193.9 snr:254.1
2018-03-18T22:15:33.933 Vcurve n9 pos:31346 hfd:3.2 peak:65193.9 snr:254.1
2018-03-18T22:15:33.933 ASCOM.USB_Focus.Focuser: Focuser move to 31640
2018-03-18T22:15:36.803 Take control exposure for 15.0 seconds
2018-03-18T22:15:54.525 Measurement 1 hfd:2.7 peak:65193.0 snr:254.1
2018-03-18T22:15:54.525 Vcurve n10 pos:31640 hfd:2.7 peak:65193.0 snr:254.1
2018-03-18T22:15:54.525 ASCOM.USB_Focus.Focuser: Focuser move to 31934
2018-03-18T22:15:57.427 Take control exposure for 15.0 seconds
2018-03-18T22:16:14.914 Measurement 1 hfd:4.0 peak:43525.8 snr:207.2
2018-03-18T22:16:15.460 Vcurve n11 pos:31934 hfd:4.0 peak:43525.8 snr:207.2
2018-03-18T22:16:15.476 ASCOM.USB_Focus.Focuser: Focuser move to 32228
2018-03-18T22:16:18.565 Take control exposure for 15.0 seconds
2018-03-18T22:16:35.537 Measurement 1 hfd:6.4 peak:19969.0 snr:139.2
2018-03-18T22:16:35.537 Vcurve n12 pos:32228 hfd:6.4 peak:19969.0 snr:139.2
2018-03-18T22:16:35.537 ASCOM.USB_Focus.Focuser: Focuser move to 32522
2018-03-18T22:16:38.611 Take control exposure for 15.0 seconds
2018-03-18T22:16:55.895 Measurement 1 hfd:8.8 peak:11846.2 snr:106.1
2018-03-18T22:16:55.895 Vcurve n13 pos:32522 hfd:8.8 peak:11846.2 snr:106.1
2018-03-18T22:16:55.895 ASCOM.USB_Focus.Focuser: Focuser move to 32816
2018-03-18T22:16:58.797 Take control exposure for 15.0 seconds
2018-03-18T22:17:16.300 Measurement 1 hfd:11.6 peak:6396.3 snr:76.3
2018-03-18T22:17:16.316 Vcurve n14 pos:32816 hfd:11.6 peak:6396.3 snr:76.3
2018-03-18T22:17:16.316 ASCOM.USB_Focus.Focuser: Focuser move to 33110
2018-03-18T22:17:20.044 Take control exposure for 15.0 seconds
2018-03-18T22:17:37.345 Measurement 1 hfd:14.1 peak:3782.2 snr:57.0
2018-03-18T22:17:37.657 Vcurve n15 pos:33110 hfd:14.1 peak:3782.2 snr:57.0
2018-03-18T22:17:37.657 ASCOM.USB_Focus.Focuser: Focuser move to 33404
2018-03-18T22:17:40.745 Take control exposure for 15.0 seconds
2018-03-18T22:17:57.937 Measurement 1 hfd:16.7 peak:2781.9 snr:47.7
2018-03-18T22:17:57.952 Vcurve n16 pos:33404 hfd:16.7 peak:2781.9 snr:47.7
2018-03-18T22:17:57.952 ASCOM.USB_Focus.Focuser: Focuser move to 33698
2018-03-18T22:18:00.885 Take control exposure for 15.0 seconds



TagsNo tags attached.

Activities

han

18-03-18 22:49

reporter  

focus4.png (166,443 bytes)
focus4.png (166,443 bytes)

han

18-03-18 23:34

reporter   ~0004565

- I doesn't happen if I reduce the range to 2000 (equals about HFD=17) instead of 2500???
- An other problem is that after V-learning it doesn't go to best focus position as in previous versions.

Patrick Chevalley

18-03-19 15:39

administrator   ~0004571

To summarize the first steps in log:
- ccdciel ask the focuser to go to 28700.
- on first measurement the focuser report it is at 25800 and this look right regarding the HFD value.
- ccdciel ask to go to 28700+294 = 28994
- second measurement the focuser report it is at 28994
- all other measurement are right at the position

Is this reproducible with the 2500 range?
If yes we may need the detailed ASCOM trace to see what the focuser driver do. You can activate the trace using the Ascom diagnostics.

It not go to the best focus position in case of error during the measurement or if the fit quality is too low. In this case it return to the starting position.

Also note that Vcurve learning code as not changed recently, except formating of message for the translations.


han

18-03-20 21:52

reporter   ~0004587

I didn't switch on Ascom trace, but I had again a problem this night. Focusing was working well the first time The second time It was far off due to huge slippage offset. No idea where it came from but even setting slippage back to zero could not fix it. Returned to an older CCDciel version for the moment.

I had the same large slippage jump two nights ago. Could be the cause of the problem.

Patrick Chevalley

18-03-23 11:25

administrator   ~0004607

You have a old version that not show this problem? Is it 0.9.29 or an older one?

You can try in daytime to move the focuser by 294 or 9*294 to see if you can reproduce this error. Even without ascom trace it can be good if you can compare the position reported in the driver window.

Looking at you screen shot again it look like the first movement was done two time but without a message from the focuser interface reporting this movement.

han

18-03-23 23:07

reporter   ~0004615

This night I tested the latest code. Same problem. The V-curve learning goes wrong. I will send all log files including ASCOM trace by email. Tomorrow, I'm away. The old version is from maybe 6 weeks older doesn't have this problem.

3.png (12,807 bytes)
3.png (12,807 bytes)

Patrick Chevalley

18-03-24 15:43

administrator   ~0004621

I upload here your ASCOM serial trace for future reference.
It show why this specific driver as this problem because it set the IsMoving property to false before it know the new position and is capable to set a new move correctly.

This must be solved by adding a small delay before the last backlash move:
https://github.com/pchev/ccdciel/commit/87236530aac69ad9959bbeff812d421fe037cbf5

ASCOM.Serial.2234.561910.txt (3,235,350 bytes)

Issue History

Date Modified Username Field Change
18-03-18 22:49 han New Issue
18-03-18 22:49 han File Added: focus4.png
18-03-18 23:34 han Note Added: 0004565
18-03-19 15:39 Patrick Chevalley Assigned To => Patrick Chevalley
18-03-19 15:39 Patrick Chevalley Status new => assigned
18-03-19 15:39 Patrick Chevalley Note Added: 0004571
18-03-20 21:52 han Note Added: 0004587
18-03-23 11:25 Patrick Chevalley Note Added: 0004607
18-03-23 23:07 han File Added: 3.png
18-03-23 23:07 han Note Added: 0004615
18-03-24 15:43 Patrick Chevalley File Added: ASCOM.Serial.2234.561910.txt
18-03-24 15:43 Patrick Chevalley Note Added: 0004621
18-03-24 15:44 Patrick Chevalley Status assigned => resolved
18-03-24 15:44 Patrick Chevalley Resolution open => fixed
18-03-24 15:44 Patrick Chevalley Target Version => 1.0