View Issue Details

IDProjectCategoryView StatusLast Update
0001923CCdciel[All Projects] Generalpublic18-09-23 15:00
Reportertango13Assigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001923: Dithering settling
DescriptionHi Patrick,
it seems that ccdciel doesn't wait correctly for the guider (PHD2 in this case) to settle after dithering.
As you can see from this log excerpt, the exposure is started right after the dithering command is sent, without waiting for the settling to complete.

2018-04-06T22:53:04.147 Dithering...
2018-04-06T22:53:04.269 Autoguider: Guiding Dithered
2018-04-06T22:53:04.609 Autoguider: Settling
2018-04-06T22:53:05.444 Starting Light exposure 9 for 60 seconds
2018-04-06T22:53:27.347 Autoguider: Settle Done
2018-04-06T22:53:27.421 Autoguider: Guiding
2018-04-06T22:54:12.555 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_9.fits
2018-04-06T22:54:12.703 Starting Light exposure 10 for 60 seconds
2018-04-06T22:55:19.705 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_10.fits
2018-04-06T22:55:19.749 Starting Light exposure 11 for 60 seconds
2018-04-06T22:56:26.641 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_11.fits
2018-04-06T22:56:26.683 Starting Light exposure 12 for 60 seconds
2018-04-06T22:57:33.734 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_12.fits
2018-04-06T22:57:33.768 Dithering...
2018-04-06T22:57:33.905 Autoguider: Guiding Dithered
2018-04-06T22:57:35.055 Starting Light exposure 13 for 60 seconds
2018-04-06T22:57:35.737 Autoguider: Settling
2018-04-06T22:57:48.070 Autoguider: Settle Done
2018-04-06T22:57:48.140 Autoguider: Guiding
2018-04-06T22:58:42.957 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_13.fits
2018-04-06T22:58:42.994 Starting Light exposure 14 for 60 seconds
2018-04-06T22:59:50.096 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_14.fits
2018-04-06T22:59:50.612 Starting Light exposure 15 for 60 seconds
2018-04-06T23:00:58.324 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_15.fits
2018-04-06T23:00:58.340 Starting Light exposure 16 for 60 seconds
2018-04-06T23:02:06.304 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_16.fits
2018-04-06T23:02:06.318 Dithering...
2018-04-06T23:02:06.760 Autoguider: Guiding Dithered
2018-04-06T23:02:07.507 Starting Light exposure 17 for 60 seconds
2018-04-06T23:02:08.173 Autoguider: Settling
2018-04-06T23:02:37.514 Autoguider: Error: timed-out waiting for guider to settle
2018-04-06T23:02:37.523 Autoguider: Guiding
2018-04-06T23:03:14.255 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_17.fits
2018-04-06T23:03:14.270 Starting Light exposure 18 for 60 seconds
2018-04-06T23:04:21.228 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_18.fits
2018-04-06T23:04:21.287 Starting Light exposure 19 for 60 seconds
2018-04-06T23:05:29.511 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_19.fits
2018-04-06T23:05:29.527 Starting Light exposure 20 for 60 seconds
2018-04-06T23:06:36.877 Saved file /home/piero/images/M51/M51_Red_60s_1x1_200_20.fits

Is this a bug or am I doing something wrong in the guiding configuration? I left the "settle tolerance" parameters in ccdciel configuration at their defaults.
Thank you.
TagsNo tags attached.

Activities

Patrick Chevalley

18-04-07 11:08

administrator   ~0004656

Can you give me the exact version of phd2 and ccdciel you use (show on top of the log file).

The main problem with ccdciel not waiting for settling is not because of the parameters but because of the order it receive the messages from phd2, or some other bug.

The second dither error with the message "Error: timed-out waiting for guider to settle" is because of the parameters. You must not keep the default but adjust them to be realistic with your guide exposure time and the guiding error RMS.

But for me it work correctly and wait for phd2 to settle, see a test log below:

2018-04-07T10:48:42.852 Saved file /home/pch/Capture/test_L_10.fits
2018-04-07T10:48:42.854 Dithering...
2018-04-07T10:48:42.958 Autoguider: Guiding Dithered
2018-04-07T10:48:43.468 Autoguider: Settling
2018-04-07T10:48:52.355 Autoguider: Settle Done
2018-04-07T10:48:53.059 Autoguider: Guiding
2018-04-07T10:48:54.075 Starting Light exposure 2 for 2 seconds

Patrick Chevalley

18-04-07 14:46

administrator   ~0004657

I can partially reproduce the problem when connecting to phd2 running on a remote Rpi with slow wifi.
In this case some message arrive out of order and can produce this error.

This is fixed by https://github.com/pchev/ccdciel/commit/f25467cbc22db6a354e283e4650c15cba1e29580

Can you compile the source for testing? or tell me for which system/architecture you need a test version.

tango13

18-04-07 15:17

reporter   ~0004658

I use all software on a single Odroid XU4 arm miniPC, so I have no remote connection between phd2 and ccdciel.
The only remote (wifi) connection is to my tablet from which I manage the apps, but that should have no effect on this malfunction.
I was using phd2 compiled from git commit f8077f558 of March 3 and ccdciel (again, compiled from git) version beta 0.9.30-947-f2b813f.
Thank you for your fix, I'll compile it right away and I hope to test it as soon as possible.

tango13

18-04-08 16:56

reporter   ~0004659

Hi Patrick,
a little off-topic just to show you what I achieved last night with your invaluable tools ccdciel, skychart and indistarter (and phd2, which you collaborate with).
The picture is not perfect (oval stars, rough processing and other problems which are in no way ccdciel fault) but I just wanted to thank you for the great joy you give us astro enthusiasts with your precious work and dedication.
Pierluigi

M51.jpg (310,495 bytes)
M51.jpg (310,495 bytes)

Patrick Chevalley

18-04-09 16:22

administrator   ~0004660

Hi Pierluigi,
Nice image, congratulation!
Thank you for your message, it is good to know that all this tools really help for our hobby.

Patrick Chevalley

18-04-28 20:18

administrator   ~0004739

I close the issue for now but please reopen if you still encounter this problem.

tango13

18-07-14 09:31

reporter   ~0004822

Hi Patrick,
I'm sorry I have to reopen this issue but yesterday I finally had a wonderful night under the stars and had the chance to test everything.
All worked perfectly (CCDciel, Skychart, INDIstarter and PHD2) but the dithering feature: once again CCDciel didn't wait for dithering to settle and started a new capture right away, so the first frames after dithering were all ruined.
When I realized this, I started dithering manually and I noticed that PHD2 informed CCDciel correctly when settling was terminated after a few seconds.
I think I should have some logging, should you need it.
And BTW, in the meantime I moved my computer from an ARM mini PC to an Intel x86 64 bit one, but again there's no remote connection between CCDciel and PHD2, they all stay on the same PC.
Thank you.

tango13

18-07-14 10:42

reporter   ~0004823

It seems there's still the same message mixing as before:

2018-07-13T23:35:42.775 1: Saved file /home/piero/images/cave/cave_Lum_120s_1x1_13.fits
2018-07-13T23:35:42.851 1: Dithering...
2018-07-13T23:35:42.978 2: Autoguider: Guiding Dithered
2018-07-13T23:35:43.866 2: Autoguider: Settling
2018-07-13T23:35:44.100 1: Starting Light exposure 13 for 120 seconds
2018-07-13T23:35:52.837 2: Autoguider: Guiding
2018-07-13T23:37:51.172 1: Saved file /home/piero/images/cave/cave_Lum_120s_1x1_14.fits
2018-07-13T23:37:51.198 1: Starting Light exposure 14 for 120 seconds
2018-07-13T23:39:58.054 1: Saved file /home/piero/images/cave/cave_Lum_120s_1x1_15.fits
2018-07-13T23:39:58.086 1: Starting Light exposure 15 for 120 seconds
2018-07-13T23:42:04.826 1: Saved file /home/piero/images/cave/cave_Lum_120s_1x1_16.fits
2018-07-13T23:42:04.875 1: Dithering...
2018-07-13T23:42:04.996 2: Autoguider: Guiding Dithered
2018-07-13T23:42:05.831 2: Autoguider: Settling
2018-07-13T23:42:06.062 1: Starting Light exposure 16 for 120 seconds
2018-07-13T23:42:34.940 2: Autoguider: Settle Done
2018-07-13T23:42:34.945 2: Autoguider: Guiding
2018-07-13T23:44:12.918 1: Saved file /home/piero/images/cave/cave_Lum_120s_1x1_17.fits
2018-07-13T23:44:12.983 1: Starting Light exposure 17 for 120 seconds
2018-07-13T23:46:20.788 1: Saved file /home/piero/images/cave/cave_Lum_120s_1x1_18.fits
2018-07-13T23:46:20.818 1: Starting Light exposure 18 for 120 seconds
2018-07-13T23:48:28.017 1: Saved file /home/piero/images/cave/cave_Lum_120s_1x1_19.fits
2018-07-13T23:48:28.057 1: Dithering...
2018-07-13T23:48:28.280 2: Autoguider: Guiding Dithered
2018-07-13T23:48:29.220 1: Starting Light exposure 19 for 120 seconds
2018-07-13T23:48:29.250 2: Autoguider: Settling
2018-07-13T23:48:52.675 2: Autoguider: Settle Done
2018-07-13T23:48:52.682 2: Autoguider: Guiding
2018-07-13T23:50:35.982 1: Saved file /home/piero/images/cave/cave_Lum_120s_1x1_20.fits
2018-07-13T23:50:36.032 1: Starting Light exposure 20 for 120 seconds
2018-07-13T23:52:42.846 1: Saved file /home/piero/images/cave/cave_Lum_120s_1x1_21.fits
2018-07-13T23:52:42.874 1: Starting Light exposure 21 for 120 seconds
2018-07-13T23:54:50.237 1: Saved file /home/piero/images/cave/cave_Lum_120s_1x1_22.fits

Thank you

Thomas Richter

18-07-17 16:28

reporter   ~0004824

Hi Patrick, hi Pierluigi,

I had the same problem with settling on Win10. But it were solved after updating my PHD Guiding from version 2.6.4 to 2.6.5.
CCDciel Version: 0.9.41-1138-fa3bf90

Best regards
Thomas

tango13

18-07-17 22:50

reporter   ~0004825

Hi Thomas, thank you very much for your suggestion.
I'll upgrade my software and let you know.

Ciao,
Pierluigi

Thomas Richter

18-07-19 09:02

reporter   ~0004826

Hi Pierluigi,

sorry, the issue is still present. Yesterday I tested it again with with PHD Guidung 2.6.5 and CCDciel 0.9.41-1138.
I did not change the configuration. And PHD2 and CCDciel runs on the same Notebook.
CCDciel does not wait until phd completes the settling. My logfile looks like yours:

Dithering...
Autoguider: Guiding Dithered
Starting Light exposure 10 for 600 seconds
Autoguider: Settling
Autoguider: Settle Done
Autoguider: Guiding
...

Ciao,
Thomas

tango13

18-07-19 14:35

reporter   ~0004827

Thank you Thomas.
This morning I also checked the PHD version installed on my PC and, like yours, it is up-to-date to version 2.6.5.
My CCDciel is at version 0.9.40

Thomas Jaeger

18-09-15 22:01

reporter   ~0004839

Hello,
I was aware of this issue, but it never happened with my setup...until tonight. I was imaging Sh2-112 and noticed that CCD Ciel starts imaging before PHD was starting guiding. See snipplet. I restarted CCD and the issue was gone. There might be a bug.
Thomas

2018-09-15T21:37:19.599 1: Saved file /home/starhopper/CCD/sh2-112-SHO-Gain111/Light/Sh2-112_OIII_111_240s_20180915_193719.fits
2018-09-15T21:37:19.611 1: Dithering...
2018-09-15T21:37:19.739 2: Autoguider: Guiding Dithered
2018-09-15T21:37:20.565 2: Autoguider: Settling
2018-09-15T21:37:20.790 1: Starting Light exposure 9 for 240 seconds
2018-09-15T21:37:28.045 2: Autoguider: Settle Done
2018-09-15T21:37:28.047 2: Autoguider: Guiding
2018-09-15T21:41:34.846 1: Saved file /home/starhopper/CCD/sh2-112-SHO-Gain111/Light/Sh2-112_OIII_111_240s_20180915_194134.fits
2018-09-15T21:41:34.863 1: Dithering...
2018-09-15T21:41:34.997 2: Autoguider: Guiding Dithered
2018-09-15T21:41:35.618 2: Autoguider: Settling
2018-09-15T21:41:36.057 1: Starting Light exposure 10 for 240 seconds

Log_20180915_185606.log (49,907 bytes)

Serg10

18-09-18 20:22

reporter   ~0004861

Last edited: 18-09-18 20:23

View 2 revisions

In PHD2 Guiding 2.6.5 if not select "Fast recenter after calibration or dither", then CCDCiel worck correct.
Else CCDCiel not wait when settling is OK.

Patrick Chevalley

18-09-18 21:46

administrator   ~0004862

Thank you for all the information here!
I think I found the error in CCDciel, it is not related to a PHD2 setting but the problem occur after you click the Stop button in the Capture box.

Can you test the following and report if you get the same result as me:

- start CCDciel
- connect the equipment and phd2
- open the Capture tool
- set a few short exposure with Dither every 1, do not set auto-focus
- click Start
- check that the second exposure is waiting correctly for the dithering
- click Stop
- wait everything stabilize
- click Start
- now the second exposure no more wait for dithering

The origin of the problem is when I add a function to cancel an auto-focus operation when you click the Stop button.

The simple fix:
https://github.com/pchev/ccdciel/commit/36e90322b91609e4f58ace346f3577cbbe49276e

Thomas Jaeger

18-09-19 20:08

reporter   ~0004869

Hi have tested it. You are right.
See log:

Log_20180919_200321.log (2,941 bytes)

Patrick Chevalley

18-09-23 15:00

administrator   ~0004880

Thank you.

So this must be fixed by this last change.

Issue History

Date Modified Username Field Change
18-04-07 09:41 tango13 New Issue
18-04-07 11:08 Patrick Chevalley Status new => feedback
18-04-07 11:08 Patrick Chevalley Note Added: 0004656
18-04-07 14:46 Patrick Chevalley Note Added: 0004657
18-04-07 15:17 tango13 Note Added: 0004658
18-04-07 15:17 tango13 Status feedback => new
18-04-08 16:56 tango13 File Added: M51.jpg
18-04-08 16:56 tango13 Note Added: 0004659
18-04-09 16:22 Patrick Chevalley Note Added: 0004660
18-04-28 20:18 Patrick Chevalley Status new => resolved
18-04-28 20:18 Patrick Chevalley Resolution open => fixed
18-04-28 20:18 Patrick Chevalley Target Version => 1.0
18-04-28 20:18 Patrick Chevalley Note Added: 0004739
18-07-14 09:31 tango13 Status resolved => new
18-07-14 09:31 tango13 Resolution fixed => reopened
18-07-14 09:31 tango13 Note Added: 0004822
18-07-14 10:42 tango13 Note Added: 0004823
18-07-17 16:28 Thomas Richter Note Added: 0004824
18-07-17 22:50 tango13 Note Added: 0004825
18-07-19 09:02 Thomas Richter Note Added: 0004826
18-07-19 14:35 tango13 Note Added: 0004827
18-09-15 22:01 Thomas Jaeger File Added: Log_20180915_185606.log
18-09-15 22:01 Thomas Jaeger Note Added: 0004839
18-09-18 15:09 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-18 15:09 Patrick Chevalley Status new => assigned
18-09-18 20:22 Serg10 Note Added: 0004861
18-09-18 20:23 Serg10 Note Edited: 0004861 View Revisions
18-09-18 21:46 Patrick Chevalley Status assigned => feedback
18-09-18 21:46 Patrick Chevalley Note Added: 0004862
18-09-19 20:08 Thomas Jaeger File Added: Log_20180919_200321.log
18-09-19 20:08 Thomas Jaeger Note Added: 0004869
18-09-23 15:00 Patrick Chevalley Status feedback => resolved
18-09-23 15:00 Patrick Chevalley Resolution reopened => fixed
18-09-23 15:00 Patrick Chevalley Note Added: 0004880