View Issue Details

IDProjectCategoryView StatusLast Update
0001924CCdciel[All Projects] Generalpublic18-04-12 15:10
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritynoneSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLinux Mint OS Version18.3
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001924: Cannot read star annotation
DescriptionThis has a very low priority.

I cannot read star annotation. The small red charakters are unreadable at my notebook. The attachment is a 100% screen capture.

TagsNo tags attached.

Activities

Thomas Jaeger

18-04-09 18:27

reporter  

CCDCiel Star Annotation.jpg (557,054 bytes)
CCDCiel Star Annotation.jpg (557,054 bytes)

Patrick Chevalley

18-04-09 21:45

administrator   ~0004664

You can improve the reading by making the image background darker. Try 96 or 98 instead of 95.

The text is small because it is draw at the scale of the full image for a 1:1 zoom.
The next version include a magnifier at the mouse position that help to read the value with the default zoom.
Tell me if this is OK after you try with this version.

Thomas Jaeger

18-04-10 19:44

reporter   ~0004670

You are absolutely right. Zoom-in is the solution. I the new version the magnifier works, but zoom-in is better. Sorry for making this supid ticket, close and forget it.
Yellow is a better color than red in my opinion.
Thomas

han

18-04-11 01:43

reporter   ~0004673

I agree with Thomas it is sometimes difficult to read with a bright background. The magnifier will help. Maybe the font size should be partly adapted to the displayed window size such as 1440x 900 pixels for some basic laptops. Large imaging sensors will produce currently a very small font on a small laptop screen.

A yellowish or orange color could be an improvement. I have the impression that at least my eyes focus poorer on a red color font. I choose initially the red color for night vision reasons and people using a red screen front but readability is not ideal.

han

18-04-11 10:09

reporter   ~0004675

Last edited: 18-04-11 10:10

View 2 revisions

Most logical would be to follow the operating system font size. So if a user has a small screen and select in the operating system a large system font/theme with large fonts, the CCDciel menus will follow. So why not the annotation font size?

Orange as color?

Patrick Chevalley

18-04-11 11:06

administrator   ~0004676

At the moment this annotation are written to the full image, not in the displayed zoomed part.
Maybe it is good to change that to move the drawing in the paint event, the same as the green selection box, this way it show the same text size independently of the zoom factor.
This just need to store the star list with hfd for later drawing.

han

18-04-11 12:24

reporter   ~0004682

Last edited: 18-04-11 13:05

View 3 revisions

Moving it to the paint event complicates everything. For the square boxes I added in ASTAP an adaption to increase the line thickness as follows:

   image1.Canvas.Pen.width := round(1+height2/image1.height);{thickness lines}

So if the image is three times larger then the window the line thickness is 4, but it looks like thickness 1 unless you zoom in. This worked fine for me.

Something similar could be applied for the font:

  image1.Canvas.font.size:=round(8*height2/image1.height);{adapt font to image dimensions}

Where height2 is the original image height and image1.height the height of the scaled image. For the user the font size always looks like size 8 independed of the image dimensions unless he zooms in. Following the system font size was no success.

I tested colors orange ($0010FF), yellow ($00FFFF) and red font ($0000FF). I must agree with Thomas that for small fonts the yellow was best readable. I guess the focusing of the eye for the green part of yellow is better and two yellow colors green&red emit together more light then one red color. The only thing it looks fancy.

Patrick Chevalley

18-04-11 15:23

administrator  

new_star_mark.jpg (328,158 bytes)
new_star_mark.jpg (328,158 bytes)

Patrick Chevalley

18-04-11 15:23

administrator   ~0004684

I try to increase the line width and the font size according to the CCD/screen ratio but this make the image very bloated and difficult to read if the CCD is big and the screen small.

So I implemented the change to draw in the image zoomed for the screen.
In fact this simplify the code a bit because the box drawing was done in two places, for image inspection and for autofocus, now this is in a single place, when the zoomed image is draw.
As the star list is already stored in the fits structure I only have to add global variable for the tilt trapeze.

This make the line with and the font size constant with any zoom level. The font size is adjusted for the screen DPI.
The yellow color is pleasant and more easy to read.

As a consequence the magnifier window no more show the boxes as they are not draw to the base image. No necessarily an inconvenience as this allow to see the original image under the lines.
But if this is really required I can add the drawing of the lines to the magnifier the same way as for the main window.

Also the boxes are no more cleared if you change the image display setting in the Visualization tool. Using the right click menu "Image cleanup" remove them.

The code change:
https://github.com/pchev/ccdciel/commit/89de1ce2fc8dc4f45a3d689383e3dd422bdf841c

See screen shot of autofocus with the INDI simulator.

han

18-04-11 16:32

reporter   ~0004687

très bien!

Now only a fix for the double detection.

Patrick Chevalley

18-04-12 15:10

administrator   ~0004699

This can be closed now.

Issue History

Date Modified Username Field Change
18-04-09 18:27 Thomas Jaeger New Issue
18-04-09 18:27 Thomas Jaeger File Added: CCDCiel Star Annotation.jpg
18-04-09 21:45 Patrick Chevalley Assigned To => Patrick Chevalley
18-04-09 21:45 Patrick Chevalley Status new => feedback
18-04-09 21:45 Patrick Chevalley Target Version => 1.0
18-04-09 21:45 Patrick Chevalley Note Added: 0004664
18-04-10 19:44 Thomas Jaeger Note Added: 0004670
18-04-10 19:44 Thomas Jaeger Status feedback => assigned
18-04-11 01:43 han Note Added: 0004673
18-04-11 10:09 han Note Added: 0004675
18-04-11 10:10 han Note Edited: 0004675 View Revisions
18-04-11 11:06 Patrick Chevalley Note Added: 0004676
18-04-11 12:24 han Note Added: 0004682
18-04-11 13:03 han Note Edited: 0004682 View Revisions
18-04-11 13:05 han Note Edited: 0004682 View Revisions
18-04-11 15:23 Patrick Chevalley File Added: new_star_mark.jpg
18-04-11 15:23 Patrick Chevalley Note Added: 0004684
18-04-11 16:32 han Note Added: 0004687
18-04-12 15:10 Patrick Chevalley Status assigned => resolved
18-04-12 15:10 Patrick Chevalley Resolution open => fixed
18-04-12 15:10 Patrick Chevalley Note Added: 0004699