View Issue Details

IDProjectCategoryView StatusLast Update
0001926CCdciel[All Projects] Generalpublic18-04-28 20:16
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001926: Automatic flat generation stopped because of autoguiding
DescriptionThere is a full log in the attachment.
At the begin of the session I did flats with a sequence. The sequence stopped with an autoguiding error, but
autoguiding is not needed with flats. In my case not possible, because I got an off-axis guider. Is it a user failure?

In short:
2018-04-07T21:20:16.329 Saved file /home/starhopper/CCD/NGC4631/Flat/Flat_G_20180407_192016.fits
2018-04-07T21:20:16.344 Starting Flat exposure 14 for 1.196 seconds
...
2018-04-07T21:21:02.574 Autoguiding stopped for 3 minutes, sequence timeout in 2 minutes.
...
2018-04-07T21:22:03.876 Autoguiding stopped for 4 minutes, sequence timeout in 1 minutes.
...
2018-04-07T21:22:57.968 Autoguider was still not guiding after 5 minutes.
2018-04-07T21:22:57.968 Try next target in sequence.
2018-04-07T21:22:57.968 Try next target
2018-04-07T21:22:57.968 Stop plan LRGB-Flats-Gain53
TagsNo tags attached.

Activities

Thomas Jaeger

18-04-09 18:38

reporter  

Log_20180407_191151.log (76,421 bytes)

Patrick Chevalley

18-04-09 21:02

administrator   ~0004661

Yes, this is a bug. It must not monitor the autoguider status when doing a flat.

I will correct that but in the mean time you can avoid this problem by not touching phd2 during the flat, here the source of the problem is because you briefly start looping exposure in phd2 at 21:17:57.

Patrick Chevalley

18-04-09 22:29

administrator   ~0004666

This is fixed by :
https://github.com/pchev/ccdciel/commit/eee8064643d4f6a6b7d20012257879c43cd39add

Thomas Jaeger

18-04-17 00:21

reporter   ~0004728

I cannot confirm, that it is fixed.
I made a sequence with only flats, CCDCiel tries to start the autoguider.

Thomas Jaeger

18-04-17 00:22

reporter  

Log_20180417_000638.log (11,806 bytes)

Patrick Chevalley

18-04-17 11:14

administrator   ~0004729

OK, at first I think you do a twilight sky flat sequence and this is fixed for this case.
But you run a standard sequence with image type = flat and I have to fix that.

Some more question because I only use twilight sky flat.
Do you use a flat panel or other light source? and do you think this way of making flat can be improved?

Thomas Jaeger

18-04-17 14:00

reporter   ~0004730

I do use a homemade 25cm flat led box and a homemade 35cm EL-Foil box. The power of the emitted light is not constant even with leds over the time I do the flats.

At first use, I was afraid that CCDCiel calculates a new exposure time every frame. But this is good. Most users would expect that CCDCiel estimates the exposure time for a given AD and than do all the flats with the same time.

After all, BIAS, DARKS and FLATS should be undepended from autoguiding.

Thomas

Patrick Chevalley

18-04-17 14:39

administrator   ~0004731

OK, this must be fixed.

This change avoid to force a connection to the auto-guider if the sequence contain only calibration (i.e. no LIGHT frames):
https://github.com/pchev/ccdciel/commit/6b29e946f4f6117876e768f59bdb41adf8c7b3fe

This change do not start auto-guiding for a plan with only calibration steps:
https://github.com/pchev/ccdciel/commit/03b0686fdd017a17485b1d80616c08b7b816fb54

Patrick Chevalley

18-04-17 14:54

administrator   ~0004732

Yes, at the moment the flat logic is for twilight flats and in this case the exposure adjustment is require for every exposure because the sky luminosity change very rapidly.

I think about another option in "Preference / Flat" for led or dome flat.
In this case I can adjust the exposure time only for the first flat with each filter and then keep the same exposure time for all the series.

Thomas Jaeger

18-04-18 13:51

reporter   ~0004733

The option "Preference/Flat/Flatbox, LED, Dome" were fine.

Patrick Chevalley

18-04-18 19:09

administrator   ~0004734

I make a new version 0.9.35 that is available for testing as the weather look good for this next days.

This include the fix for the autoguider and a new option in Preference/Flat for Dome/Panel.

When Dome/Panel is selected the exposure is adjusted only for the first frame and all the series is done with this exposure time.
I also add an option to slew the telescope to a specific position before the flat. This can be use with a flat panel or other white surface fixed on the observatory wall.

Thomas Jaeger

18-04-28 19:18

reporter   ~0004737

I cannot reproduce the movement of the telescope to a specific position, because I do not have a observatory. I have tried the dome flat option. This worked as expected. In my case I went back to the twilight flat option because my two flatboxes (led and EL) do not produce a constant light flux.

Thanks for implementing all the options - CCDCiel grows better and better.
Thomas

Patrick Chevalley

18-04-28 20:16

administrator   ~0004738

OK, no problem. Now there is enough options to adapt to many use case.
Thank you for all your testing and the suggestion to improve the program.

Issue History

Date Modified Username Field Change
18-04-09 18:38 Thomas Jaeger New Issue
18-04-09 18:38 Thomas Jaeger File Added: Log_20180407_191151.log
18-04-09 21:02 Patrick Chevalley Assigned To => Patrick Chevalley
18-04-09 21:02 Patrick Chevalley Status new => confirmed
18-04-09 21:02 Patrick Chevalley Target Version => 1.0
18-04-09 21:02 Patrick Chevalley Note Added: 0004661
18-04-09 22:29 Patrick Chevalley Status confirmed => resolved
18-04-09 22:29 Patrick Chevalley Resolution open => fixed
18-04-09 22:29 Patrick Chevalley Note Added: 0004666
18-04-17 00:21 Thomas Jaeger Status resolved => new
18-04-17 00:21 Thomas Jaeger Resolution fixed => reopened
18-04-17 00:21 Thomas Jaeger Note Added: 0004728
18-04-17 00:22 Thomas Jaeger File Added: Bildschirmfoto vom 2018-04-17 00-06-18.png
18-04-17 00:22 Thomas Jaeger File Added: Log_20180417_000638.log
18-04-17 11:14 Patrick Chevalley Note Added: 0004729
18-04-17 14:00 Thomas Jaeger Note Added: 0004730
18-04-17 14:39 Patrick Chevalley Note Added: 0004731
18-04-17 14:54 Patrick Chevalley Note Added: 0004732
18-04-18 13:51 Thomas Jaeger Note Added: 0004733
18-04-18 19:09 Patrick Chevalley Note Added: 0004734
18-04-28 19:18 Thomas Jaeger Note Added: 0004737
18-04-28 20:16 Patrick Chevalley Status new => resolved
18-04-28 20:16 Patrick Chevalley Resolution reopened => fixed
18-04-28 20:16 Patrick Chevalley Note Added: 0004738