View Issue Details

IDProjectCategoryView StatusLast Update
0001927CCdciel[All Projects] Generalpublic18-04-16 23:02
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritynormalSeveritytweakReproducibilityrandom
Status resolvedResolutionfixed 
PlatformPCOSLinux Mint OS Version18.3
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001927: Autofocus canceled because no star was found
DescriptionFocuser calibration tool was a great progress in CCDCiel. This session started with an already calibrated focuser. My telescope is a very fast 12" f/4 Newton and a ZWO ASI183 with very high quantum efficiency and very tiny pixels. All stars are huge oversampled.
I started with a 2s exposure at 2x2 binning for autofocus, this is more than enough with my old software SGP. Autofocus failed.

I was on the notebook and had to double integration time to success
>>> 2018-04-07T22:05:02.850 Take control exposure for 4.0 seconds

The sequence started a further autofocus and it failed. I saw many stars (rings in my case) on the screen, but CCDCiel did not recognized it. I have tried it two times more, no success. But I saw many stars on the screen !!!
>>> 2018-04-07T22:39:50.318 Autofocus start Dynamic curve

Was there a change in autofocus star detection to this version?

Further in the night it worked better. I assume there was a better star signal to background ratio.

Next time this happens, should I save a focus image as fits?

Thomas



Tagsautofocus

Activities

Patrick Chevalley

18-04-09 21:38

administrator   ~0004663

Last edited: 18-04-09 21:39

View 2 revisions

Yes, there was a lot of change in the star detection function for this version and I have one more change for the next version.
Also with the next version it will automatically save the image if it cannot detect the stars so we can work on them to improve the detection.

With the last version the focuser calibration suggest a smaller movement for the dynamic focus to work with less defocused stars so it accept shorter exposure time. You can make test with that, now for dynamic focus the maximum HFD only need to be 2x or 2.5x the focus HFD.

If the stars are oversampled it is also important that the star detection window (in Preference/Focus) is big enough. It must be at least 4x the defocused ring diameter multiplied by the binning.

You can test with a defocused image by using the "Image inspection" button. Now this function use exactly the same method as the autofocus.

I try to make a new version with the last changes tomorrow.

Patrick Chevalley

18-04-09 21:52

administrator   ~0004665

I see now the screen shot with your other issue showing the result of a dynamic focus.

You can try to multiply the value for "Movement between points" by 0.7 to make the maximum HFD only 8 instead of 12. This can help with low SNR stars.

Thomas Jaeger

18-04-10 20:12

reporter   ~0004671

Thanks for the reply. I am the opinion, that If I see a star clearly on the screen, than it must be recognized by the software. There is room for further development. CCDCiel is getting better an better. I like the way it goes.

Next session I will run an new focuser calibration and check the size of the star detection window again. I may give you feedback again.

Thanks

Patrick Chevalley

18-04-11 11:59

administrator   ~0004680

The difficulty is to adjust the star detection level from the noise. This is very dependent of the camera and at the moment the level is a bit high to not make false detection with noisy sensor like in the asi1600.

So I am very interested if you can send me some fits file with a defocused image you see stars but ccdciel do not detect them.

Thomas Jaeger

18-04-15 21:40

reporter   ~0004719

You wrote
>If the stars are oversampled it is also important that the star detection window (in Preference/Focus)
> is big enough. It must be at least 4x the defocused ring diameter multiplied by the binning.

I have checked this. My data for the detection window was 320/1000px this should be enough.
The weather forecast for tomorow is good. I will make a new focuser calibration and do a screenshoots if this problem occurs again.

Thomas

Patrick Chevalley

18-04-16 14:44

administrator   ~0004720

A too big window can be problematic too because this make difficult to isolate a star.
A good value is the maximum HFD you want to measure multiplied by 4 and multiplied by the binning.
For example to reach HFD=20 with binning 2x2 : star detection window = 20*4*2 = 160

With Han we make a few improvement in the star detection this last days: 0001931 and 0001934

I just make a new version 0.9.34 so we can test this if the weather go better this week.

Thomas Jaeger

18-04-16 18:39

reporter   ~0004721

I have updated and have reduced the detection window to 160. Looking forward to test the new version and image M98 tomorrow if the weather got fine.
Thanks - Thomas

Thomas Jaeger

18-04-16 22:22

reporter   ~0004723

Suddenly it cleared here in N├╝rnberg. I ran a new focuser calibration with success. The reduced dection window worked also. The star detection routine seems to be more sensitive, this is great. I use dynamic autofocus at the moment imaging M82
Thanks for all - Thomas

Patrick Chevalley

18-04-16 23:02

administrator   ~0004726

This look good!
I think I can close this issue. If you have problem in the future be sure to look at the .config/ccdciel/Log/ directory for the failed focus images to send me an example.

Good imaging for tonight!

Issue History

Date Modified Username Field Change
18-04-09 21:09 Thomas Jaeger New Issue
18-04-09 21:09 Thomas Jaeger Tag Attached: autofocus
18-04-09 21:38 Patrick Chevalley Assigned To => Patrick Chevalley
18-04-09 21:38 Patrick Chevalley Status new => assigned
18-04-09 21:38 Patrick Chevalley Target Version => 1.0
18-04-09 21:38 Patrick Chevalley Note Added: 0004663
18-04-09 21:39 Patrick Chevalley Note Edited: 0004663 View Revisions
18-04-09 21:52 Patrick Chevalley Note Added: 0004665
18-04-10 20:12 Thomas Jaeger Note Added: 0004671
18-04-11 11:59 Patrick Chevalley Note Added: 0004680
18-04-15 21:40 Thomas Jaeger Note Added: 0004719
18-04-16 14:44 Patrick Chevalley Note Added: 0004720
18-04-16 18:39 Thomas Jaeger Note Added: 0004721
18-04-16 22:22 Thomas Jaeger File Added: Bildschirmfoto vom 2018-04-16 21-35-50.png
18-04-16 22:22 Thomas Jaeger Note Added: 0004723
18-04-16 23:02 Patrick Chevalley Status assigned => resolved
18-04-16 23:02 Patrick Chevalley Resolution open => fixed
18-04-16 23:02 Patrick Chevalley Note Added: 0004726