View Issue Details

IDProjectCategoryView StatusLast Update
0001930CCdciel[All Projects] Generalpublic18-04-16 22:51
ReporterhanAssigned ToPatrick Chevalley 
PrioritylowSeveritytweakReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001930: Problem with slewing to object very near to the meridian.
DescriptionTonight I have noticed again a small problem for the third or fourth time. After imaging close the the meridian but east of it, I targeted object (M84, M86, M87) just on the right side of the meridian. The telescope does a meridian flip and then pointing is suffering of overshoot across the meridian and program request a retry. Normally after short time it is succeeding with slewing since the object moves away from the meridian. Not a big problem but I noticed is already a few times. See attached log.





TagsNo tags attached.

Activities

han

18-04-11 01:15

reporter  

log slewing around meridian.txt (5,545 bytes)
2018-04-11T00:49:34.040  Starting sequence M84, M86, M87
2018-04-11T00:49:34.071  Initialize target M84, M86, M87
2018-04-11T00:49:34.071  Stop autoguider
2018-04-11T00:49:36.271  Slew to 12h28m48s/+12d33m25s
2018-04-11T00:49:36.286  EQMOD.Telescope: move to 12h28m48s +12d33m25s
2018-04-11T00:50:35.488  EQMOD.Telescope: move completed
2018-04-11T00:50:55.612  Take control exposure for 10.0 seconds
2018-04-11T00:51:10.105  Resolve control exposure
2018-04-11T00:51:10.151  Resolving using Astrometry.Net ...
2018-04-11T00:51:20.089  Open file C:\Users\admin\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2018-04-11T00:51:20.104  Astrometry.Net resolve successful.
2018-04-11T00:51:20.167  Distance to target: 122.85505 arcmin
2018-04-11T00:51:20.167  Sync to 12h37m10s/+12d41m48s
2018-04-11T00:51:20.182  EQMOD.Telescope: sync to 12h37m10s +12d41m48s
2018-04-11T00:51:22.351  Slew to 12h28m48s/+12d33m25s
2018-04-11T00:51:22.351  EQMOD.Telescope: move to 12h28m48s +12d33m25s
2018-04-11T00:51:25.751  EQMOD.Telescope: move completed
2018-04-11T00:51:46.156  Take control exposure for 10.0 seconds
2018-04-11T00:52:00.680  Resolve control exposure
2018-04-11T00:52:00.711  Resolving using Astrometry.Net ...
2018-04-11T00:52:08.261  Open file C:\Users\admin\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2018-04-11T00:52:08.277  Astrometry.Net resolve successful.
2018-04-11T00:52:08.339  Distance to target: 122.74407 arcmin
2018-04-11T00:52:08.339  Sync to 12h37m10s/+12d41m52s
2018-04-11T00:52:08.339  EQMOD.Telescope: sync to 12h37m10s +12d41m52s
2018-04-11T00:52:10.508  Slew to 12h28m48s/+12d33m25s
2018-04-11T00:52:10.523  EQMOD.Telescope: move to 12h28m48s +12d33m25s
2018-04-11T00:52:13.909  EQMOD.Telescope: move completed
2018-04-11T00:52:34.017  Take control exposure for 10.0 seconds
2018-04-11T00:52:48.275  Resolve control exposure
2018-04-11T00:52:48.322  Resolving using Astrometry.Net ...
2018-04-11T00:52:56.294  Open file C:\Users\admin\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2018-04-11T00:52:56.309  Astrometry.Net resolve successful.
2018-04-11T00:52:56.356  Distance to target: 122.68751 arcmin
2018-04-11T00:52:56.356  Sync to 12h37m10s/+12d41m54s
2018-04-11T00:52:56.356  EQMOD.Telescope: sync to 12h37m10s +12d41m54s
2018-04-11T00:52:58.509  Slew to 12h28m48s/+12d33m25s
2018-04-11T00:52:58.525  EQMOD.Telescope: move to 12h28m48s +12d33m25s
2018-04-11T00:53:01.863  EQMOD.Telescope: move completed
2018-04-11T00:53:01.879  Precision slew failed!
2018-04-11T00:53:01.894  Telescope slew error: 122.69 arcminutes.
2018-04-11T00:53:01.910  Pause: After telescope pointing to target the offset relative to requested position is 122.69 arcminutes.
Do you want to retry the slew?
2018-04-11T00:54:07.445  Slew to 12h28m48s/+12d33m25s
2018-04-11T00:54:07.477  EQMOD.Telescope: move to 12h28m48s +12d33m25s
2018-04-11T00:54:10.909  EQMOD.Telescope: move completed
2018-04-11T00:54:31.001  Take control exposure for 10.0 seconds
2018-04-11T00:54:45.743  Resolve control exposure
2018-04-11T00:54:45.775  Resolving using Astrometry.Net ...
2018-04-11T00:54:52.997  Open file C:\Users\admin\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2018-04-11T00:54:53.013  Astrometry.Net resolve successful.
2018-04-11T00:54:53.075  Distance to target: 122.69967 arcmin
2018-04-11T00:54:53.075  Sync to 12h37m10s/+12d41m57s
2018-04-11T00:54:53.075  EQMOD.Telescope: sync to 12h37m10s +12d41m57s
2018-04-11T00:54:55.337  Slew to 12h28m48s/+12d33m25s
2018-04-11T00:54:55.337  EQMOD.Telescope: move to 12h28m48s +12d33m25s
2018-04-11T00:55:09.409  EQMOD.Telescope: move completed
2018-04-11T00:55:29.439  Take control exposure for 10.0 seconds
2018-04-11T00:55:43.573  Resolve control exposure
2018-04-11T00:55:43.604  Resolving using Astrometry.Net ...
2018-04-11T00:55:50.639  Open file C:\Users\admin\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2018-04-11T00:55:50.639  Astrometry.Net resolve successful.
2018-04-11T00:55:50.686  Distance to target: 0.22370 arcmin
2018-04-11T00:55:50.702  Precision slew finished.
2018-04-11T00:55:55.772  Object M84, M86, M87, start plan 200sec
2018-04-11T00:56:00.873  Start step 200secx999
2018-04-11T00:56:00.889  Start capture
2018-04-11T00:56:00.889  Autofocus now
2018-04-11T00:56:00.920  Stay at the current position for autofocus
2018-04-11T00:56:00.920  Focuser temperature: 8.8
2018-04-11T00:56:00.935  Take control exposure for 4.0 seconds
2018-04-11T00:56:13.353  Autofocus start Dynamic curve
2018-04-11T00:56:13.353  Focuser temperature: 8.8
2018-04-11T00:56:13.353  AutoFocus started, initial position: 33110
2018-04-11T00:56:23.290  Using median of 66 stars
2018-04-11T00:56:24.710  Autofocus running, hfd=1.5 peak:32908.6 snr:179.9
2018-04-11T00:56:24.725  ASCOM.USB_Focus.Focuser: Focuser move to 32510 - 400 Backlash compensation
2018-04-11T00:56:31.917  ASCOM.USB_Focus.Focuser: Focuser move to 32510
2018-04-11T00:56:44.413  Using median of 33 stars
2018-04-11T00:56:45.395  Autofocus running, hfd=5.2 peak:30605.5 snr:168.7
2018-04-11T00:56:45.629  ASCOM.USB_Focus.Focuser: Focuser move to 32660
2018-04-11T00:56:56.362  Using median of 45 stars
2018-04-11T00:56:57.189  Autofocus running, hfd=3.9 peak:27612.0 snr:162.4
2018-04-11T00:56:57.205  ASCOM.USB_Focus.Focuser: Focuser move to 32810
2018-04-11T00:57:08.468  Using median of 56 stars
2018-04-11T00:57:09.435  Autofocus running, hfd=2.7 peak:27402.7 snr:162.9
2018-04-11T00:57:09.466  ASCOM.USB_Focus.Focuser: Focuser move to 32960

Patrick Chevalley

18-04-11 11:37

administrator   ~0004678

CCDciel do not specify a meridian side when doing the goto.

From your log it look like Eqmod do nothing with the Sync for the first 3 retry, the position error stay at 122'.
Then after the message prompt the Sync correct the position and the error is reduced to 0.2'.

For me it look like Eqmod do not accept the first Sync because it wrongly compute a large position distance across the meridian.
Can you look at the Eqmod log or console if it show a message about "Sync data too big: ignoring"

han

18-04-11 16:05

reporter   ~0004686

There is no Eqmod log as far i know, but it is easy to reproduce. I have tested it and the HEQ5 & EQMOD combination can't sync across the merdian. In principle this is a save behaviour so I don't think it is a bug.

Maybe it is good to give an hint in the precision slew error message if the meridian crossing is nearby. Something like "Near meridan sync could be problematic. Some mounts can't sync across the meridian. Reduce mount error first by moving the mount a little further away from meridian and sync the mount on a new image."

It is theoretical possible to cope with it by code but that will be not a trivial solution. Near the meridian the found error should be used first to move the scope and then sync. That will work.

Patrick Chevalley

18-04-12 15:40

administrator   ~0004700

You can activate the message log to %APPDATA%\EQMOD\messagelog*.
In the Eqmod window click the green + button until you see the messages instead of the coordinates, there is a check box to activate the log just below the messages.

The problem to add something in ccdciel is this is very specific to every mount/telescope combination and driver setting.

I think the best is you try to solve the issue at the Eqmod level so it accept to Sync near the meridian.
From this document it look like you can change the meridian limit
http://eq-mod.sourceforge.net/docs/EQASCOM_Limits.pdf

My HEQ5 with the telescope tube I use can easily go 30 minutes of hour angle each side of the meridian at any declination, this is more than enough to accept any pointing error.

han

18-04-12 19:07

reporter   ~0004707

Last edited: 18-04-12 19:07

View 2 revisions

The EQMOD or better EQASCOM limits are always off. I often run the scope in tracking mode far across the meridian during imaging. Only slewing and sync seems to be very strict. I tried the latest version 2.00k but same result. I will drop a question at the EQMOD forum.

han

18-04-12 20:13

reporter   ~0004708

I have placed the question in the forum:
 
https://groups.yahoo.com/neo/groups/EQMOD/conversations/messages/49499

Patrick Chevalley

18-04-12 20:47

administrator   ~0004709

I see there is a version 2.00p now. I try in simulation in a VM but not find any option in the limits to make it work.
A difference with this last version is it rise an exception when the Sync is refused so at least it show some information in the ccdciel log.

han

18-04-13 09:59

reporter   ~0004710

Last edited: 18-04-13 10:19

View 2 revisions

I got an answer. There is and most likely will be no solution in future:

>>>>Sorry but there isn't any such setting. Syncs, and the pointing model in general, is only designed for counterweights down operation
>>>>there really is no prospect of that changing at this late stage of EQMOD's life. EQMOD will deliberately reject any syncs made in a counterweights
>>>>up orientation as these would compromise the model for "normal" counterweights down gotos.

As you indicated in version 2.00n has "ASCOM Sync reject exception reinstated". This version and version 2.0.0p are available from the yahoo group files. So that will give at least a warning to the user that it has a sync problem.

https://groups.yahoo.com/neo/groups/EQMOD/files/A%20EQMOD%20Release/EQASCOM/

Knowledge will help to cope with it. The better the mount is polar aligned the less likely it will happen.

Suggested to the EQMOD group to clamp the RA value on the meridian value in case of a sync. At least it would reduce the offset and after a few platesolves and sync actions it will be on target.

Patrick Chevalley

18-04-14 11:11

administrator   ~0004716

Now we have an indication the Sync as failed.
This can be used to switch to the alternate method "slew with offset" in this case. But the risk is it make an unwanted meridian flip to reach the offset target.

Another option is in case of Sync error make a check if we are within +/- 2 degree of the meridan and in this case do a series of maximum 10 retry at one minute interval until it succeed.

Or try if the Syncscan handpad react better to such Sync. Because with plate solving we no more use the main advantage of Eqmod that is it's pointing model. Maybe we can use the Synscan even without any alignment.

han

18-04-14 12:29

reporter   ~0004717

It would be nice if it could be fixed in EQMOD but it seems not.

Your suggestion of 10 retries at one minute near meridian will fix it simple and robust. The 2 degree offset is equivalent to 8 minutes time so within the 10 minutes. That would fix the problems of any CCDciel & EQASCOM user not aware of the problem. He only shouldn't start imaging near the meridian but that is unlikely. It happens later in an imaging session when the object has crossed the meridian and the mount does the meridian flip due to a focus slew. I like it!

The Synscan hand controller is collecting dust. Entering every time the date and time is too cumbersome. I have the mount linked using a bluetooth module. I never use the pointing model. I just unlock the mount after use so I don't hit it when I move around in the small shed to open/close the roof. When i start I just lock the mount manually in celestial pole position and it will fine within 10, 20 degrees position. The plate solving makes the point model unnecessary. Only the polar alignment is checked maybe twice a year using the alignment scope.

Patrick Chevalley

18-04-14 14:45

administrator   ~0004718

I implemented this Sync retries near the meridian:
https://github.com/pchev/ccdciel/commit/f25b7f0ee95b1fc9cf30befa8b98eb5c95715fdc

This is minimally tested because INDI Eqmod on Linux do not have this problem and I cannot test that with the ASCOM simulators.
I can only say it not break anything if the Sync is OK.

There is also many years I not use the Synscan and not want to return to. And more than one year I no more make pointing model with Eqmod, it is set to single point adjustment and this work fine with the plate solving.

han

18-04-16 21:56

reporter   ~0004722

Tested it this evening. Looks good. See log below. I think this can be closed.

2018-04-16T21:47:23.195 EQMOD.Telescope: move completed
2018-04-16T21:47:43.254 Take control exposure for 10.0 seconds
2018-04-16T21:47:57.417 Resolve control exposure
2018-04-16T21:47:57.450 Resolving using Astrometry.Net ...
2018-04-16T21:48:05.985 Open file C:\Users\admin\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2018-04-16T21:48:05.986 Astrometry.Net resolve successful.
2018-04-16T21:48:06.023 Distance to target: 123.58172 arcmin
2018-04-16T21:48:06.023 Sync to 09h55m46s/+11d52m42s
2018-04-16T21:48:06.025 EQMOD.Telescope: sync to 09h55m46s +11d52m42s
2018-04-16T21:48:06.155 EQMOD.Telescope: Error: SyncToTarget() RaDec sync was rejected.
2018-04-16T21:48:06.156 Mount Sync failed near the meridian.
2018-04-16T21:48:06.158 Waiting 1 minute before to retry
2018-04-16T21:49:26.229 Take control exposure for 10.0 seconds
2018-04-16T21:49:40.394 Resolve control exposure
2018-04-16T21:49:40.410 Resolving using Astrometry.Net ...
2018-04-16T21:49:48.444 Open file C:\Users\admin\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2018-04-16T21:49:48.444 Astrometry.Net resolve successful.
2018-04-16T21:49:48.491 Distance to target: 123.86322 arcmin
2018-04-16T21:49:48.491 Sync to 09h55m47s/+11d52m45s
2018-04-16T21:49:48.491 EQMOD.Telescope: sync to 09h55m47s +11d52m45s
2018-04-16T21:49:48.600 EQMOD.Telescope: Error: SyncToTarget() RaDec sync was rejected.
2018-04-16T21:49:48.600 Mount Sync failed near the meridian.
2018-04-16T21:49:48.615 Waiting 1 minute before to retry
2018-04-16T21:51:08.815 Take control exposure for 10.0 seconds
2018-04-16T21:51:23.011 Resolve control exposure
2018-04-16T21:51:23.042 Resolving using Astrometry.Net ...
2018-04-16T21:51:30.421 Open file C:\Users\admin\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2018-04-16T21:51:30.421 Astrometry.Net resolve successful.
2018-04-16T21:51:30.515 Distance to target: 124.10276 arcmin
2018-04-16T21:51:30.515 Sync to 09h55m48s/+11d52m47s
2018-04-16T21:51:30.515 EQMOD.Telescope: sync to 09h55m48s +11d52m47s
2018-04-16T21:51:32.699 Slew to 09h47m22s/+11d43m28s
2018-04-16T21:51:32.699 EQMOD.Telescope: move to 09h47m22s +11d43m28s
2018-04-16T21:51:47.409 EQMOD.Telescope: move completed

Patrick Chevalley

18-04-16 22:51

administrator   ~0004725

Yes, this look efficient.
I close the issue, thank you for testing.

Issue History

Date Modified Username Field Change
18-04-11 01:15 han New Issue
18-04-11 01:15 han File Added: log slewing around meridian.txt
18-04-11 11:37 Patrick Chevalley Assigned To => Patrick Chevalley
18-04-11 11:37 Patrick Chevalley Status new => feedback
18-04-11 11:37 Patrick Chevalley Note Added: 0004678
18-04-11 16:05 han Note Added: 0004686
18-04-11 16:05 han Status feedback => assigned
18-04-12 15:40 Patrick Chevalley Note Added: 0004700
18-04-12 19:07 han Note Added: 0004707
18-04-12 19:07 han Note Edited: 0004707 View Revisions
18-04-12 20:13 han Note Added: 0004708
18-04-12 20:47 Patrick Chevalley Note Added: 0004709
18-04-13 09:59 han Note Added: 0004710
18-04-13 10:19 han Note Edited: 0004710 View Revisions
18-04-14 11:11 Patrick Chevalley Note Added: 0004716
18-04-14 12:29 han Note Added: 0004717
18-04-14 14:45 Patrick Chevalley Note Added: 0004718
18-04-16 21:56 han Note Added: 0004722
18-04-16 22:51 Patrick Chevalley Status assigned => resolved
18-04-16 22:51 Patrick Chevalley Resolution open => fixed
18-04-16 22:51 Patrick Chevalley Target Version => 1.0
18-04-16 22:51 Patrick Chevalley Note Added: 0004725