View Issue Details

IDProjectCategoryView StatusLast Update
0001931CCdciel[All Projects] Generalpublic18-04-12 18:56
ReporterhanAssigned ToPatrick Chevalley 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001931: CCD inspector is measuring some stars twice
DescriptionThe magnifier is a nice addition. This helped to highlight a small problem that the CCD inspector is measuring some stars twice with a slightly different result. See attached screen shots. I can have look to the problem myself, but it has to wait some days.
TagsNo tags attached.

Activities

han

18-04-11 01:26

reporter  

ccdinspection.png (645,352 bytes)
ccdinspection.png (645,352 bytes)
ccdinspection2.png (667,437 bytes)
ccdinspection2.png (667,437 bytes)

han

18-04-11 02:06

reporter   ~0004674

Last edited: 18-04-11 02:18

View 2 revisions

This zoom-in is better highlighting the problem. Maybe 15% of stars is counted double.

I have also the impression that for dynamic focussing the number of stars reported is about double as the number of red square marked stars. Similar double counting but less visible?



ccd inspector3.png (1,257,530 bytes)

Patrick Chevalley

18-04-11 11:17

administrator   ~0004677

I confirm that.
I make some quick testing and strangely setting overlap=0 in GetStarList do not fix it, I have to put a negative overlap to remove the duplicate.
I try a find a sample image that show the problem with not too many stars so it is more easy to debug.

han

18-04-11 17:39

reporter   ~0004690

Last edited: 18-04-11 17:40

View 2 revisions

I didn't look into the CCDciel code, but I have solved it in ASTAP by a second/shadow image array by marking the found star area in a shape of a square box 5*HFD. If a new star is found it is ignored if the shadow image array has a value on the position of the new star. So the area is already taken & marked by an previous found star. This made the code simple and robust.

Patrick Chevalley

18-04-11 23:52

administrator   ~0004696

The problem must be fixed by this change:
https://github.com/pchev/ccdciel/commit/90a7a168870ab81b9e87c877e0c971cb88e0e6cb

I miss to apply the overlap test when I do the new GetStarList using GetHFD2.

But also the overlap was much to small, making easy for a big star to be split between two boxes and measured individually in each with half of the pixels.
I increase the overlap to half of the box width. This has the effect to remove more duplicate and also detect more legit stars in defocused images.

han

18-04-12 12:38

reporter  

_m31-3_55s_2x2_20180108_190058 x 6 _stacked.zip (5,758,449 bytes)
doubles.png (858,580 bytes)
doubles.png (858,580 bytes)

han

18-04-12 12:38

reporter   ~0004697

Great it is almost perfect. I see only a very few doubles in a very crowded star field. Maybe some tuning of the parameters. I have attached the screenshot and sample file.

Patrick Chevalley

18-04-12 14:09

administrator   ~0004698

This morning I do two changes to avoid to use a too big measurement window after the yesterday change.
For me this solve this duplicates in your test image.
Can you try with the latest git now?

han

18-04-12 16:32

reporter   ~0004701

This time it works flawlessly. No more double detection's!

Something to consider is an adaptation for saturated stars. Their HFD is reported too high since the center peak is clamped. For focusing due to the median selection you probably would not notice. But It should be possible to reconstruct the star peak values since their shape will most follow a clamped 3D Gaussian curve but that is an other topic.

han

18-04-12 16:48

reporter   ~0004702

Last edited: 18-04-12 16:55

View 2 revisions

Sorry but still a small problem. Two pixel stars are not detected even with undersampled on. See attach screen shot. This was working in version 9.30.873



Untitled.png (27,898 bytes)
Untitled.png (27,898 bytes)

han

18-04-12 17:07

reporter   ~0004703

Here the test files.

test images.zip (3,669 bytes)

Patrick Chevalley

18-04-12 17:31

administrator   ~0004704

For saturated star you can exclude them by setting the camera Maximum ADU in Preference/Camera, any detection with valmax higher than this value is ignored. For your M31 image I set it to 32000.

The two pixel stars in this image are measured if the "star detection window size" is not too big. From my testing this work up to a size of 80. With a bigger size they are rejected by some of the test we do on the data distribution.

The problem is you probably have a bigger value because of your camera small pixels and the binning 2x2 you use for focusing.
As this file as no binning information it consider this is 1x1 and the window size is not divided by two.
If you add a keyword "XBINNING=2" in the image fits header this also work.

This is not a problem when the image are taken by the camera because this setting is stored in the profile and a different camera will use another profile. But this is something we must be careful when opening random images.
Personally I have to change my value of 80 to 150-200 before to test your defocused images.

In this case it will be better if the value is not divided by the binning but if we do that it will fail to measure an image from the camera when the binning change.

han

18-04-12 18:31

reporter   ~0004705

Okay false alarm. When I changed the detection size from 120 to 50 it works :)

The images are fully artificial. The reason I used them was that I found a difference in the median HFD reported by CCDCiel and ASTAP. It looks like CCDciel is correct.

Calculating the HFD of saturated stars is probably a futile activity. As you indicated you can filter them out and in group they will be always in the minority so never median, For focusing on single bright star it could influence the bottom part of the curve with some effects.

This topic is anyhow solved.

Patrick Chevalley

18-04-12 18:56

administrator   ~0004706

Ok I close this issue as solved.

About the median HFD value beware my Smedian function is not a pure median, it is make to always return something even if the number of points is too small, and if there is enough points it return the mean of the 3 central values.

Issue History

Date Modified Username Field Change
18-04-11 01:26 han New Issue
18-04-11 01:26 han File Added: ccdinspection.png
18-04-11 01:26 han File Added: ccdinspection2.png
18-04-11 02:06 han File Added: ccd inspector3.png
18-04-11 02:06 han Note Added: 0004674
18-04-11 02:18 han Note Edited: 0004674 View Revisions
18-04-11 11:17 Patrick Chevalley Assigned To => Patrick Chevalley
18-04-11 11:17 Patrick Chevalley Status new => assigned
18-04-11 11:17 Patrick Chevalley Note Added: 0004677
18-04-11 17:39 han Note Added: 0004690
18-04-11 17:40 han Note Edited: 0004690 View Revisions
18-04-11 23:52 Patrick Chevalley Note Added: 0004696
18-04-12 12:38 han File Added: doubles.png
18-04-12 12:38 han File Added: _m31-3_55s_2x2_20180108_190058 x 6 _stacked.zip
18-04-12 12:38 han Note Added: 0004697
18-04-12 14:09 Patrick Chevalley Note Added: 0004698
18-04-12 16:32 han Note Added: 0004701
18-04-12 16:48 han File Added: Untitled.png
18-04-12 16:48 han Note Added: 0004702
18-04-12 16:55 han Note Edited: 0004702 View Revisions
18-04-12 17:07 han File Added: test images.zip
18-04-12 17:07 han Note Added: 0004703
18-04-12 17:31 Patrick Chevalley Note Added: 0004704
18-04-12 18:31 han Note Added: 0004705
18-04-12 18:56 Patrick Chevalley Status assigned => resolved
18-04-12 18:56 Patrick Chevalley Resolution open => fixed
18-04-12 18:56 Patrick Chevalley Target Version => 1.0
18-04-12 18:56 Patrick Chevalley Note Added: 0004706