View Issue Details

IDProjectCategoryView StatusLast Update
0001940CCdciel[All Projects] Generalpublic18-05-10 10:22
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0001940: Message: Telescope: move completed --> telescope moved
Description1) The message "EQMOD.Telescope: move completed is presented numerous times. It is a little conflicting with the final message "Precision slew finished" I would suggest to change it in "moved" since it precedes with message move to.

2018-05-07T00:45:57.163 ASTAP resolve successful. Solved in 3 seconds , offset 0.0562 degree
2018-05-07T00:45:57.191 Distance to target: 3.72326 arcmin
2018-05-07T00:45:57.196 Sync to 13h43m19s/+28d17m13s
2018-05-07T00:45:57.202 EQMOD.Telescope: sync to 13h43m19s +28d17m13s
2018-05-07T00:45:59.362 Slew to 13h43m02s/+28d17m06s
2018-05-07T00:45:59.410 EQMOD.Telescope: move to 13h43m02s +28d17m06s
2018-05-07T00:46:03.390 EQMOD.Telescope: move completed
2018-05-07T00:46:23.429 Take control exposure for 10.0 seconds
2018-05-07T00:46:23.450 ASCOM.ASICamera2.Camera: Set frame type Light
2018-05-07T00:46:37.084 Resolve control exposure
2018-05-07T00:46:37.131 Resolving using ASTAP ...
2018-05-07T00:46:39.773 Open file C:\Users\admin\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2018-05-07T00:46:39.782 ASTAP resolve successful. Solved in 3 seconds , offset 0.0016 degree
2018-05-07T00:46:39.815 Distance to target: 0.27144 arcmin
2018-05-07T00:46:39.824 Precision slew finished.
TagsNo tags attached.

Activities

han

18-05-07 02:21

reporter   ~0004752

Last edited: 18-05-07 02:21

View 2 revisions

Probably these message are fixed in EQMOD and not changeable.

Anyhow after some thinking, I think to verb move is wrong. Move is when you bring the thing to an other location. Better would be:

1) EQMOD.Telescope: SLEW to 13h43m02s +28d17m06s
2) EQMOD.Telescope: AIMED or SLEWED to position

I have little preference for aimed since it describes the higher target and not a rotaton/slew.

But as these message come from EQMOD, no way to change. Then I have to place a message at the EQMOD forum.

Patrick Chevalley

18-05-10 10:22

administrator   ~0004754

This messages are from ccdciel, you not get any message from an ASCOM driver apart of exceptions.

I prefer slewed over aimed because this message is when the mount rotation stop, not when we are sure the target is centered.
Finally I use the same messages as reported by the INDI Eqmod driver in this case: "Slewing to ..." and "Slew is complete".
I also remove the duplicate messages.
https://github.com/pchev/ccdciel/commit/ce6cf9023646d9c00446d16543aee7c7d8059b87

Issue History

Date Modified Username Field Change
18-05-07 01:02 han New Issue
18-05-07 02:21 han Note Added: 0004752
18-05-07 02:21 han Note Edited: 0004752 View Revisions
18-05-10 10:22 Patrick Chevalley Assigned To => Patrick Chevalley
18-05-10 10:22 Patrick Chevalley Status new => resolved
18-05-10 10:22 Patrick Chevalley Resolution open => fixed
18-05-10 10:22 Patrick Chevalley Target Version => 1.0
18-05-10 10:22 Patrick Chevalley Note Added: 0004754