View Issue Details

IDProjectCategoryView StatusLast Update
0001941CCdciel[All Projects] Generalpublic18-05-13 09:47
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0001941: Log with tabs SHOW ALL or MILESTONES ONLY
DescriptionMaybe it is good to introduce a message filter on importance or better two logs. See attached screenshot with some sketching as an idea

Add two tabs:

tab 1, show all
tab 2, milestones only

Some messages are important as focusing successful and precision slew successful. Others are less interesting. I notice that I often have to go back to "show current log" to see of focusing was successful because it scrolls away in a few seconds.

Depending on priority a message is only written to the existing log or additional to the milestone/important log.


2018-05-07T01:05:53.328 1: Autofocus now
2018-05-07T01:05:53.344 3: Stay at the current position for autofocus
2018-05-07T01:05:53.344 3:Pause autoguider
2018-05-07T01:05:53.468 3:Autoguider: Paused
2018-05-07T01:05:55.434 3:Focuser temperature: 12.1
2018-05-07T01:05:55.450 3:Take control exposure for 4.0 seconds
2018-05-07T01:05:55.465 3:ASCOM.ASICamera2.Camera: Set frame type Light
2018-05-07T01:06:07.680 2:Autofocus start Dynamic curve
2018-05-07T01:06:07.696 3:Focuser temperature: 12.1
2018-05-07T01:06:07.696 3:AutoFocus started, initial position: 34276
2018-05-07T01:06:16.400 3:Using median of 79 stars
2018-05-07T01:06:16.432 3:Autofocus running, hfd=1.6 peak:29175.7 snr:169.5
2018-05-07T01:06:16.447 3:ASCOM.USB_Focus.Focuser: Focuser move to 33676 - 400 Backlash compensation
2018-05-07T01:06:23.639 3:ASCOM.USB_Focus.Focuser: Focuser move to 33676
2018-05-07T01:06:35.136 3:Using median of 46 stars
2018-05-07T01:06:35.152 3:Autofocus running, hfd=4.5 peak:7125.3 snr:82.0
2018-05-07T01:06:35.167 3:ASCOM.USB_Focus.Focuser: Focuser move to 33826
2018-05-07T01:06:46.243 3:Using median of 60 stars
2018-05-07T01:06:46.368 3:Autofocus running, hfd=3.0 peak:8933.6 snr:92.5
2018-05-07T01:06:46.384 3:ASCOM.USB_Focus.Focuser: Focuser move to 33976
2018-05-07T01:06:56.399 3:Using median of 81 stars
2018-05-07T01:06:56.414 3:Autofocus running, hfd=2.5 peak:11443.0 snr:105.0
2018-05-07T01:06:56.446 3:ASCOM.USB_Focus.Focuser: Focuser move to 34126
2018-05-07T01:07:06.476 3:Using median of 84 stars
2018-05-07T01:07:06.570 3:Autofocus running, hfd=1.9 peak:15268.3 snr:122.0
2018-05-07T01:07:06.586 3:ASCOM.USB_Focus.Focuser: Focuser move to 34276
2018-05-07T01:07:16.757 3:Using median of 86 stars
2018-05-07T01:07:16.788 3:Autofocus running, hfd=1.9 peak:13307.1 snr:113.7
2018-05-07T01:07:16.804 3:ASCOM.USB_Focus.Focuser: Focuser move to 34426
2018-05-07T01:07:27.817 3:Using median of 87 stars
2018-05-07T01:07:28.597 3:Autofocus running, hfd=1.7 peak:24456.0 snr:155.1
2018-05-07T01:07:28.628 3:ASCOM.USB_Focus.Focuser: Focuser move to 34576
2018-05-07T01:07:38.878 3:Using median of 83 stars
2018-05-07T01:07:38.893 3:Autofocus running, hfd=2.0 peak:13931.9 snr:116.4
2018-05-07T01:07:38.909 3:ASCOM.USB_Focus.Focuser: Focuser move to 34726
2018-05-07T01:07:49.751 3:Using median of 70 stars
2018-05-07T01:07:49.766 3:Autofocus running, hfd=2.3 peak:7341.3 snr:83.5
2018-05-07T01:07:49.782 3:ASCOM.USB_Focus.Focuser: Focuser move to 34876
2018-05-07T01:08:00.452 3:Using median of 57 stars
2018-05-07T01:08:00.577 3:Autofocus running, hfd=3.9 peak:4149.9 snr:61.2
2018-05-07T01:08:00.624 3:HYPERBOLA curve fitting focus at 5.500, remaining curve fit error 0.2776, iteration cycles 2
2018-05-07T01:08:00.655 3:ASCOM.USB_Focus.Focuser: Focuser move to 34201 - 400 Backlash compensation
2018-05-07T01:08:08.330 3:ASCOM.USB_Focus.Focuser: Focuser move to 34201
2018-05-07T01:08:12.620 3:ASCOM.USB_Focus.Focuser: Focuser move to 34351
2018-05-07T01:08:23.743 3:Using median of 83 stars
2018-05-07T01:08:23.774 3:Autofocus finished, POS=34351 HFD=1.6 PEAK:25957.9 SNR:159.8 TEMP:12.1
2018-05-07T01:08:24.851 1:AutoFocus successful






TagsNo tags attached.

Activities

han

18-05-07 01:41

reporter  

two logs.png (53,548 bytes)
two logs.png (53,548 bytes)

Patrick Chevalley

18-05-10 12:04

administrator   ~0004755

I add the message filter by log level:
https://github.com/pchev/ccdciel/commit/fe710fe9c00eb2ee5675a3dac1e1cd7c3c9fed1f

Now I need to classify every message.
The default level is 1, so everything not classified is show.
For testing I set the "Connecting..." message to 2 and every message from the driver to 3.

Patrick Chevalley

18-05-10 12:09

administrator   ~0004756

The tabs as you show are good but this need some work to hide them when the mouse is not over, and be sure they work if the log tool is placed on the top of the screen.
So for simplicity I only use vertical speedbutton for this first test.

Patrick Chevalley

18-05-10 18:57

administrator   ~0004757

More messages are now classified:
https://github.com/pchev/ccdciel/commit/5c45ccde604f6ca807cabf81d94faf039de0734f

Level 1 : show only the main steps when running an automated sequence
Level 2 : show more information, useful when using the tools manually
Level 3 : show all the details as in previous version

Patrick Chevalley

18-05-10 20:27

administrator   ~0004758

I remove the button and you can use tabs that appear when the mouse is in the message area:
https://github.com/pchev/ccdciel/commit/31b063c16a7f1f50da78a7947eb0e699c6e25ebc

han

18-05-10 21:13

reporter   ~0004760

Great! I think this is a signification interface improvement for the casual user. He will keep track of what's happening and he is not flooded by messages.

Maybe the preceding numbers 1:, 2:, 3: are not required in the summary, but it helps to classify in this phase.
I tried to follow the code, but couldn't find it quickly. Is it sorted depending on the tab or do you maintain three tmemo's?

Patrick Chevalley

18-05-10 21:45

administrator   ~0004761

I just fixed the tabs position and transparency on Windows.

All the messages are put in the TStringList AllMsg. It is added to the memo if the level match.
When the level change, the memo is cleared and a loop in AllMsg add the matching messages.
This is in Tf_main.NewMessage and Tf_main.LogLevelChange

There is no performance problem because the number of message was already limited to 100. I can increase this limit a bit if there is not enough messages when filtered to level=1.

Patrick Chevalley

18-05-13 09:47

administrator   ~0004763

Yes this is a very useful feature.

I do a few more change:
- to not display the number on the screen, but let it in the log file.
- be sure every driver exception message is of level 1.
- save the selected log detail for the next session.
- translate the tab text.

I close the issue now but please send me any message you think is misclassified.

Issue History

Date Modified Username Field Change
18-05-07 01:41 han New Issue
18-05-07 01:41 han File Added: two logs.png
18-05-10 12:04 Patrick Chevalley Assigned To => Patrick Chevalley
18-05-10 12:04 Patrick Chevalley Status new => assigned
18-05-10 12:04 Patrick Chevalley Target Version => 1.0
18-05-10 12:04 Patrick Chevalley Note Added: 0004755
18-05-10 12:09 Patrick Chevalley Note Added: 0004756
18-05-10 18:57 Patrick Chevalley Note Added: 0004757
18-05-10 20:27 Patrick Chevalley Note Added: 0004758
18-05-10 21:13 han Note Added: 0004760
18-05-10 21:45 Patrick Chevalley Note Added: 0004761
18-05-13 09:47 Patrick Chevalley Status assigned => resolved
18-05-13 09:47 Patrick Chevalley Resolution open => fixed
18-05-13 09:47 Patrick Chevalley Note Added: 0004763