View Issue Details

IDProjectCategoryView StatusLast Update
0001952CCdciel[All Projects] Generalpublic18-06-26 17:33
ReportergakellermanAssigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001952: Add Stop an object at dawn option and continue to next plan step (ie., script to park scope).
DescriptionIt would be really nice to have the ability to stop a step in a plan at dawn (without needing to modify the time on a daily basis. The option to stop a plan at dawn that already exists but doesn't allow for a script to park the scope, it seems to just end all activities.

I am really enjoying this program and am getting tons of great science images. Thanks for all the hard work!

TagsNo tags attached.

Activities

Patrick Chevalley

18-06-22 08:53

administrator   ~0004793

I not put the option at the target/step level because we not necessarily know what target will be running at dawn, by having the option at the sequence level we are sure to stop at dawn in any case.
If "dawn" is checked this sequence dawn time is recomputed every day the sequence is started.

To park the scope at the end of a sequence you not need to add a script in the sequence itself, there is a standard end_sequence script that run automatically whenever a sequence is terminated.
There is also the unattended_error script that run in case of error in "unattended mode".
This is described at the top of the script help page : https://www.ap-i.net/ccdciel/en/documentation/ccdscript
I probably need to copy this information to the sequence help page.
Beware there is a typo error in the pdf documentation, it show end-sequence instead of end_sequence.

Do this solve the problem?

gakellerman

18-06-22 09:27

reporter   ~0004794

Oh I think I see it now... No Park script is required in the Sequence Step area. It is automatic when Dawn is reached when Dawn is enabled.

I had been using a script in the step area so I never realized what action takes place when Dawn is reached so I didn't enable that and was changing the step end time daily.

Very powerful but a bit hard to figure out from the documentation.

Also I have noticed that the number of repeats set in the sequence seems to reset to some number that is not what I saved prior. Seems random or at least I cannot reproduce the change consistantly.

gakellerman

18-06-23 22:06

reporter   ~0004795

i need to report that after 2 nights of attempting to use the auto executed script at end of sequence I have mixed results.

When a script finishes normally (ie. When it terminates because it completed itself), the auto execute works as expected.

When I check the stop at Dawn box to get it to end on that calculated time I get a user terminated message and NO auto script executes;

2018-06-23T04:13:01.572 3: FCUSB.Focuser: Focuser move by -91, Backlash compensation - 500
2018-06-23T04:13:09.830 1: Stop the current sequence at 4:13:09
2018-06-23T04:13:09.840 1: Request to stop autofocus ...
2018-06-23T04:13:09.850 3: ASCOM.OrionG3CameraDriver.Camera: Abort exposure
2018-06-23T04:13:09.860 3: ASCOM.OrionG3CameraDriver.Camera: Abort exposure
2018-06-23T04:13:09.870 2: Abort exposure
2018-06-23T04:13:09.880 2: Stop capture
2018-06-23T04:13:09.880 2: Stop autoguider
2018-06-23T04:13:09.990 1: Sequence stopped by user request, no termination script will be run.
2018-06-23T04:13:10.000 3: ASCOM.OrionG3CameraDriver.Camera: Abort exposure
2018-06-23T04:13:10.490 1: Sequence CG Dra stopped.
2018-06-23T04:13:10.510 2: Camera frame x=0 y=0 width=752 height=582
2018-06-23T04:13:11.060 1: AutoFocus error
2018-06-23T04:13:11.070 1: Autofocus failed!
2018-06-23T04:13:11.080 0: Cannot start capture now
2018-06-23T04:13:11.090 2: Stop capture
2018-06-23T04:13:12.300 2: Camera cooler : False
2018-06-23T04:13:14.340 1: Plan Astrometry stopped.
2018-06-23T04:13:14.350 2: Camera cooler : True
2018-06-23T04:13:14.490 2: End preview

In this bit of last nights log file the dawn portion executed at 04:13:09 and you can see the Sequence stopped by user request, no termination script will be run. BTW I also check the run unattended box and have the same end script set for that action.

I also want to Request that a check box be placed in the sequence funtion dialog area giving a choice of weather to execute the end of sequence script. The reason is that I use a script to do my nightly flats and I have a light box that attaches to the telscope tube. I manually point the tube UP for this operation, then remove it when completed. Now that I have a end of sequence script setup I DON't want it to execute so that I don't damage the light box by the scope going to PARK (the light box will fall off). Another reason is that I sometimes use a dew shield on my tube that must be removed prior to parking or it will hit the wall of my observatory.

I really like the end of sequence termination script, 99% of the time but there needs to be a way for exceptions.

Also the target REPEAT function resets itself to 2 from wahtever number I set WHEN I close CCD Ciel and re-open the program.

Patrick Chevalley

18-06-24 10:12

administrator   ~0004796

Last edited: 18-06-24 10:20

View 2 revisions

Thank you for this log. Yes, the script is not executed because this interruption at dawn is considered as a user request, I will correct that.

You are right this need more options to adapt to every case.

I am currently working at an improvement for the sequence editing: https://www.ap-i.net/mantis/view.php?id=1945
I take this occasion to add the option to select the action to do at the end of a sequence.

This can be a set of option you can select more than one like:
- do nothing
- stop tracking
- park
- warm the camera
- run a script

In case of unattended error it is probably best to do this same action + eventually run a additional script.

Edit: I just test for the target repeat option that reset to 2. This bug is fixed by my new implementation of the sequence editor.

gakellerman

18-06-24 10:18

reporter   ~0004797

Tonight I need to report that the STOP the sequence button ran the end sequence script even though the doccumentation says it is not supposed to.

Patrick Chevalley

18-06-24 10:22

administrator   ~0004798

Can you add the part of the log when you stop the sequence?

gakellerman

18-06-24 22:29

reporter   ~0004799

Here is the relevant portion of the log:

2018-06-23T21:04:37.926 1: Saved file C:\APT_Images\CameraCCD_1\LightFlats\20180623\Flat_Blue_2_45s_1x1_20180624_030437_31.6C.fits
2018-06-23T21:04:37.936 2: Stop capture
2018-06-23T21:04:37.956 1: Object Light Flats, plan Light Flats finished.
2018-06-23T21:04:38.707 1: Run script Pause
2018-06-23T21:04:38.727 1: Cover Tube
2018-06-23T21:06:36.612 1: Request to stop the current sequence
2018-06-23T21:06:36.623 1: Sequence stopped by user request, no termination script will be run.
2018-06-23T21:06:36.957 1: Script Pause finished
2018-06-23T21:06:36.967 1: Sequence Flats 06-23-18 finished.
2018-06-23T21:06:36.977 1: Run script end_sequence
2018-06-23T21:06:37.006 3: ASCOM.Celestron.Telescope: Park

Note that I have a pause script as part of the sequence so that I can remove the light box and cover the tube...I usually make dark flats. As you can see the log shows after I acknowledged the pause no script was to be run then goes ahead and runs the end sequence script anyways.

gakellerman

18-06-24 22:36

reporter   ~0004800

This happend as I was shutting down last night:

2018-06-24T04:12:37.936 3: Take control exposure for 21.0 seconds
2018-06-24T04:12:59.577 2: Camera cooler : False
2018-06-24T04:13:00.114 1: Stop the current target at 4:13:00
2018-06-24T04:13:00.114 1: Try next target
2018-06-24T04:13:00.134 1: Request to stop autofocus ...
2018-06-24T04:13:00.134 3: ASCOM.OrionG3CameraDriver.Camera: Abort exposure
2018-06-24T04:13:00.154 0: ASCOM.OrionG3CameraDriver.Camera: Abort exposure error: Cannot complete operation
2018-06-24T04:13:00.164 1: Stop plan Astrometry
2018-06-24T04:13:00.174 3: ASCOM.OrionG3CameraDriver.Camera: Abort exposure
2018-06-24T04:13:00.184 0: ASCOM.OrionG3CameraDriver.Camera: Abort exposure error: Cannot complete operation
2018-06-24T04:13:00.194 2: Abort exposure
2018-06-24T04:13:00.204 2: Stop capture
2018-06-24T04:13:00.543 1: Run script scope_park
2018-06-24T04:13:00.703 3: ASCOM.Celestron.Telescope: Park
2018-06-24T04:13:43.623 2: Camera cooler : True
2018-06-24T04:13:47.231 1: Script scope_park finished
2018-06-24T04:13:47.241 2: Stop autoguider
2018-06-24T04:13:47.361 1: Sequence CG Dra finished.
2018-06-24T04:13:47.381 0: Exposure fail!
2018-06-24T04:13:47.391 0: Precision slew failed!
2018-06-24T04:13:48.481 3: Take control exposure for 0.5 seconds
2018-06-24T04:13:49.571 2: Camera cooler : False
2018-06-24T04:13:51.634 2: Camera cooler : True
2018-06-24T04:13:54.600 2: Camera frame x=100 y=-78 width=400 height=400
2018-06-24T04:13:54.870 2: Autofocus start Iterative focus
2018-06-24T04:13:54.880 0: ASCOM.OrionG3CameraDriver.Camera: Start exposure error: Invalid y
2018-06-24T04:13:54.890 2: AutoFocus started
2018-06-24T04:14:25.914 1: Autoguider: Connection reset by peer
2018-06-24T04:14:25.934 1: Autoguider disconnected
2018-06-24T04:14:25.964 1: Autoguider: Disconnected
2018-06-24T04:14:45.552 3: ASCOM.OrionG3CameraDriver.Camera: Abort exposure

With this log I was shutting things down... I had alraedy removed the end_sequence script and added the scope park script as the last step in the sequence. The scope parked but the attempt for auto-focus was still trying to run. I was not using Dawn setting in the sequence area; instead I set 4:13 in the object end time area.

Patrick Chevalley

18-06-26 17:33

administrator   ~0004802

A new version 0.9.39 is now available and it must fix this problem. I have specifically fixed the cancellation when a script or the autofocus is running.

Also the new sequence editor allow to specify the action to do when the sequence is finished.
An important change is the normal termination actions are always taken when "Run unattended" is checked.
The documentation give more detail :
https://www.ap-i.net/ccdciel/en/documentation/sequence

Issue History

Date Modified Username Field Change
18-06-21 23:30 gakellerman New Issue
18-06-22 08:53 Patrick Chevalley Assigned To => Patrick Chevalley
18-06-22 08:53 Patrick Chevalley Status new => feedback
18-06-22 08:53 Patrick Chevalley Note Added: 0004793
18-06-22 09:27 gakellerman Note Added: 0004794
18-06-22 09:27 gakellerman Status feedback => assigned
18-06-23 22:06 gakellerman Note Added: 0004795
18-06-24 10:12 Patrick Chevalley Note Added: 0004796
18-06-24 10:18 gakellerman Note Added: 0004797
18-06-24 10:20 Patrick Chevalley Note Edited: 0004796 View Revisions
18-06-24 10:22 Patrick Chevalley Note Added: 0004798
18-06-24 22:29 gakellerman Note Added: 0004799
18-06-24 22:36 gakellerman Note Added: 0004800
18-06-26 17:33 Patrick Chevalley Status assigned => resolved
18-06-26 17:33 Patrick Chevalley Resolution open => fixed
18-06-26 17:33 Patrick Chevalley Target Version => 1.0
18-06-26 17:33 Patrick Chevalley Note Added: 0004802