View Issue Details

IDProjectCategoryView StatusLast Update
0001961CCdciel[All Projects] Generalpublic18-07-07 20:21
ReporterBasil RoweAssigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version8
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001961: Saturated stars recorded as 0 ADU, not 65535
DescriptionStarting with v. 9.39.1098 all saturated stars are shown in preview and recorded as 0 ADU, not 65535. Installing v. 9.38.1058 fixes the problem. Installing v. 1098 or v. 1132 brings it back.

Atik one 6.0 CCD

Attached is an example.

Thanks!
TagsNo tags attached.

Activities

Basil Rowe

18-07-07 05:00

reporter  

arcturus.fits (1,350,720 bytes)

Thomas Jaeger

18-07-07 16:04

reporter   ~0004819

Hello,
I can confirm this behavior using version 0.9.39-1098 on Linux Mint. My ASI1600 show's a black image exposed to a bright light (all pixel saturated). This is not the case using EKOS as a INDI Client.
Thomas

Patrick Chevalley

18-07-07 17:06

administrator   ~0004820

Thomas,
I not think this is the same, because Basil problem is due of a change to the Ascom camera I do recently. My images done last night on Linux do not show this problem with saturated stars.
An image filled uniformly with the same value appear black on the screen because of the automatic stretching.
You can look at the pixel value on the bottom left of the ccdciel window, is it really 0?

Basil,
I probably know what to change to fix the problem but I am currently rebuilding my raid5 after I replace a disk, so I have to wait it finish before to reboot on Windows for testing.

Patrick Chevalley

18-07-07 20:21

administrator   ~0004821

This is fixed by https://github.com/pchev/ccdciel/commit/ec2a4d3390094fd1db38a674b65b7c0cbd673435

The fix is available now in a new version 0.9.41.

I also change the display of images with a uniform value, now they show as gray instead of black so it is more easy to interpret what is doing.
https://github.com/pchev/ccdciel/commit/d26c18df3a972b551c01bae10c43a9fcc7b9528c

Issue History

Date Modified Username Field Change
18-07-07 05:00 Basil Rowe New Issue
18-07-07 05:00 Basil Rowe File Added: arcturus.fits
18-07-07 16:04 Thomas Jaeger Note Added: 0004819
18-07-07 17:06 Patrick Chevalley Note Added: 0004820
18-07-07 20:21 Patrick Chevalley Assigned To => Patrick Chevalley
18-07-07 20:21 Patrick Chevalley Status new => resolved
18-07-07 20:21 Patrick Chevalley Resolution open => fixed
18-07-07 20:21 Patrick Chevalley Target Version => 1.0
18-07-07 20:21 Patrick Chevalley Note Added: 0004821