View Issue Details

IDProjectCategoryView StatusLast Update
0001962CCdciel[All Projects] Generalpublic19-04-05 22:43
ReporterPeter FasslerAssigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001962: cannot get picture to show
Description I have a QYH CCD 165C and it connects to CCDciel without a problem . However taking a test picture I get the following message:
0:35:30 Camera frame x=0 y=0 width=4968 height=3378
10:35:46 Start capture
10:35:46 Starting Light exposure 1 for 0.1 seconds
10:35:47 ASCOM.QHYCCD.Camera: Error accessing ImageArray: Can not show image with wrong size.
10:35:47 Exposure aborted!

All the drivers from QHY have been updated as well as the Ascom driver from QHY

System info : Windows 10,
Laptop with 16 Gig Ram 8 cores.

What do I do wrong. Please advise
TagsNo tags attached.

Relationships

related to 0002105 resolvedPatrick Chevalley QHY294C camera cannot connect to CCDCiel 

Activities

Patrick Chevalley

18-09-19 11:30

administrator   ~0004866

No idea for this message.
The part "Can not show image with wrong size" is returned when the program access the ImageArray ASCOM property.
It is probably returned by the Qhy driver but I don't know why.

Can you try to set another image size, for example by setting the binning to 2.

Peter Fassler

18-09-27 20:58

reporter   ~0004893

Hi Patrick, I contacted QHY with this problem and they wrote back to me today only. According to them CCD Ciel software only supports small-resolution camera imaging. The camera I am using (OSC) has an array of 4952x3288 with 4.8 micron pixels. So I am not sure if this makes sense to you.
I tried also binning 2x and it did not work.

Patrick Chevalley

18-10-03 11:17

administrator   ~0004919

CCDciel support large image. At the moment I have a safeguard limit to 20000x20000 but this can be changed at any time, this is only limited by available memory.
The program work fine with a ASI1600 at 4656×3520, I also use it with my Sony RX100 at 5496x3672.

The error is raised when I access the safearray using the ImageArray ASCOM property:
https://ascom-standards.org/Help/Developer/html/P_ASCOM_DeviceInterface_ICameraV2_ImageArray.htm

I am sure the message "Can not show image with wrong size" is returned by the QHY Ascom driver because the Microsoft safearray functions probably not assume the data is an image.

Maybe a point you can look at is the size set for the image.
You say the camera is 4952x3288, but from the log you copy above the size is set to 4968x3378:
>>Camera frame x=0 y=0 width=4968 height=3378

Can you use the Frame tool in the Capture tab, click the Reset button and look at the size it set ?
If this is bigger than 4952x3288 please try to reduce the size to a valid value and take a picture.


Patrick Chevalley

18-10-25 11:40

administrator   ~0004979

An other weird ASCOM problem was fixed by a 64bit build of CCDciel.

Can you try with the new version 0.9.45 for Windows 64bit?

Peter Fassler

18-10-28 23:24

reporter   ~0004988

Hi Patrick,
I installed the new version and after I changed the frame size in frame tool in the Capture tab to the actual frames size of x-4952 y-3288 the program worked and I got a black&white photo. So, every-time I open CCDCiel I have to manually adjust the frame size as the frame size after connection the camera is automatically set at x-4968 and y-3378. As this camera (QHY 165C) is an OSC I need to see how to debayer the photo to get a color frame.

Patrick Chevalley

18-10-29 10:35

administrator   ~0004989

Hi Peter,

I need to send you a test version that log messages about the detail how it get the frame size,

The debayer options are in the Preview preferences : https://www.ap-i.net/ccdciel/en/documentation/preferences#preview

Peter Fassler

18-10-31 14:59

reporter   ~0005019

Hi Patrick,

I have now another problem. I started to get a message before opening the CCDCiel program which read, File not found, and then it opened the program. Anything I started within the program, this message, File not found, came up. So I decided to uninstall the whole program and remove everything from the computer with regard to CCDCiel and downloaded the newest version of it. Now I cannot connect the camera at all. I include a screenshot for your information. Needles to say, I have updated the ascom driver from QHY and the camera workes well with SharCap and the native program EZCAP_QT

Screenshot (14).png (269,693 bytes)
Screenshot (14).png (269,693 bytes)
Screenshot (15).png (252,131 bytes)
Screenshot (15).png (252,131 bytes)

Patrick Chevalley

18-10-31 23:25

administrator   ~0005021

From the error number this is because you install the 64bit version of CCDciel but the QHY driver is only 32bit.
Please reinstall the 32bit version, the one without x64 in the name.

Peter Fassler

18-11-01 15:09

reporter   ~0005024

Sorry Patrick, my fault. Didn't think about it. It works with the 32 bit version. Still the same problem that the initial set-up shows the wrong pixel amount.I reset it manually and then it works. However, if I want to create a bad pixel map from the camera it reverts back to the wrong pixel amount and the process is aborted.

Patrick Chevalley

18-11-03 14:02

administrator   ~0005034

OK, no problem, I asked you to install the 64bit version but now we know we must stay in 32bit for the QHY driver.

I make a test version with more log message for the ASCOM camera, specifically when setting the frame size.
Please install this version:
https://vega.ap-i.net/tmp/ccdciel-0.9.46-traceascom-windows.exe

Start CCDciel, connect the camera, go to the Frame tool and click Reset.
Copy here the resulting log.

Peter Fassler

18-11-03 20:19

reporter   ~0005036

Patrick,
I think this is what you wanted.

018-11-03T15:14:42.532 CCDciel Version beta 0.9.46-1215-da1ac5b 2018/11/03 13:48:23
2018-11-03T15:14:42.532 Compiled with: Lazarus 2.0.0.1 Free Pascal 3.0.4 Win32-i386-win32
2018-11-03T15:14:42.532 1: CCDciel Version beta 0.9.46-1215-da1ac5b initialized
2018-11-03T15:14:42.532 3: Using configuration file ccdciel.conf
2018-11-03T15:15:24.444 1: Camera connected
2018-11-03T15:15:25.526 3: ASCOM.QHYCCD.Camera: Connected
2018-11-03T15:15:26.530 2: Camera frame x=0 y=0 width=4968 height=3378
2018-11-03T15:15:26.530 3: ASCOM.QHYCCD.Camera: Get frame range :4968x3378
2018-11-03T15:15:34.936 3: ASCOM.QHYCCD.Camera: ResetFrame: XSize=4968 YSize=3378 BinX=1 BinY=1
2018-11-03T15:15:34.936 3: ASCOM.QHYCCD.Camera: Request frame 0,0/4968x3378
2018-11-03T15:15:34.936 3: ASCOM.QHYCCD.Camera: XSize=4968 YSize=3378 BinX=1 BinY=1
2018-11-03T15:15:34.936 3: ASCOM.QHYCCD.Camera: Xmax=4968 Ymax=3378
2018-11-03T15:15:34.936 3: ASCOM.QHYCCD.Camera: Set frame 0,0/4968x3378
2018-11-03T15:16:11.201 3: ASCOM.QHYCCD.Camera: ResetFrame: XSize=4968 YSize=3378 BinX=1 BinY=1
2018-11-03T15:16:11.201 3: ASCOM.QHYCCD.Camera: Request frame 0,0/4968x3378
2018-11-03T15:16:11.201 3: ASCOM.QHYCCD.Camera: XSize=4968 YSize=3378 BinX=1 BinY=1
2018-11-03T15:16:11.201 3: ASCOM.QHYCCD.Camera: Xmax=4968 Ymax=3378
2018-11-03T15:16:11.201 3: ASCOM.QHYCCD.Camera: Set frame 0,0/4968x3378

Patrick Chevalley

18-11-03 22:15

administrator   ~0005037

Yes,
In the message "Camera frame x=0 y=0 width=4968 height=3378" the values are respectively from the ASCOM properties StartX, StartY, NumX, NumY. The value are read just after the camera is connected.

In the message "XSize=4968 YSize=3378 BinX=1 BinY=1" the values are respectively from the ASCOM properties CameraXSize, CameraYSize, BinX, BinY.

I don't know why the QHY Ascom driver return this values instead of the real image size, maybe this include the overscan? But there is no other Ascom properties that can be used to find the magic 4952x3288.

To be sure if I no have a bug with the Ascom interface can you do the following :
- download the file testcamera.zip attached to this note.
- unzip in your Documents folder
- connect the camera to the computer
- open a command prompt
- open a 32bit shell, type : C:\Windows\SySWOW64\cmd.exe
- change to your documents folder, type : cd Documents
- run the script, type: cscript testcamera.js
- this open the Ascom chooser, select the QHY camera
- click OK
- this print a message in the console with CameraXSize and CameraYSize

Please report this numbers.
The attached screenshot show the console after running the script with the simulator set for a size of 4000x3000.

testcamera.zip (346 bytes)
testcamera.png (16,714 bytes)
testcamera.png (16,714 bytes)

Peter Fassler

18-11-04 02:59

reporter   ~0005039

enclosed is a screenshot of which you can see the numbers........the last one are the wrong numbers, while at the beginning of this script.

Screenshot (20).png (261,970 bytes)
Screenshot (20).png (261,970 bytes)

Patrick Chevalley

18-11-04 09:55

administrator   ~0005040

Thank you Peter.

This is good the driver print some information we can try to interpret.
For me the first block of value indicate the raw size is 4968x3378 , then it set an overscan offset of 4x82 and size of 4952x3288. This look good.
But on the next block it use a ROI of 0,0, 4968,3376, it even print a fatal error about 3378>3376.
And finally the script print the Ascom CameraXSize, CameraYSize of 4968,3378

So this is definitively a bug in the QHY ASCOM driver you must report to them, sending them your screenshot can probably help to explain the problem.

I let this issue open for now if there is other information you want to add.

Peter Fassler

18-11-05 15:18

reporter   ~0005041

Ok, Patrick, I will send this forward to Qiu from QHY and see if their programmers can make any difference, as I wrote him already several months ago that I think their ASCOM driver has a bug...so maybe this one helps better.....I will keep you posted

Peter Fassler

18-11-08 20:29

reporter   ~0005048

Hi Patrick

QHY sent me a new SDK for their ASCOM driver and when I connect the camera with other software and I disable the overscan offset I can now run the camera with the correct pixel array. With CCD Ciel however, even if I disable the overscan in the camera set up, after I connect the camera the pixel array still comes out including the overscan pixels, i.e. 4968,3378 instead of 4952 3288. So for me to use the camera with CCD ciel I will just reset the correct pixel array as then I can take pictures.....

Screenshot (22).png (427,575 bytes)
Screenshot (22).png (427,575 bytes)

Peter Fassler

18-11-11 16:15

reporter   ~0005050

Hi Patrick,

I just wanted you to show the log file once I connected the camera, it ends up with the correct pixel array on the last line, however in the frame tool the the pixel array shows always the higher number. Unfortynately I cannot run the command promt with the cscript testcamera command as I get this info you can see in the screen shot. Anyway, I just wanted to give you the latest info from what I could do...if there is anything you want to add please let me know otherwise we can close this issue. Thanks for your help. Peter

018-11-11T09:53:23.743 CCDciel Version beta 0.9.46-1215-da1ac5b 2018/11/03 13:48:23
2018-11-11T09:53:23.743 Compiled with: Lazarus 2.0.0.1 Free Pascal 3.0.4 Win32-i386-win32
2018-11-11T09:53:23.743 1: CCDciel Version beta 0.9.46-1215-da1ac5b initialized
2018-11-11T09:53:23.743 3: Using configuration file ccdciel.conf
2018-11-11T09:53:41.319 1: Camera connected
2018-11-11T09:53:42.324 3: ASCOM.QHYCCD.Camera: Connected
2018-11-11T09:53:43.327 2: Camera frame x=0 y=0 width=4968 height=3378
2018-11-11T09:53:43.389 3: ASCOM.QHYCCD.Camera: Get frame range :4952x3288

Screenshot (24).png (901,117 bytes)
Screenshot (24).png (901,117 bytes)

Patrick Chevalley

18-11-11 17:00

administrator   ~0005051

Thank you for the information!
From your log the Ascom properties CameraXSize and CameraYSize are now right with the good size.
But the default frame just after you connect the camera (properties NumX and NumY) still indicate the size + the overscan.

I make a change in the program to check if the frame size returned by the driver is not bigger than the camera size, despite we could expect a sane driver do that itself:
https://github.com/pchev/ccdciel/commit/5f3e1ef48188310de42356bd7d913cfa21b0fee7

You can download and try this test version with this change:
https://vega.ap-i.net/tmp/ccdciel-0.9.47-traceascom-windows.exe

About the scrit, it fail because you start it in a 64bit shell, you miss this step:
- open a 32bit shell, type : C:\Windows\SySWOW64\cmd.exe

Peter Fassler

18-11-11 20:15

reporter   ~0005054

We are almost there.....I forgot to set the shell type to 32 bit shell....enclosed is now the screenshot of the script...it looks good to me...using your new test version I induced another screenshot showing that the camera is now connected with the correct x,y values, but trying to to make an exposure it hangs with the exposure light on until I click on stop..I included also the log where you can see what's happening

Screenshot (25).png (1,092,995 bytes)
Screenshot (26).png (263,995 bytes)
Screenshot (26).png (263,995 bytes)

Patrick Chevalley

18-11-11 21:23

administrator   ~0005055

OK, this is because I correct the values in CCDciel but they are not set in the driver.
This must be fixed by a new change that also log what happen when it set the new value.

The new version to try:
https://vega.ap-i.net/tmp/ccdciel-0.9.47-1220-windows.exe

If this version work please also make some test with other binning to be sure there is no unwanted side effect because of this change.

Peter Fassler

18-11-12 19:39

reporter   ~0005058

Patrick, this version works great...I tried also binning 2x and had no problem.......I assume this closes this issues...Thanks for all your help
Peter

Patrick Chevalley

18-11-12 20:22

administrator   ~0005060

Great!
Thank you for all your testing and for convincing QHY to fix this issue.
I hope this change apply also to the other camera and it will be available to all users soon.

Issue History

Date Modified Username Field Change
18-07-11 16:45 Peter Fassler New Issue
18-09-19 11:30 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-19 11:30 Patrick Chevalley Status new => feedback
18-09-19 11:30 Patrick Chevalley Target Version => 1.0
18-09-19 11:30 Patrick Chevalley Note Added: 0004866
18-09-27 20:58 Peter Fassler Note Added: 0004893
18-09-27 20:58 Peter Fassler Status feedback => assigned
18-10-03 11:17 Patrick Chevalley Status assigned => feedback
18-10-03 11:17 Patrick Chevalley Note Added: 0004919
18-10-25 11:40 Patrick Chevalley Note Added: 0004979
18-10-28 23:24 Peter Fassler Note Added: 0004988
18-10-28 23:24 Peter Fassler Status feedback => assigned
18-10-29 10:35 Patrick Chevalley Note Added: 0004989
18-10-31 14:59 Peter Fassler File Added: Screenshot (14).png
18-10-31 14:59 Peter Fassler File Added: Screenshot (15).png
18-10-31 14:59 Peter Fassler Note Added: 0005019
18-10-31 23:25 Patrick Chevalley Note Added: 0005021
18-11-01 15:09 Peter Fassler Note Added: 0005024
18-11-03 14:02 Patrick Chevalley Status assigned => feedback
18-11-03 14:02 Patrick Chevalley Note Added: 0005034
18-11-03 20:19 Peter Fassler Note Added: 0005036
18-11-03 20:19 Peter Fassler Status feedback => assigned
18-11-03 22:15 Patrick Chevalley File Added: testcamera.zip
18-11-03 22:15 Patrick Chevalley File Added: testcamera.png
18-11-03 22:15 Patrick Chevalley Note Added: 0005037
18-11-04 02:59 Peter Fassler File Added: Screenshot (20).png
18-11-04 02:59 Peter Fassler Note Added: 0005039
18-11-04 09:55 Patrick Chevalley Note Added: 0005040
18-11-04 09:57 Patrick Chevalley Status assigned => confirmed
18-11-05 15:18 Peter Fassler Note Added: 0005041
18-11-08 20:29 Peter Fassler File Added: Screenshot (22).png
18-11-08 20:29 Peter Fassler Note Added: 0005048
18-11-11 16:15 Peter Fassler File Added: Screenshot (24).png
18-11-11 16:15 Peter Fassler Note Added: 0005050
18-11-11 17:00 Patrick Chevalley Note Added: 0005051
18-11-11 20:15 Peter Fassler File Added: Screenshot (25).png
18-11-11 20:15 Peter Fassler File Added: Screenshot (26).png
18-11-11 20:15 Peter Fassler Note Added: 0005054
18-11-11 21:23 Patrick Chevalley Note Added: 0005055
18-11-12 19:39 Peter Fassler Note Added: 0005058
18-11-12 20:22 Patrick Chevalley Status confirmed => resolved
18-11-12 20:22 Patrick Chevalley Resolution open => fixed
18-11-12 20:22 Patrick Chevalley Note Added: 0005060
19-04-05 22:43 Patrick Chevalley Relationship added related to 0002105