View Issue Details

IDProjectCategoryView StatusLast Update
0001963CCdciel[All Projects] Generalpublic18-09-23 17:31
ReporterAlexander VarakinAssigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001963: Date/time is not updated to the mount upon startup
DescriptionI am using OnStep motor driver and noticed that Date/time is not updated to the mount upon startup, so the clock in the mount is totally wrong which makes pointing the mount incorrect.

I did not notice this behavior with EQMOD, although the reason for this might be that in case of EQMOD all calculations are done on PC, whereas with Onstep it is done in the mount.

On the other hand, Kstars does set the correct date/time during startup.
Steps To ReproduceConnect to Onstep motor driver and observe that timestamp in the "Site Management" tab is incorrect.
I suspect that same behavior can be reproduced with any mount, except EQMOD.
TagsNo tags attached.

Activities

Patrick Chevalley

18-09-18 13:22

administrator   ~0004847

Yes, at the moment nothing is done to set the mount time at startup.

There is several reason for that, one is that many mount require to do the alignment with the handpad before to connect to the computer, so the time must be set correctly in the mount before the connection and not changed later.
Another half of the user may want the computer time to be set from the mount because it include an accurate GPS unit.
And finally you want to set the mount time from the computer at startup.

This require to add an option with this 3 choices:
- do nothing
- set computer time from mount
- set mount time from computer

Before I add this option you can just open the INDI dialog for the mount to set the time.

Patrick Chevalley

18-09-23 17:30

administrator   ~0004881

Last edited: 18-09-23 17:31

View 2 revisions

I add the option to set the mount time when connecting.
I not add an option to set the computer time because this require administrator privilege and I not want users run ccdciel as administrator.
There is also an option to send the configured observatory coordinates to the mount.

When activating this options you must be sure the mount is not aligned when you connect ccdciel. Otherwise you may have to redo the alignment procedure.

https://github.com/pchev/ccdciel/commit/1d998842140c5ae2f76e21d135a05e3b8e935f24

Issue History

Date Modified Username Field Change
18-07-15 17:44 Alexander Varakin New Issue
18-09-18 13:22 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-18 13:22 Patrick Chevalley Status new => assigned
18-09-18 13:22 Patrick Chevalley Target Version => 1.0
18-09-18 13:22 Patrick Chevalley Note Added: 0004847
18-09-23 17:30 Patrick Chevalley Status assigned => resolved
18-09-23 17:30 Patrick Chevalley Resolution open => fixed
18-09-23 17:30 Patrick Chevalley Note Added: 0004881
18-09-23 17:31 Patrick Chevalley Note Edited: 0004881 View Revisions