View Issue Details

IDProjectCategoryView StatusLast Update
0001978CCdciel[All Projects] Generalpublic19-06-08 18:51
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version 
Target Version1.0Fixed in Version 
Summary0001978: Adding a "pause" button to control a sequence
DescriptionIn the sequence tab there are to buttons "Start" and "Stop". Is it possible to add a pause button?

Thomas
TagsNo tags attached.

Relationships

has duplicate 0002026 resolvedPatrick Chevalley Suggestion : pause sequence button 
related to 0002025 assignedPatrick Chevalley Suggestion : cancel exposure button 

Activities

Thomas Jaeger

18-09-05 22:49

reporter  

screen.jpg (222,683 bytes)
screen.jpg (222,683 bytes)

Patrick Chevalley

18-09-18 14:13

administrator   ~0004850

Last edited: 18-09-18 14:14

View 2 revisions

This is something I want to add but probably not before version 2.0, after the new scheduler is implemented.

At the moment it is even difficult to stop a sequence, see 0001974 .
So restarting after that can be challenging.
  
We also need to clarify what the pause button do exactly, do it abort the current operation or wait for completion ?
Waiting can be long in the case of an exposure, it can also be long and useless in the case of auto-focus.
Aborting must be done in a way the operation can be restarted, ensuring the telescope is not moving away, or the camera is not let in a unusable state.

han

18-09-21 09:39

reporter   ~0004874

Last edited: 18-09-21 09:44

View 2 revisions

I agree it is a good idea. Sometimes I'm not happy with the focus and would like to have the possibility to start an extra autofocus run. An other reason could be a sudden loss of guiding due to mechanical problems and you want to reposition the telescope pointing. A third reason could be the desire to modify the sequence halfway.

I assume it is difficult to implement. It is a wish, not a must. :)

Thomas Jaeger

18-09-21 13:51

reporter   ~0004876

IIt is a wish for 2.0.
After pressing pause there might be a ask from CCDCiel :
1. Pause and discard runnung exposure
2. Pause and complete running exposure
3. Pause after completion of running step
Thomas

Patrick Chevalley

19-06-08 18:50

administrator   ~0005685

This is solved with the new option "Keep completion status" available in next version 0.9.57.
The documentation:
https://www.ap-i.net/ccdciel/en/documentation/sequence#restarting_a_sequence

You can simply use the Stop button to interrupt the sequence and click Start when ready to continue.

The new Reset button clear the completion status and allow to restart the full sequence from the beginning.

Issue History

Date Modified Username Field Change
18-09-05 22:49 Thomas Jaeger New Issue
18-09-05 22:49 Thomas Jaeger File Added: screen.jpg
18-09-18 14:13 Patrick Chevalley Target Version => 2.0
18-09-18 14:13 Patrick Chevalley Note Added: 0004850
18-09-18 14:13 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-18 14:13 Patrick Chevalley Status new => assigned
18-09-18 14:14 Patrick Chevalley Note Edited: 0004850 View Revisions
18-09-21 09:39 han Note Added: 0004874
18-09-21 09:44 han Note Edited: 0004874 View Revisions
18-09-21 13:51 Thomas Jaeger Note Added: 0004876
18-11-16 22:05 Patrick Chevalley Relationship added related to 0001894
18-11-16 22:05 Patrick Chevalley Relationship added has duplicate 0002026
18-11-17 21:05 Patrick Chevalley Relationship added related to 0002025
19-06-08 18:50 Patrick Chevalley Status assigned => resolved
19-06-08 18:50 Patrick Chevalley Resolution open => fixed
19-06-08 18:50 Patrick Chevalley Target Version 2.0 => 1.0
19-06-08 18:50 Patrick Chevalley Note Added: 0005685
19-06-08 18:51 Patrick Chevalley Relationship deleted related to 0001894