View Issue Details

IDProjectCategoryView StatusLast Update
0001983CCdcielGeneralpublic18-09-20 09:44
ReporterThomas Jaeger Assigned ToPatrick Chevalley  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLinux 
Product Version0.9 
Target Version1.0 
Summary0001983: Unable to do flats via capture tool
DescriptionHello,
I prepared to do flats and get some strange error.
I wanted to do flats without the help of a sequence, only use the capture tool. The tool does the following, it finds the exact exposure time, but than it does not do flats at all.
It it shown in the log. A restart of ciel does not help.

Flats with a sequence work well.

Thomas
TagsNo tags attached.

Activities

Thomas Jaeger

18-09-19 19:12

reporter  

Log_20180919_185934.log (1,866 bytes)   
2018-09-19T18:59:34.199  CCDciel Version beta 0.9.41-1138-fa3bf90 2018/07/07 20:04:17
2018-09-19T18:59:34.199  Compiled with: Lazarus 1.8.2.0 Free Pascal 3.0.4 Linux-x86_64-gtk2
2018-09-19T18:59:34.199 1: CCDciel Version beta 0.9.41-1138-fa3bf90 initialized
2018-09-19T18:59:36.538 2: Connecting Camera...
2018-09-19T18:59:36.545 2: Connecting Filter wheel...
2018-09-19T18:59:36.552 2: Connecting Focuser...
2018-09-19T18:59:36.665 2: Connecting Camera...
2018-09-19T18:59:36.668 2: Connecting Camera...
2018-09-19T18:59:36.767 1: Filter wheel connected
2018-09-19T18:59:36.778 1: Focuser connected
2018-09-19T18:59:36.893 2: Camera frame x=0 y=0 width=5496 height=3672
2018-09-19T18:59:36.893 2: Camera cooler : True
2018-09-19T18:59:39.886 1: Camera connected
2018-09-19T18:59:40.947 3: ZWO CCD ASI183MM Pro: Set temperature -20.0
2018-09-19T18:59:49.426 2: Start capture
2018-09-19T18:59:49.427 3: ZWO CCD ASI183MM Pro: Set frame type Light   
2018-09-19T18:59:49.427 1: Starting Light exposure 1 for 0.328 seconds
2018-09-19T19:00:04.315 1: Saved file /home/starhopper/CCD/Light/Sh2-112_L_111_0_328s_20180919_170003.fits
2018-09-19T19:00:04.330 1: Starting Light exposure 2 for 0.328 seconds
2018-09-19T19:00:18.804 1: Saved file /home/starhopper/CCD/Light/Sh2-112_L_111_0_328s_20180919_170018.fits
2018-09-19T19:00:18.816 1: Starting Light exposure 3 for 0.328 seconds
2018-09-19T19:00:26.365 3: ZWO CCD ASI183MM Pro: Abort exposure
2018-09-19T19:00:26.365 2: Abort exposure
2018-09-19T19:00:26.367 2: Stop capture
2018-09-19T19:00:39.110 2: Start capture
2018-09-19T19:00:39.111 3: ZWO CCD ASI183MM Pro: Set frame type Flat    
2018-09-19T19:00:39.111 1: Starting Flat exposure 1 for 0.328 seconds
2018-09-19T19:00:53.366 2: Flat level=65504
2018-09-19T19:00:53.370 1: Reach configured minimum flat exposure time!
2018-09-19T19:00:53.370 1: Stop flat capture
Log_20180919_185934.log (1,866 bytes)   

Patrick Chevalley

18-09-19 21:39

administrator   ~0004870

In the log it say it reach the minimum exposure time you configure, but the flat is still saturated with a mean level of 65504.
So it abandon the procedure because it need a shorter exposure time but it cannot.

What are your setting for min/max exposure time and flat level in this page :
https://www.ap-i.net/ccdciel/en/documentation/preferences#flat

Thomas Jaeger

18-09-19 22:33

reporter   ~0004871

Sorry Patrick, must be blind.
Thomas

Patrick Chevalley

18-09-20 09:44

administrator   ~0004872

No problem.

I remark an inconsistency with this message send only for sky flat, but panel flat continue with the wrong image level.
It is probably better to also stop to adjust the panel power or the parameters.
This is fixed by:
https://github.com/pchev/ccdciel/commit/0a5269a70eaaac0e9da8c6f45c1ee64871338b8a

Issue History

Date Modified Username Field Change
18-09-19 19:12 Thomas Jaeger New Issue
18-09-19 19:12 Thomas Jaeger File Added: Bildschirmfoto vom 2018-09-19 19-01-03.png
18-09-19 19:12 Thomas Jaeger File Added: Log_20180919_185934.log
18-09-19 21:39 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-19 21:39 Patrick Chevalley Status new => feedback
18-09-19 21:39 Patrick Chevalley Note Added: 0004870
18-09-19 22:33 Thomas Jaeger Note Added: 0004871
18-09-19 22:33 Thomas Jaeger Status feedback => assigned
18-09-20 09:44 Patrick Chevalley Note Added: 0004872
18-09-20 09:44 Patrick Chevalley Status assigned => resolved
18-09-20 09:44 Patrick Chevalley Resolution open => fixed
18-09-20 09:44 Patrick Chevalley Target Version => 1.0