View Issue Details

IDProjectCategoryView StatusLast Update
0001989CCdciel[All Projects] Generalpublic18-10-09 22:06
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0001989: Starting Light Exposure before Settling complete - please reopen 0001923
DescriptionHello Patrick,
the issue described in 0001923 seems not to be gone. See my log from tonight.
I realized it too late, because I had to bother with my family. Restarted CCDCiel, cutting the sequence...running
Thomas
TagsNo tags attached.

Activities

Thomas Jaeger

18-09-27 23:01

reporter  

Log_20180927_164602.log (49,270 bytes)

Thomas Jaeger

18-09-27 23:02

reporter   ~0004894

I would give it a high priority to solve.

Patrick Chevalley

18-09-28 09:05

administrator   ~0004895

I continue to follow this issue here instead of reopenning because this is probably not exactly the same issue.

This is strange, for the first two series between autofocus starting at 20:49:34 and 21:26:32 there is two wrong exposure starting before settling, followed by 5 good exposure that waited for settling.
For the third series starting at 22:03:28 there is 6 wrong followed by 1 good.
The last one started by a wrong exposure you aborted.

Can you upload the PHD2 debug log for this session so I can see exactly when the settling message where send?

Thomas Jaeger

18-09-29 08:17

reporter   ~0004900

i hope these are the files you want
Thomas

Log_20180927_164602-2.log (49,270 bytes)
PHD2_GuideLog_2018-09-27_195553.txt (1,293,613 bytes)

Thomas Jaeger

18-09-29 08:20

reporter  

PHD2_DebugLog_2018-09-27_195553.txt.tar.gz (4,519,642 bytes)

Thomas Jaeger

18-09-29 08:20

reporter   ~0004901

debug.log

Patrick Chevalley

18-09-29 11:18

administrator   ~0004902

Thank you for the files.
Unfortunately I cannot find what is wrong here. I try to reproduce your sequence but for me it always wait for dithering.

I make a test version with a message that detail the condition of the dithering wait loop.
Can you download and install this test version before to make a new test and send me the CCDciel log:
https://vega.ap-i.net/tmp/ccdciel_0.9.42-1155_amd64.deb

Thomas Jaeger

18-09-29 13:12

reporter   ~0004908

Sure, I will give feedback.
Thomas

Thomas Jaeger

18-09-30 17:52

reporter   ~0004912

I have installed it. Maybe it will be clear at thursday.
Thomas

Thomas Jaeger

18-09-30 21:32

reporter   ~0004913

The weather hat not changed yet, so I am looking forward to image until midnight, but the test version you provide is not usable because of a new issue, not happend before.

Autofocus works only once, than it failed. I restarted ccdciel, but the behaviour was the same. I want to continue my sequence so I deinstalled this version an revert to the previous.

2018-09-30T20:57:29.876 2: Autofocus start Dynamic curve
2018-09-30T20:57:29.876 2: Focuser temperature: 20.0
2018-09-30T20:57:29.876 2: AutoFocus started, initial position: 9652
2018-09-30T20:57:36.445 0: Autofocus canceled because no star was selected.
2018-09-30T20:57:36.446 3: ZWO CCD ASI183MM Pro: Set binning 1x1
2018-09-30T20:57:36.679 1: AutoFocus error

Log_20180930_203358.log (28,985 bytes)

Patrick Chevalley

18-10-01 09:42

administrator   ~0004914

Sorry for this error I make when trying to improve the stop of a sequence.
This is fixed by:
https://github.com/pchev/ccdciel/commit/3dd5eb9c553ac7c114919e6814e0d80028c241af

You can install the new test version from:
https://vega.ap-i.net/tmp/ccdciel_0.9.42-1158_amd64.deb

The good new is that all the exposure waited for dithering in your last log.

Thomas Jaeger

18-10-01 17:41

reporter   ~0004916

I will try your built 1158 at the next clear evening. Now it is cloudy here.
Thomas

Thomas Jaeger

18-10-06 09:32

reporter   ~0004926

Half the night it was perfect clear. I grab your provided version and made a sequence. I cannot see the issue anymore, but this must not be representative.

Here is the log. At 2h I got up from bed and pointed the scope to another target. At 4 it must have been clouded.
Maybe you can have a look at my issue with VirtualMoonAtlas.

Thomas

Log_20181005_201547.log (323,499 bytes)

Patrick Chevalley

18-10-06 10:12

administrator   ~0004927

Yes, we cannot be sure because the condition that produce the error the last time is not know.
I keep the additional message but I change it to be written only in the log file to not mess the console log.
https://github.com/pchev/ccdciel/commit/c241159db214e9472e9ee94fdf174e9952160029

Sorry, I forget to look at VMA issue this last days, I reply now.

Thomas Jaeger

18-10-09 21:09

reporter   ~0004938

Sorry Patrick,
in my recent session, the issue appeared again.
I hope the log helps. I had to restart CCDCiel to continue my sequence.
Thomas

2018-10-09T20:15:33.441 2: Autoguider: Guiding Dithered
2018-10-09T20:15:34.370 1: Starting Light exposure 2 for 240 seconds
2018-10-09T20:15:35.407 2: Autoguider: Settling
2018-10-09T20:15:47.425 2: Autoguider: Settle Done
2018-10-09T20:15:47.439 2: Autoguider: Guiding

Log_20181009_185251.log (41,722 bytes)

Patrick Chevalley

18-10-09 22:06

administrator   ~0004939

Yes, very good. your log nicely show the problem.
The bad guy is "FStopGuiding=True"

The sequence that produce the error is:
- at the end of the flat sequence the program set this value as part of "Stop autoguider" at 19:48:52
- you start the autoguider directly from phd2 so this value "FStopGuiding=True" is not reset
- at the start of the sequence the autofocus procedure just pause the guiding, this again not reset the value
- guiding resume
- dithering exit immediately because of this value, he think you stopped guiding now and it must not wait for settling anymore.

This is fixed by resetting "FStopGuiding=False" in the Pause and Dither command:
https://github.com/pchev/ccdciel/commit/ff5e433d21f0838f8158304833a7d281a13232a5

New version 0.9.43 is compiling now and will be available in 30 minutes.

I close the issue now but please reopen if you get it again.
I let the extra trace message in place for a few more week.

Issue History

Date Modified Username Field Change
18-09-27 23:01 Thomas Jaeger New Issue
18-09-27 23:01 Thomas Jaeger File Added: Log_20180927_164602.log
18-09-27 23:02 Thomas Jaeger Note Added: 0004894
18-09-28 09:05 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-28 09:05 Patrick Chevalley Status new => assigned
18-09-28 09:05 Patrick Chevalley Target Version => 1.0
18-09-28 09:05 Patrick Chevalley Note Added: 0004895
18-09-29 08:17 Thomas Jaeger File Added: PHD2_GuideLog_2018-09-27_195553.txt
18-09-29 08:17 Thomas Jaeger File Added: Log_20180927_164602-2.log
18-09-29 08:17 Thomas Jaeger Note Added: 0004900
18-09-29 08:20 Thomas Jaeger File Added: PHD2_DebugLog_2018-09-27_195553.txt.tar.gz
18-09-29 08:20 Thomas Jaeger Note Added: 0004901
18-09-29 11:18 Patrick Chevalley Status assigned => feedback
18-09-29 11:18 Patrick Chevalley Note Added: 0004902
18-09-29 13:12 Thomas Jaeger Note Added: 0004908
18-09-29 13:12 Thomas Jaeger Status feedback => assigned
18-09-30 17:52 Thomas Jaeger Note Added: 0004912
18-09-30 21:32 Thomas Jaeger File Added: Log_20180930_203358.log
18-09-30 21:32 Thomas Jaeger Note Added: 0004913
18-10-01 09:42 Patrick Chevalley Note Added: 0004914
18-10-01 17:41 Thomas Jaeger Note Added: 0004916
18-10-06 09:32 Thomas Jaeger File Added: Log_20181005_201547.log
18-10-06 09:32 Thomas Jaeger Note Added: 0004926
18-10-06 10:12 Patrick Chevalley Note Added: 0004927
18-10-09 21:09 Thomas Jaeger File Added: Log_20181009_185251.log
18-10-09 21:09 Thomas Jaeger Note Added: 0004938
18-10-09 22:06 Patrick Chevalley Status assigned => resolved
18-10-09 22:06 Patrick Chevalley Resolution open => fixed
18-10-09 22:06 Patrick Chevalley Note Added: 0004939