View Issue Details

IDProjectCategoryView StatusLast Update
0001992CCdciel[All Projects] Generalpublic18-10-23 15:41
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0001992: Auto focus interval is working on sequence but not on steps.
DescriptionAuto focus interval is not working if you enter 999 steps. Is this intentional or should it?

See attached to screen shots:

TagsNo tags attached.

Activities

han

18-09-28 21:11

reporter  

han

18-09-28 21:49

reporter   ~0004898

Last edited: 18-09-28 21:50

View 2 revisions

It is getting more confusing. For the second image "sequence focus interval2, it is focussing every image! I will test it tommorow in simulation.

han

18-09-29 11:40

reporter   ~0004903

Last edited: 18-09-29 11:41

View 2 revisions

Testing again in simulation confirms weird behavior:

Sequence interval 999, Step interval 1, autofocus every 4, autofocus before start on ===> Autofocus for every image.
Sequence interval 999, Step interval 1, autofocus every 4, autofocus before start off ===> No autofocus

See attached two screen shots of the settings used:



log and sequence.zip (5,006 bytes)
autofocus every image.png (29,082 bytes)
autofocus every image.png (29,082 bytes)
no autofocus.png (32,850 bytes)
no autofocus.png (32,850 bytes)

han

18-09-29 11:48

reporter   ~0004904

Moving the repeat to the step, I get this behavior:

Sequence interval 1, Step interval 999, autofocus every 4, autofocus before start on ===> Autofocus only first image
Sequence interval 1, Step interval 999, autofocus every 4, autofocus before start off ===> No autofocus

Patrick Chevalley

18-09-29 12:23

administrator   ~0004907

At the moment the "Autofocus every..." do not work on repetition but only for the "Count" of the steps.

If your step as count=10 and autofocus_every=4 , the autofocus will be done two time after exposure 4 and 8.
Buf if you configure with count=1 and repeat=10 it will never autofocus.

This is because a step only fill the Capture tab with it's option and start the capture. So the frame counter is reset at every repetition.

It is probably difficult to change this behavior without introducing unwanted side effect, principally when using the Capture tool alone.

Is there any reason you use repetition instead of increasing the count value?

han

18-09-29 14:00

reporter   ~0004910

Last edited: 18-09-29 14:43

View 3 revisions

Now it becomes clear. I missed the option count. Confusing to have a count and repeat. Now using plan count it works. :)

Why it there both an option step and repeat? You can do everything with count. I would remove the repeat to make it simpler and prevent confusion. Saves also space in the menus.

Still there is an other display problem. The counter is not shown in the sequence tool for the case count=999 and repeat=1. That would be my imaging approach for deep sky, one object whole night. It is only updated if repeat reaches 2. I should display both plan count and plan repeat also in the beginning. Or as above suggested remove repeat from the menu and use count for everything.

And finally:
- The title locations are a little confusing. The step title is below but correct located together with the step buttons (ignore sketch) but the title of the sequence file could move to caption.
- Can the default save name of a new sequence been set to the (last) object name. That is convenient if you import target from the planetarium program. Otherwise I have to type a name using a keyboard in the dark.



sequence layout.png (33,826 bytes)
sequence layout.png (33,826 bytes)

Patrick Chevalley

18-10-23 15:41

administrator   ~0004967

The difference between Repeat and Count is you can set a delay between the exposures, useful to make a series of an eclipse for example.
But I agree this can be done at the target level so this option is redundant.
It is now removed:
https://github.com/pchev/ccdciel/commit/0530fb51807369536974182963d56725b337114d

This change use the last object name in the list as default sequence name:
https://github.com/pchev/ccdciel/commit/e4fabc9046b7b7d22a9aec77a0d892489269228c

I also relocate the title as you suggest and make some other clarification in the display.

Issue History

Date Modified Username Field Change
18-09-28 21:10 han New Issue
18-09-28 21:11 han File Added: sequence focus interval.png
18-09-28 21:11 han File Added: sequence focus interval2.png
18-09-28 21:49 han Note Added: 0004898
18-09-28 21:50 han Note Edited: 0004898 View Revisions
18-09-29 11:40 han File Added: autofocus every image.png
18-09-29 11:40 han File Added: no autofocus.png
18-09-29 11:40 han File Added: log and sequence.zip
18-09-29 11:40 han Note Added: 0004903
18-09-29 11:41 han Note Edited: 0004903 View Revisions
18-09-29 11:48 han Note Added: 0004904
18-09-29 12:23 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-29 12:23 Patrick Chevalley Status new => assigned
18-09-29 12:23 Patrick Chevalley Target Version => 1.0
18-09-29 12:23 Patrick Chevalley Note Added: 0004907
18-09-29 14:00 han File Added: sequence counter missing.png
18-09-29 14:00 han File Added: sequence layout.png
18-09-29 14:00 han Note Added: 0004910
18-09-29 14:37 han Note Edited: 0004910 View Revisions
18-09-29 14:43 han Note Edited: 0004910 View Revisions
18-10-23 15:41 Patrick Chevalley Status assigned => resolved
18-10-23 15:41 Patrick Chevalley Resolution open => fixed
18-10-23 15:41 Patrick Chevalley Note Added: 0004967