View Issue Details

IDProjectCategoryView StatusLast Update
0002002CCdciel[All Projects] Generalpublic18-10-29 21:16
ReporterSerg10Assigned ToPatrick Chevalley 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002002: Access violation 0.9.45
DescriptionWhen you start the version beta 0.9.45-1203-b5b4bea of the program, the message "Access violation" appears. If you click OK, the program starts.
TagsNo tags attached.

Activities

Serg10

18-10-26 19:28

reporter  

2018-10-26_21-16-49.png (32,375 bytes)
2018-10-26_21-16-49.png (32,375 bytes)

Patrick Chevalley

18-10-26 20:20

administrator   ~0004982

I cannot reproduce the problem. Can you give me more details.

- is windows 7 32 or 64 bit?
- is ccdciel 32 or 64 bit ?
- if ccdciel is 32 bit do you install today version ccdciel-0.9.45-1203-1-windows.exe

- is the main window already show when you get this message?
- after you click OK and the program start, is all the tool box visible?
- is any special message in the log?
- can you take a image preview from the camera?

Cedric Raguenaud

18-10-29 15:54

reporter   ~0004993

I didn't report this bug but I'm getting the same thing with Windows 10 64 bits, ccdciel 32 bits (the right one). It appears before the main window or anything else. After clicking OK, everything is fine.

Interestingly it doesn't happen when running from Lazarus (could be that some of the config files aren't shared).

Cedric Raguenaud

18-10-29 15:55

reporter   ~0004994

The log file doesn't show anything:
2018-10-29T15:55:25.049 CCDciel Version beta 0.9.45-1203-b5b4bea 2018/10/26 16:50:55
2018-10-29T15:55:25.049 Compiled with: Lazarus 2.0.0.1 Free Pascal 3.0.4 Win32-i386-win32
2018-10-29T15:55:25.050 1: CCDciel Version beta 0.9.45-1203-b5b4bea initialized
2018-10-29T15:55:25.050 3: Using configuration file ccdciel.conf
2018-10-29T15:55:25.197 1: TCP/IP server listen on port: 3277

Patrick Chevalley

18-10-29 16:31

administrator   ~0004995

Cedric,
When you try from Lazarus be sure you use the version 2.0 RC1 and you also installed the cross-i386 to compile for 32bit.
Try to compile for 32bit windows in Debug and in Releases mode.

This is important if you can reproduce the issue from Lazarus because I cannot reproduce the problem in a virtual machine or with my real system.

Cedric Raguenaud

18-10-29 16:47

reporter   ~0004996

I used the version of Lazarus below with the compile options in the screencap.

Sorry, I'm totally new at Lazarus and FPC so I don't know my way yet.

ccdciel.png (39,166 bytes)
ccdciel.png (39,166 bytes)
lazarus.png (109,654 bytes)
lazarus.png (109,654 bytes)

Cedric Raguenaud

18-10-29 16:54

reporter   ~0004997

I'll install 2.0rc1 win32 and try again.

Cedric Raguenaud

18-10-29 17:11

reporter   ~0004998

With Lazarus 2.0rc1 win32, building with the same options can't run ccdciel at all. I get the following error.

sigsegv.png (4,781 bytes)
sigsegv.png (4,781 bytes)
assembly.png (25,671 bytes)
assembly.png (25,671 bytes)

Patrick Chevalley

18-10-29 17:40

administrator   ~0004999

Good, when you get the exception and the assembly break point, open the Lazarus menu View/Debug windows/Call Stack

In the Call Stack window eventually click "Max 10" to change to "Max 50", and copy the screen here.

Cedric Raguenaud

18-10-29 19:35

reporter   ~0005000

Here it is.

callstack.png (64,134 bytes)
callstack.png (64,134 bytes)

Cedric Raguenaud

18-10-29 19:40

reporter   ~0005001

It looks like a component problem:
f_EditTargets.FGainEdit.Value:=poscapt; (line 3032 in pu_main)
-> type TSPINEDIT has no component named Value. I can't reaqlly investigate much more easily.

Patrick Chevalley

18-10-29 21:16

administrator   ~0005002

Thank you!

The problem was in the Change event for this component, I wrongly tested if the target list is empty resulting in using an uninitialized variable.
I have difficulties to reproduce because this condition is only if the camera use numeric gain (not ISO), and the gain in capture is set.

This is fixed by:
https://github.com/pchev/ccdciel/commit/fa8df14289c89c10d9d0823b953e55be9ff4528b

New version 0.9.46 with the fix is currently building, available on Sourceforge in 15 minutes.

Issue History

Date Modified Username Field Change
18-10-26 19:26 Serg10 New Issue
18-10-26 19:28 Serg10 File Added: 2018-10-26_21-16-49.png
18-10-26 20:20 Patrick Chevalley Assigned To => Patrick Chevalley
18-10-26 20:20 Patrick Chevalley Status new => feedback
18-10-26 20:20 Patrick Chevalley Target Version => 1.0
18-10-26 20:20 Patrick Chevalley Note Added: 0004982
18-10-29 15:54 Cedric Raguenaud Note Added: 0004993
18-10-29 15:55 Cedric Raguenaud Note Added: 0004994
18-10-29 16:31 Patrick Chevalley Note Added: 0004995
18-10-29 16:47 Cedric Raguenaud File Added: lazarus.png
18-10-29 16:47 Cedric Raguenaud File Added: ccdciel.png
18-10-29 16:47 Cedric Raguenaud Note Added: 0004996
18-10-29 16:54 Cedric Raguenaud Note Added: 0004997
18-10-29 17:11 Cedric Raguenaud File Added: sigsegv.png
18-10-29 17:11 Cedric Raguenaud File Added: assembly.png
18-10-29 17:11 Cedric Raguenaud Note Added: 0004998
18-10-29 17:40 Patrick Chevalley Note Added: 0004999
18-10-29 19:35 Cedric Raguenaud File Added: callstack.png
18-10-29 19:35 Cedric Raguenaud Note Added: 0005000
18-10-29 19:40 Cedric Raguenaud Note Added: 0005001
18-10-29 21:16 Patrick Chevalley Status feedback => resolved
18-10-29 21:16 Patrick Chevalley Resolution open => fixed
18-10-29 21:16 Patrick Chevalley Note Added: 0005002