View Issue Details

IDProjectCategoryView StatusLast Update
0002005CCdciel[All Projects] Generalpublic18-10-30 14:02
ReporterCedric RaguenaudAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 32bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002005: In sequence editor, adding new object ignores name
DescriptionIn the sequence editor, when you have existing targets and you click on "new object", the name you provide is ignored and instead the name of the target currently selected is used.

The code seems to do it on purpose (maybe a shortcut for duplication of the current row?):
  txt:=FormEntry(self, rsObjectName, 'None');
  if txt=ScriptTxt then txt:='_Script';
  t:=TTarget.Create;
  n:=TargetList.Row;
  if n>=1 then begin
    tt:=TTarget(TargetList.Objects[colseq,n]);
    if (tt.objectname<>ScriptTxt) and (tt.objectname<>SkyFlatTxt) then t.Assign(tt);
  end;

But the object's should be the one provided by the user since there is no way I can see to not select any row.
Steps To ReproduceWhat about this?

  txt:=FormEntry(self, rsObjectName, 'None');
  if txt=ScriptTxt then txt:='_Script';
  t:=TTarget.Create;
  n:=TargetList.Row;
  if n>=1 then begin
    tt:=TTarget(TargetList.Objects[colseq,n]);
    if (tt.objectname<>ScriptTxt) and (tt.objectname<>SkyFlatTxt) then
     begin
       t.Assign(tt);
       t.objectname:=txt;
     end;
  end;
TagsNo tags attached.

Activities

Patrick Chevalley

18-10-30 14:02

administrator   ~0005008

This was originally set by the row:
TargetList.Cells[colname,i]:=txt;
but a later change break it.

Your fix work fine, thank you:
https://github.com/pchev/ccdciel/commit/eb0c8d5384a85597bd8329258c633e94a28c3d27

Issue History

Date Modified Username Field Change
18-10-30 11:21 Cedric Raguenaud New Issue
18-10-30 14:02 Patrick Chevalley Assigned To => Patrick Chevalley
18-10-30 14:02 Patrick Chevalley Status new => resolved
18-10-30 14:02 Patrick Chevalley Resolution open => fixed
18-10-30 14:02 Patrick Chevalley Target Version => 1.0
18-10-30 14:02 Patrick Chevalley Note Added: 0005008