View Issue Details

IDProjectCategoryView StatusLast Update
0002007CCdciel[All Projects] Generalpublic18-11-19 18:17
ReporterCedric RaguenaudAssigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002007: Suggestion: Move some options from sequence object to plan?
DescriptionOptions "use astrometry", "stay in place", and "update RA+DEC" in the sequence editor might better moved to the plan sections: they'd apply to the same thing (the target in general so no change in function) but for long sequences (e.g. variable stars scan) it's a lot of clicking to activate them for all targets when having it in plan means it can be done once.
TagsNo tags attached.

Activities

Cedric Raguenaud

18-10-30 14:23

reporter   ~0005010

Maybe not "update RA+DEC", which could be more linked to a specific use of the plan.

Patrick Chevalley

18-10-30 17:14

administrator   ~0005012

This options are really related to the target, I put them on the side only because I not have enough space on the grid. The program must work on 1024 screen.

"use astrometry" is automatically activated when the coordinates are set from the planetarium or current image. Maybe it can also be activated when you type the coordinates. (if astrometry is configured)

The default value for "stay in place" is configured in Preferences/Autofocus.
But you may want to change it by target, typically it is easy to stay in place for targets in the milky way but more difficult near the galactic pole because there is less stars.

"update RA+DEC" is useful only for moving objects, asteroid or comets.

Normally you activate the options you want for the first object and they are copied for the next, also when you import a CdC observing list.

Maybe all of this is too complicated and not evident to understand if you not write the code ;-)

A solution is to add a button to save the default options? There can be one for the targets and one for the plan step?
This default is then used for every new object.

Cedric Raguenaud

18-10-30 17:26

reporter   ~0005013

In my case I was loading a long list of targets (dozens) from a CdC observation list (though not generated by CdC, I wrote a program). In that case the "use astrometry" isn't set even though the coordinates are provided by the file.

For background, the reason I was generating a CdC list is that it's very easy and only took me minutes. The next step for me would be to generate a proper sequence file and set all the options I need. That's feasable, it will just take longer. But that means that when you load from a CdC list you have to set the options (for most people it wouldn't be a huge list, so not too bad).

So I guess you can close this suggestion.

Patrick Chevalley

18-10-31 10:31

administrator   ~0005016

Yes this is a solution , but not for everyone.

I need to fix the loading of observing list when astrometry is configured, and find a way to set the default for the other option.

Cedric Raguenaud

18-10-31 13:50

reporter   ~0005018

What about adding a "check all" options at the top to trigger all the options in the column? At least that way it would be quick to set the options for all targets.

Patrick Chevalley

18-11-03 11:29

administrator   ~0005030

Yes this is also an option. For the table this can be a click in the title row. And for the 3 other option a checkbox on top.

Patrick Chevalley

18-11-19 18:17

administrator   ~0005112

Version 0.9.48 has the can change an option globally for a column.

The fix to set plate solving and autofocus mode when loading a CdC observing list is here:
https://github.com/pchev/ccdciel/commit/4997aab7df40e8e59b7b0e084782deb8a855a305

Issue History

Date Modified Username Field Change
18-10-30 14:13 Cedric Raguenaud New Issue
18-10-30 14:23 Cedric Raguenaud Note Added: 0005010
18-10-30 17:14 Patrick Chevalley Note Added: 0005012
18-10-30 17:26 Cedric Raguenaud Note Added: 0005013
18-10-31 10:31 Patrick Chevalley Note Added: 0005016
18-10-31 13:50 Cedric Raguenaud Note Added: 0005018
18-11-03 11:29 Patrick Chevalley Assigned To => Patrick Chevalley
18-11-03 11:29 Patrick Chevalley Status new => assigned
18-11-03 11:29 Patrick Chevalley Target Version => 1.0
18-11-03 11:29 Patrick Chevalley Note Added: 0005030
18-11-19 18:17 Patrick Chevalley Status assigned => resolved
18-11-19 18:17 Patrick Chevalley Resolution open => fixed
18-11-19 18:17 Patrick Chevalley Note Added: 0005112