View Issue Details

IDProjectCategoryView StatusLast Update
0002017CCdciel[All Projects] Generalpublic18-11-14 12:53
ReporterCedric RaguenaudAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002017: Suggestion: Start CCDCiel with a sequence
DescriptionWith a view to automate an observatory and image capture, it would be useful to be able to start CCDCiel with a sequence:
- Start CCDCiel with the name of a sequence or a file containing a sequence on the command line.
- Let CCDCiel connect mount, camera, etc.
- Let CCDCiel load the sequence and start with the first suitable target (depending on options in the sequence and current conditions).
- As part of the sequence, manage target loss, park/unpark, close observatory, etc (as it is now).
TagsNo tags attached.

Activities

Patrick Chevalley

18-11-13 21:28

administrator   ~0005065

There is already the startup script ( https://www.ap-i.net/ccdciel/en/documentation/ccdscript ) that can help for that, but I agree that a command line option give more flexibility to run different sequences.

The option can be --run_sequence=test.targets or -r test.targets

But maybe it is best to let the startup script to connect the equipment and open the observatory, then the shutdown script to park and close everything. Because this can be very different for everyone and probably not possible by adding simple command line options.

Cedric Raguenaud

18-11-13 22:15

reporter   ~0005067

Agreed: if the startup script can do all the connections and manage the observatory, let it.

Yes that command line looks perfect.

Patrick Chevalley

18-11-14 12:53

administrator   ~0005077

I make a separated option to close the program at the end of the sequence because this may not be always wanted.

This is implemented by:
https://github.com/pchev/ccdciel/commit/48014f43da422959349141dc73c750473a4dfdb2

I add a documentation page to describe this options :
https://www.ap-i.net/ccdciel/en/documentation/cmdline

So the startup script is used for extra initialization, like open the observatory roof.
The shutdown script is used to close the roof.
The target termination option do the normal end process, like park the telescope and warm the camera. And the abnormal termination script can be used to send email or other.

Issue History

Date Modified Username Field Change
18-11-12 21:11 Cedric Raguenaud New Issue
18-11-13 21:28 Patrick Chevalley Assigned To => Patrick Chevalley
18-11-13 21:28 Patrick Chevalley Status new => assigned
18-11-13 21:28 Patrick Chevalley Target Version => 1.0
18-11-13 21:28 Patrick Chevalley Note Added: 0005065
18-11-13 22:15 Cedric Raguenaud Note Added: 0005067
18-11-14 12:53 Patrick Chevalley Status assigned => resolved
18-11-14 12:53 Patrick Chevalley Resolution open => fixed
18-11-14 12:53 Patrick Chevalley Note Added: 0005077