View Issue Details

IDProjectCategoryView StatusLast Update
0002020CCdciel[All Projects] Generalpublic18-11-16 21:00
ReporterCedric RaguenaudAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002020: Suggestion : overview page
DescriptionWhen a sequence Is running, ccdciel doesn't give much feedback. It would be useful to have an overview page that shows high level progress, PHD status, last image, etc.

Ekos had a fairly good one: https://www.indilib.org/images/phocagallery/ekos_2.7/thumbs/phoca_thumb_l_ekos_main.png
TagsNo tags attached.

Activities

Patrick Chevalley

18-11-13 21:39

administrator   ~0005066

Yes this can be very useful.
Even more useful if the status page is not a window of the program but a web page you can access remotely (or locally) in any browser. This can make easy to check the status with a phone.

At the moment there is a very simple telnet interface but this can be a good improvement and give more information.
https://www.ap-i.net/ccdciel/en/documentation/server

Patrick Chevalley

18-11-16 21:00

administrator   ~0005084

I add the status web page, it run on the same port as the telnet interface so you get visualize the page from http://localhost:3277 . I also add a menu entry in the Help section to access this page.

At the moment the sequence progress is imprecise because this is only a percent of items, this can be improved after solving 0001880

https://github.com/pchev/ccdciel/commit/694bab16a4c44e81292e937d5964b9130dff1300

Issue History

Date Modified Username Field Change
18-11-13 21:26 Cedric Raguenaud New Issue
18-11-13 21:39 Patrick Chevalley Assigned To => Patrick Chevalley
18-11-13 21:39 Patrick Chevalley Status new => assigned
18-11-13 21:39 Patrick Chevalley Target Version => 1.0
18-11-13 21:39 Patrick Chevalley Note Added: 0005066
18-11-16 21:00 Patrick Chevalley Status assigned => resolved
18-11-16 21:00 Patrick Chevalley Resolution open => fixed
18-11-16 21:00 Patrick Chevalley Note Added: 0005084