View Issue Details

IDProjectCategoryView StatusLast Update
0002027CCdciel[All Projects] Generalpublic18-11-17 10:25
ReporterCedric RaguenaudAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002027: Error generating flats
DescriptionI tried to generate flats last night several times but failed to get them. I tried at dusk. Here an extract of the log:
2018-11-15T16:12:56.168 1: Waiting for twilight at 17:41:08
2018-11-15T16:12:56.168 1: Need to wait until 17:41:08
2018-11-15T16:12:56.183 1: Pause: Need to wait until 17:41:08
2018-11-15T17:41:08.324 3: EQMOD.Telescope: Slewing to 21h17m40s/+45d58m17s
2018-11-15T17:42:12.960 3: EQMOD.Telescope: Slew is complete
2018-11-15T17:42:12.983 3: EQMOD.Telescope: Stop telescope motion.
2018-11-15T17:42:13.047 1: Object SkyFlat, start plan
2018-11-15T17:42:13.050 1: Object SkyFlat, plan finished.

Nothing was generated.

I tried again:
2018-11-15T17:58:28.936 3: EQMOD.Telescope: Unpark
2018-11-15T18:00:05.582 3: CCD temperature: -9.9
2018-11-15T18:01:19.136 1: The sequence test will be stopped at 06:23:02, in 44506 seconds.
2018-11-15T18:01:25.363 1: Starting sequence test
2018-11-15T18:02:48.131 2: Stop autoguider
2018-11-15T18:02:48.468 3: EQMOD.Telescope: Slewing to 21h40m41s/+46d18m04s
2018-11-15T18:03:27.359 3: EQMOD.Telescope: Slew is complete
2018-11-15T18:03:27.360 3: EQMOD.Telescope: Stop telescope motion.
2018-11-15T18:03:27.422 1: Waiting for twilight at 17:41:08
2018-11-15T18:03:27.422 1: Time already passed 17:41:08
2018-11-15T18:03:27.423 1: Object SkyFlat, start plan
2018-11-15T18:03:27.424 1: Object SkyFlat, plan finished.

I then tried at dawn:
2018-11-16T05:14:09.945 1: Waiting for twilight at 06:35:50
2018-11-16T05:14:09.960 1: Need to wait until 06:35:50
2018-11-16T05:14:09.976 1: Pause: Need to wait until 06:35:50
2018-11-16T06:35:50.300 3: EQMOD.Telescope: Slewing to 08h15m13s/+45d42m34s
2018-11-16T06:35:54.715 3: EQMOD.Telescope: Slew is complete
2018-11-16T06:35:54.746 3: EQMOD.Telescope: Stop telescope motion.
2018-11-16T06:35:54.824 1: Object SkyFlat, start plan
2018-11-16T06:35:54.840 1: Object SkyFlat, plan finished.

In all cases, the time between start and end of flat generation is too short to have generated 15 images (as requested in the plan).

I didn't have time to load the code before the dawn window closed so I can't say why it didn't generate the flats. I think I'll add logging in that section and try again tonight.
TagsNo tags attached.

Activities

Patrick Chevalley

18-11-16 22:31

administrator   ~0005088

This must work, I use this function every clear night.
Can you upload you flat .targets file here?

Also do you configure the auto-exposure in Preferences/Flat ?

Yes at this season the time to take sky flat is short, but this work if you use a camera without shutter that can take good flat with short exposure when the sky is still bright.

Cedric Raguenaud

18-11-16 22:45

reporter   ~0005090

Sample target file with flats at dawn.

Patrick Chevalley

18-11-16 22:47

administrator   ~0005091

you must rename the file to .txt because Mantis check for allowed extension.

Cedric Raguenaud

18-11-16 22:54

reporter   ~0005093

Txt

test.txt (3,610 bytes)
<?xml version="1.0" encoding="utf-8"?>
<CONFIG Version="3" ListName="test" TargetNum="8" RepeatCount="1">
  <Startup SeqStop="True" SeqStart="False" SeqStopAt="06:24:13" SeqStartAt="19:30:00" SeqStopTwilight="True" SeqStartTwilight="False"/>
  <Termination Park="True" EndScript="" RunScript="False" WarmCamera="True" ErrorScript="" StopTracking="False" ErrorRunScript="False"/>
  <Targets>
    <Target1 PA="-" RA="  1h23m20s" Dec="+34d46m00s" Path="" Plan="6x300s" Skip="True" Delay="1" EndSet="True" EndTime="" Preview="False" FlatBinX="0" FlatBinY="0" FlatGain="0" DarkNight="False" FlatCount="0" StartRise="True" StartTime="" ObjectName="AT2018ims" FlatFilters="" RepeatCount="1" UpdateCoord="False" PreviewExposure="1" InplaceAutofocus="False" AstrometryPointing="True"/>
    <Target2 PA="-" RA=" 23h44m40s" Dec="+28d42m00s" Path="" Plan="6x300s" Skip="True" Delay="1" EndSet="True" EndTime="01:38:04" Preview="False" FlatBinX="0" FlatBinY="0" FlatGain="0" DarkNight="False" FlatCount="0" StartRise="True" StartTime="16:30:50" ObjectName="AT2018imt" FlatFilters="" RepeatCount="1" UpdateCoord="False" PreviewExposure="1" InplaceAutofocus="False" AstrometryPointing="True"/>
    <Target3 PA="-" RA="  2h23m48s" Dec="+42d26m07s" Path="" Plan="120x600s" Skip="True" Delay="1" EndSet="True" EndTime="05:04:36" Preview="False" FlatBinX="0" FlatBinY="0" FlatGain="0" DarkNight="False" FlatCount="0" StartRise="False" StartTime="23:45:00" ObjectName="NGC 891" FlatFilters="" RepeatCount="1" UpdateCoord="False" PreviewExposure="1" InplaceAutofocus="False" AstrometryPointing="True"/>
    <Target4 PA="-" RA="  8h18m45s" Dec="+48d00m00s" Path="" Plan="6x300s" Skip="True" Delay="1" EndSet="True" EndTime="11:18:34" Preview="False" FlatBinX="0" FlatBinY="0" FlatGain="0" DarkNight="False" FlatCount="0" StartRise="True" StartTime="23:55:04" ObjectName="2018ide" FlatFilters="" RepeatCount="1" UpdateCoord="False" PreviewExposure="1" InplaceAutofocus="False" AstrometryPointing="True"/>
    <Target5 PA="-" RA="  7h57m44s" Dec="+30d07m00s" Path="" Plan="6x300s" Skip="True" Delay="1" EndSet="True" EndTime="09:54:30" Preview="False" FlatBinX="0" FlatBinY="0" FlatGain="0" DarkNight="False" FlatCount="0" StartRise="True" StartTime="00:42:05" ObjectName="2018iko" FlatFilters="" RepeatCount="1" UpdateCoord="False" PreviewExposure="1" InplaceAutofocus="False" AstrometryPointing="True"/>
    <Target6 PA="-" RA="  6h32m29s" Dec="+34d16m00s" Path="" Plan="6x300s" Skip="True" Delay="1" EndSet="True" EndTime="08:44:01" Preview="False" FlatBinX="0" FlatBinY="0" FlatGain="0" DarkNight="False" FlatCount="0" StartRise="True" StartTime="22:57:47" ObjectName="AT2018ind" FlatFilters="" RepeatCount="1" UpdateCoord="False" PreviewExposure="1" InplaceAutofocus="False" AstrometryPointing="True"/>
    <Target7 PA="-" RA="  8h03m42s" Dec="+65d27m00s" Path="" Plan="6x300s" Skip="True" Delay="1" EndSet="True" EndTime="12:26:57" Preview="False" FlatBinX="0" FlatBinY="0" FlatGain="0" DarkNight="False" FlatCount="0" StartRise="True" StartTime="22:16:42" ObjectName="AT2018imu" FlatFilters="" RepeatCount="1" UpdateCoord="False" PreviewExposure="1" InplaceAutofocus="False" AstrometryPointing="True"/>
    <Target8 PA="-" RA="-" Dec="-" Path="" Plan="Dawn" Skip="False" Delay="1" EndSet="False" EndTime="08:00:24" Preview="False" FlatBinX="1" FlatBinY="1" FlatGain="11" DarkNight="False" FlatCount="15" StartRise="False" StartTime="06:35:50" ObjectName="SkyFlat" FlatFilters="" RepeatCount="1" UpdateCoord="False" PreviewExposure="1" InplaceAutofocus="False" AstrometryPointing="False"/>
  </Targets>
</CONFIG>
test.txt (3,610 bytes)

Cedric Raguenaud

18-11-16 22:55

reporter   ~0005094

Options (sorry screen shot in doing this on my phone).

Patrick Chevalley

18-11-16 23:11

administrator   ~0005095

Thank you, the problem is because you not use a filter wheel and there is a bug in this case that prevent to generate the flat plan.
I send you a fix tomorrow.

Cedric Raguenaud

18-11-16 23:19

reporter   ~0005096

I debugged a bit tonight and I wondered if it was that. I saw that the section that generates the steps was bypassed if there are no filter steps.

Patrick Chevalley

18-11-17 10:25

administrator   ~0005097

Yes this was the problem. And I have to make a new config to test because the program make much effort to remember the filter name, so even if I not connect a wheel for testing I not get this case.

This is fixed by:
https://github.com/pchev/ccdciel/commit/29a6a9e755fba56c1e480eee08d1c100ea928e78

Issue History

Date Modified Username Field Change
18-11-16 11:55 Cedric Raguenaud New Issue
18-11-16 22:31 Patrick Chevalley Assigned To => Patrick Chevalley
18-11-16 22:31 Patrick Chevalley Status new => feedback
18-11-16 22:31 Patrick Chevalley Target Version => 1.0
18-11-16 22:31 Patrick Chevalley Note Added: 0005088
18-11-16 22:45 Cedric Raguenaud Note Added: 0005090
18-11-16 22:45 Cedric Raguenaud Status feedback => assigned
18-11-16 22:47 Patrick Chevalley Note Added: 0005091
18-11-16 22:54 Cedric Raguenaud File Added: test.txt
18-11-16 22:54 Cedric Raguenaud Note Added: 0005093
18-11-16 22:55 Cedric Raguenaud File Added: Screenshot_2018-11-16-22-41-15-315_com.microsoft.rdc.android.png
18-11-16 22:55 Cedric Raguenaud Note Added: 0005094
18-11-16 23:11 Patrick Chevalley Note Added: 0005095
18-11-16 23:19 Cedric Raguenaud Note Added: 0005096
18-11-17 10:25 Patrick Chevalley Status assigned => resolved
18-11-17 10:25 Patrick Chevalley Resolution open => fixed
18-11-17 10:25 Patrick Chevalley Note Added: 0005097