View Issue Details

IDProjectCategoryView StatusLast Update
0002040CCdciel[All Projects] Generalpublic18-12-13 17:03
ReporterAndre KovacsAssigned ToPatrick Chevalley 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSmacOSOS Version10.11
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002040: OS X says that the installer dmg package is invalid
DescriptionHello,

Im trying to install CCDciel, but both versions available of the installer dmg package is said to be invalid by OS X.

Thanks,
Andre
TagsNo tags attached.

Activities

Patrick Chevalley

18-12-13 10:59

administrator   ~0005199

I make the package with Mojave and also test with High Sierra, but not the previous version. Maybe I need to add some compatibility option.
The program itself is compiled to be compatible with Yosemite.

As I cannot test with your MacOS version can you give me more detail about the error.
Is the error when you open the dmg?
Or do the dmg mount and the error is when you run the pkg?
Make a screenshot of the error message you can upload here, so I can search for the exact words.

Andre Kovacs

18-12-13 12:47

reporter   ~0005200

Both DMGs (ccdciel-0.9.49-1277-x86_64-macosx.dmg and ccdciel-0.9.48-1243-x86_64-macosx.dmg, with sizes 7,911,593 bytes and 7,906,796 bytes) were downloaded from SourceForge, and El Capitan displays an alert that says "the following disk image could not be opened: No Mountable File System."
I even tried to open the DMG using DiskUtility, but with no success (not even a message displayed), convert the image to uncompressed read-write using DiskUtility, and to change the download mirror from SourceForge, but with no luck.
I managed to mount the disk using diskutil (as described here: https://superuser.com/questions/19426/im-unable-to-mount-a-dmg-getting-a-no-mountable-filesystems-error), but couldn't see any partition on it.

Patrick Chevalley

18-12-13 14:56

administrator   ~0005201

Thank you for this information.
The problem is because my build virtual machine disk get formatted with APFS and this file system was also used for the dmg.
But APFS is only supported since High Sierra, thus the error you get with El Capitan.

I add a HFS disk to the virtual machine to build the image and I check the dmg is now also using HFS.

Can you try with the new file ccdciel-0.9.49-1298-x86_64-macosx.dmg available from Sourceforge and tell me if it's OK.

Andre Kovacs

18-12-13 15:31

reporter   ~0005202

Yes, you got it. Now it mounts and installs the package perfectly.
Thank you very much for your promptly reply!

Patrick Chevalley

18-12-13 17:03

administrator   ~0005203

Nice!
thank you for your help.

Issue History

Date Modified Username Field Change
18-12-12 21:47 Andre Kovacs New Issue
18-12-13 10:59 Patrick Chevalley Status new => feedback
18-12-13 10:59 Patrick Chevalley Note Added: 0005199
18-12-13 12:47 Andre Kovacs Note Added: 0005200
18-12-13 12:47 Andre Kovacs Status feedback => new
18-12-13 14:56 Patrick Chevalley Assigned To => Patrick Chevalley
18-12-13 14:56 Patrick Chevalley Status new => feedback
18-12-13 14:56 Patrick Chevalley Target Version => 1.0
18-12-13 14:56 Patrick Chevalley Note Added: 0005201
18-12-13 15:31 Andre Kovacs Note Added: 0005202
18-12-13 15:31 Andre Kovacs Status feedback => assigned
18-12-13 17:03 Patrick Chevalley Status assigned => resolved
18-12-13 17:03 Patrick Chevalley Resolution open => fixed
18-12-13 17:03 Patrick Chevalley Note Added: 0005203