View Issue Details

IDProjectCategoryView StatusLast Update
0002050CCdciel[All Projects] Generalpublic19-01-05 14:23
ReporterCedric RaguenaudAssigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002050: Autoguiding failed to start
DescriptionAt about 00:50 last night, after moving back to the target after autofocusing, autoguiding failed to start. I can't see any specific explanation in the logs. The sequence was abandonned for the night at that point.
TagsNo tags attached.

Activities

Cedric Raguenaud

19-01-03 09:55

reporter  

Log_20190102_220251.log (111,209 bytes)

Cedric Raguenaud

19-01-03 10:11

reporter   ~0005217

I think I understand it: PHD is complaining that all deviced aren't connected. There must have been an error with the camera and it was disconnected.

Patrick Chevalley

19-01-03 10:24

administrator   ~0005218

Yes, from the log:
2019-01-03T00:50:37.572 2: Restart autoguider
2019-01-03T00:50:43.830 1: Autoguider: loop error could not start looping
2019-01-03T00:51:54.053 2: Autoguider: Star Selected
2019-01-03T00:51:56.329 1: Autoguider: guide error all equipment must be connected first

The messages following "Autoguider:" are send by PHD2. There must be information in the PHD2 debug log about what is not connected.

You have a lot of alert from PHD2 that it periodically lost connection with the guide camera. Do you try to increase the timeout as indicated to avoid it disconnect and reconnect the camera every time?
This is generally because all the USB bandwidth it taken by the main camera during image download.
But here I see many of this problem when the main camera is idle, for example 4 event during the exposure starting at 00:31:13. This may be a cable problem?

Cedric Raguenaud

19-01-03 10:30

reporter   ~0005219

Yes I have lots of problems with that camera. Increasing the time out doesn't really help, it just increases the time it takes for it to fail.

It's a camera problem. It's always been there and I've tried everything (hub, no hub, usb2, usb3, various cables). I've ordered a new on which should arrive soon.

We can close this one.

Patrick Chevalley

19-01-03 17:56

administrator   ~0005221

OK, I close the issue, I not see what can be improved in CCDCiel in this case.

Cedric Raguenaud

19-01-04 12:59

reporter   ~0005223

I had a thought: given that when we're guiding we'd expect and require that PHD is connected to its peripherals (camera, mount, etc) and that if running unattended nobody would be there to redo the connections and we could lose a night of imaging, would sending a "set_connected=true" to PHD when ccdciel gets the error "guide error all equipment must be connected first" be sensible?

Patrick Chevalley

19-01-05 14:23

administrator   ~0005224

I am not sure if this can help because PHD2 already disconnect and try to reconnect the camera every time you have this message "Alert warning, After 9.0 sec the camera has not completed..."

But why not try, I make a change for that. When testing by forcing an error with the simulator and then start guiding it now start correctly.
I not check for this specific message because it can change depending on the PHD2 version and translation but it now try to reconnect if the status is in error.
I also tested it not hurt to send "set_connected=true" even if not required so it is good to try.

https://github.com/pchev/ccdciel/commit/28d78ede9ed4cf02fbd47448369c442c2cfc5315

Issue History

Date Modified Username Field Change
19-01-03 09:55 Cedric Raguenaud New Issue
19-01-03 09:55 Cedric Raguenaud File Added: Log_20190102_220251.log
19-01-03 10:11 Cedric Raguenaud Note Added: 0005217
19-01-03 10:24 Patrick Chevalley Note Added: 0005218
19-01-03 10:30 Cedric Raguenaud Note Added: 0005219
19-01-03 17:56 Patrick Chevalley Status new => resolved
19-01-03 17:56 Patrick Chevalley Resolution open => no change required
19-01-03 17:56 Patrick Chevalley Note Added: 0005221
19-01-04 12:59 Cedric Raguenaud Status resolved => new
19-01-04 12:59 Cedric Raguenaud Resolution no change required => reopened
19-01-04 12:59 Cedric Raguenaud Note Added: 0005223
19-01-05 14:23 Patrick Chevalley Assigned To => Patrick Chevalley
19-01-05 14:23 Patrick Chevalley Status new => resolved
19-01-05 14:23 Patrick Chevalley Resolution reopened => fixed
19-01-05 14:23 Patrick Chevalley Target Version => 1.0
19-01-05 14:23 Patrick Chevalley Note Added: 0005224