View Issue Details

IDProjectCategoryView StatusLast Update
0002052CCdciel[All Projects] Generalpublic19-01-09 21:29
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002052: Pop-up menu options "Preview debayer" and "preview raw"
DescriptionThe pop-up options "Preview debayer" and "preview raw" could be combined in a checkable menu "Preview debayer" as shown in attached sketch. Any reason why these two menus are seperate?

Note that most literature is now calling this demosaic rather then debayer. See for example the reference list of Wikipedia:
https://en.wikipedia.org/wiki/Demosaicing
TagsNo tags attached.

Activities

han

19-01-09 19:44

reporter  

preview debayer.png (17,909 bytes)
preview debayer.png (17,909 bytes)

Patrick Chevalley

19-01-09 21:29

administrator   ~0005237

No reason for that, maybe only because I not use it very often...

Yes, this is much better with a checkbox:
https://github.com/pchev/ccdciel/commit/883bf2769e784a04131c55a9e86bec394729fa74

I keep debayer because this is widely used in astronomy. For example the PixInsight tool is named Debayer.

Issue History

Date Modified Username Field Change
19-01-09 19:44 han New Issue
19-01-09 19:44 han File Added: preview debayer.png
19-01-09 21:29 Patrick Chevalley Assigned To => Patrick Chevalley
19-01-09 21:29 Patrick Chevalley Status new => resolved
19-01-09 21:29 Patrick Chevalley Resolution open => fixed
19-01-09 21:29 Patrick Chevalley Target Version => 1.0
19-01-09 21:29 Patrick Chevalley Note Added: 0005237