View Issue Details

IDProjectCategoryView StatusLast Update
0002058CCdciel[All Projects] Generalpublic19-02-03 20:29
ReporterhanAssigned ToPatrick Chevalley 
PrioritylowSeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002058: Visualisation, use of histogram and 90,95, 96, 98 buttons
Description1) After connecting my old QHY8, i noticed that the Visualisation 90,95, 96, 98 buttons aren't doing much. Most effective tools are the gamma setting and red/green sliders in the histrogram. Suggest to review working and improve. Attached one of my QHY8 images taken during foggy conditions.

2) When auto focusing is executed (read only a smart part of the sensor) , the QHY8 behaves strange and the histogram values change significantly (and go up) and screen becomes fully white. This odd behavior is a problem of the QHY8 but it would be nice if CCDCIEL could adapt to a different histogram values for sub section of the sensor.

So I wish a more flexible and robust automatic brightness and contrast settings. I required, I could try myself to improve the code and behavior.

TagsNo tags attached.

Activities

han

19-01-20 01:22

reporter  

M33_120s_20190109_191626.zip (8,435,050 bytes)

Patrick Chevalley

19-01-20 18:22

administrator   ~0005258

The problem is the very low image contrast above the high background level.

I change the auto-level detection to ignore everything below the mean sky background, i.e. the below the peak of the histogram:
https://github.com/pchev/ccdciel/commit/92ebab699f4260256f4827c95e6a911a03178984

This give a much darker sky and the nebula are better detected.
For this image the signal is still low but the galaxy is now clearly visible.
This also improve the display for all the other images I tested.

Can you try if this also work for your other images and if this improve the display during focusing?

han

19-01-22 14:31

reporter   ~0005268

The images are now much better presented.

I need a field trial to test is during auto-focus. This has to wait for clear weather.

han

19-02-03 18:52

reporter   ~0005316

Current version works well. No problems. Problem is solved :)

Patrick Chevalley

19-02-03 20:29

administrator   ~0005317

Good! thank you.

Issue History

Date Modified Username Field Change
19-01-20 01:22 han New Issue
19-01-20 01:22 han File Added: M33_120s_20190109_191626.zip
19-01-20 18:22 Patrick Chevalley Assigned To => Patrick Chevalley
19-01-20 18:22 Patrick Chevalley Status new => feedback
19-01-20 18:22 Patrick Chevalley Note Added: 0005258
19-01-22 14:31 han Note Added: 0005268
19-01-22 14:31 han Status feedback => assigned
19-02-03 18:52 han Note Added: 0005316
19-02-03 20:29 Patrick Chevalley Status assigned => resolved
19-02-03 20:29 Patrick Chevalley Resolution open => fixed
19-02-03 20:29 Patrick Chevalley Target Version => 1.0
19-02-03 20:29 Patrick Chevalley Note Added: 0005317