View Issue Details

IDProjectCategoryView StatusLast Update
0002059CCdciel[All Projects] Generalpublic19-03-12 21:04
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002059: Feature: Autofocus only if the ambient temerature changes
DescriptionFeature: Autofocus only if the ambient temerature changes

Having a high quality APO is nice, but like all refractors, they suffer from temperature gradient. This is caused by diffraction changes air->glass->air

Currently there are two ways to compensate:

1) Focus every so many exposures.
2) Temperature compensated focus.

Option 2) is not so successful with my setup because of mechanical slippage in the focuser
Option 1) is fine but it takes time and there is no need for if the ambient temperature is stable. I noticed I start to adjust the settings manually if the temperature drops fast in the beginning of the night (giving poorer HFD values) and disable autofocus it the temperature stabilizes.

So I would a suggest a third option " 3) Auto Focus after a temperature drop" which will save precious imaging time. It should auto-focus if the temperature varies beyond an adjustable value, but do nothing if the temperature is stable.

For my APO, an adjustment for every 1 or 2 degrees temperature difference drop/rise will be adequate.

Option 1) has an additional side effect, " automatic meridian flip" which is very useful. But that could be also done by the auto meridian option (haven't tried yet. Notices one spelling error in the menu) Secondly a telescope temperature drift is maybe lagging behind the ambient temperature. So allowing a combination of 1) and proposed 3) is maybe the best solution. So for me option 1) auto-focus after so many exposures are taken or 3) auto-focus if the temperature drift is beyond a set value.

TagsNo tags attached.

Activities

Patrick Chevalley

19-01-21 21:01

administrator   ~0005263

I can add a global option for focusing after the temperature change by a given amount. This can be handled the same way as the temperature compensation and this is independent of any auto-focus option in the sequence.

Then you can add additional auto-focus option to the sequence as you want, after a number of exposure or at the start of a step if you know the filter in use require refocusing.
This will not make refocusing to often because every auto-focus operation reset the reference temperature.

The meridian flip is because you slew to a focus star. If you focus less often the auto meridian flip function work fine and if you configure correctly the two time option it not lost any time to wait for the flip. Please indicate the spelling correction it need.

han

19-01-22 00:24

reporter   ~0005264

Yes I like to test this global option. :)

For spelling error, see attached:

spelling_error.png (18,173 bytes)
spelling_error.png (18,173 bytes)

Patrick Chevalley

19-01-22 10:18

administrator   ~0005266

Thank you for the screenshot. The bigger the error the most difficult to see it!

Patrick Chevalley

19-01-22 11:37

administrator   ~0005267

I add the option:
https://github.com/pchev/ccdciel/commit/ba5ff038ccfb335d13204cfb27e290b67cb4aece

The new option is in the Focus tab, in the same box as the temperature compensation because this is related. But the setting are independent, no need to set a compensation for the autofocus to work.

Beware it work with the difference of temperature from the previous autofocus, so if no autofocus is previously run in this session it do nothing.
This can be changed if required but I fear in this case it can try to autofocus in a session you not want it.

I let the issue open for your feedback because I cannot test the function, the focuser simulator do not report a modifiable temperature and I have cloud for many days now.

 

han

19-01-22 16:39

reporter   ~0005269

Great, this new feature works nicely in an ASCOM simulation. The ASCOM simulator has a temperature drift simulator.

>>.Beware it work with the difference of temperature from the previous autofocus, so if no autofocus is previously run in this session it do nothing.
This is not a problem. Any imaging session starts with an autofocus.

Any telescope follows the ambient temperature delayed. So if the ambient temperature has stabilized, the telescope could be still a little warmer. So maybe I have to put some more mass/metal around my temperature sensor so it mimics the telescope temperature rather then measuring the air temperature. For an APO the diffraction factor change most by temperature. I have no idea how the air temperature and delayed glass temperature have an influence. Field tests are required.

Feedback will follow if the sky clears. :)

han

19-01-24 11:49

reporter   ~0005277

For info only:

To study the focus behavior, I have added to the ASTAP program the possibility to copy the analyzed FITS image list to the clipboard. I will use this to test the focus routine for practical use.

Attached an first spreadsheet screenshot of the focuser temperature, focus position and HFD against the time (2 days). Three objects where imaged. Temperature went to down to -6 C. HFD was steady around 2.3 so number of autofocus executions could be reduced.

focus_trend.png (33,569 bytes)
focus_trend.png (33,569 bytes)

Patrick Chevalley

19-01-24 13:40

administrator   ~0005280

Interesting analysis.
It can be instructive to have a full night with good seeing, imaging only target at high elevation and do a single autofocus at the start, then not move the focuser to obtain the instrument hfd versus temperature relation.

han

19-01-24 16:19

reporter   ~0005282

Yes using a spreadsheet, all kind of analyses become possible. HFD as function of altitude, HFD as function of temperature. HFD as function of weather, time of the year. Sky background value, as function of time, azimuth, altitude, age of Moon, Moon altitude, Slippage focuser.

Now available in ASTAP version 0.9.166

han

19-02-05 21:08

reporter   ~0005330

Last edited: 19-02-06 07:48

View 3 revisions

I'm still testing it. Had one clear night but in general the weather is poor.

Today while taking flats, I noticed it was trying to autofocus and slew to a star. This could be avoided by disabling it. Luckily the mount connected was the ascom.simulator so my breakable flat panel did not fall off the telescope. So it was a "near miss". :)

For type of frame , I selected wrongly "light" rather then "flat". Is the autofocus disabled if flat/bias/dark is selected?

Patrick Chevalley

19-02-06 09:19

administrator   ~0005331

Yes the auto-focus run only if the type is Light.
But probably many people do not care and let the setting to Light when doing flat.

The only solution I see for this problem is to run the temperature change autofocus only if a corresponding checkbox is checked in the step description.
It can be checked by default if the temperature change setting is different than 0 and frame type is Light.
This way it never run when not part of a sequence and if you add a flat step you see this checkbox to disable it.

Is this OK for you?

han

19-02-07 09:51

reporter   ~0005351

I have thought about disabling the feature if the exposure is equal or shorter then 5 seconds. The autofocus could do only harm if somebody has his a light-box on top of the telescope. The exposure will then be shorter then 5 seconds I assume.

The cleanest solution would be to move the option to the "sequence "step" and "capture tool" below the option "focus every" (1). That would be a better location then preferences. An extra check on exposure > 5 seconds for absent-minded people like me would help to avoid disaster.(2)

I haven't looked in the log but a more strict boolean check on a first autofocus exercise before activating this feature would also help if the flat exercise is done under cloudy or indoor conditions. (3)

Patrick Chevalley

19-02-07 12:57

administrator   ~0005352

I add the 'Autofocus when temperature change' option to the sequence step editor and to the capture tool.
Now it also disable all this autofocus and dither options if the frame type is not Light, both in the capture tool and the step editor..

I also change the test to start the temperature change autofocus to be sure a successful autofocus was run in this session.

I let the temperature threshold definition in the preferences because this depend on the focuser used for this profile and we can imagine the same sequence can be run with another profile with another focuser.

I not add a test for the 5 sec. exposure because this is too empirical.

https://github.com/pchev/ccdciel/commit/50020d0e7a0f2357b9e052ff11d9a983b55bda13
and
https://github.com/pchev/ccdciel/commit/11b74cd9beeea3b97d076246b442ccd402aa81f2

han

19-03-12 14:24

reporter   ~0005469

This works fine for me. I have set the temperature change setting to 0.5 degrees and that keep the focus well controlled and reduces the focus events later in the night.

The only problem is that the initial focus is far out when I start imaginf, The temperature at the beginning of the evening is much higher then the last temperature of previous clear night. but that is an other topic.

Patrick Chevalley

19-03-12 21:04

administrator   ~0005470

Thank you, I close this issue.

Issue History

Date Modified Username Field Change
19-01-21 01:39 han New Issue
19-01-21 21:01 Patrick Chevalley Assigned To => Patrick Chevalley
19-01-21 21:01 Patrick Chevalley Status new => assigned
19-01-21 21:01 Patrick Chevalley Target Version => 1.0
19-01-21 21:01 Patrick Chevalley Note Added: 0005263
19-01-22 00:24 han File Added: spelling_error.png
19-01-22 00:24 han Note Added: 0005264
19-01-22 10:18 Patrick Chevalley Note Added: 0005266
19-01-22 11:37 Patrick Chevalley Status assigned => feedback
19-01-22 11:37 Patrick Chevalley Note Added: 0005267
19-01-22 16:39 han Note Added: 0005269
19-01-22 16:39 han Status feedback => assigned
19-01-24 11:49 han File Added: focus_trend.png
19-01-24 11:49 han Note Added: 0005277
19-01-24 13:40 Patrick Chevalley Note Added: 0005280
19-01-24 16:19 han Note Added: 0005282
19-02-05 21:08 han Note Added: 0005330
19-02-06 07:47 han Note Edited: 0005330 View Revisions
19-02-06 07:48 han Note Edited: 0005330 View Revisions
19-02-06 09:19 Patrick Chevalley Note Added: 0005331
19-02-07 09:51 han Note Added: 0005351
19-02-07 12:57 Patrick Chevalley Note Added: 0005352
19-03-12 14:24 han Note Added: 0005469
19-03-12 21:04 Patrick Chevalley Status assigned => resolved
19-03-12 21:04 Patrick Chevalley Resolution open => fixed
19-03-12 21:04 Patrick Chevalley Note Added: 0005470