View Issue Details

IDProjectCategoryView StatusLast Update
0002060CCdciel[All Projects] Generalpublic19-01-22 10:14
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002060: ASTAP, request to remove -fov parameter from the commandline
DescriptionToday after a routine check today, I had a weird problem with solving FITS images using CCDCIEL as front end and ASTAP.

The problem only occurred with older FITS images produced by CCDCIEL. Using CCDCIEL they didn't solve but in loading in ASTAP they solved without problems. There was a difference in the values of SECPIX1/2.

Some older FITS files from different origin had similar problems and was also caused by the fov parameter send.

Normally there is no need for testing older FITS file. But nevertheless the problem can be fixed by removing the -fov parameter in the ASTAP command line. The -fov parameter is not required. ASTAP will extract the data from the FITS keywords. So I would suggest to remove this parameter allowing some flexibility. The current definition of -fov is image height since I use a square field for searching but that has changed in the past.

Existing:
C:\astap.fpc\astap.exe -fov 1.36 -z 1 -r 5 -f C:\Users\h\AppData\Local\ccdciel\tmp\ccdcieltmp.fits

Proposed:
C:\astap.fpc\astap.exe -z 1 -r 5 -f C:\Users\h\AppData\Local\ccdciel\tmp\ccdcieltmp.fits


p.s. I also noted the definition of the two keyword below is now in line with MaximDL use:
XPIXSZ = 6 / [um] Pixel Size X, binned
YPIXSZ = 6 / [um] Pixel Size Y, binned



TagsNo tags attached.

Activities

Patrick Chevalley

19-01-22 10:14

administrator   ~0005265

I remove the fov option:
https://github.com/pchev/ccdciel/commit/a20641738429f246174f5bef8433d97675d7433c

I was not sending the image height, but the max of height,width. This is probably the reason for the problem.

Yes I fix XPIXSZ,YPIXSZ last autumn so it indicate the binned pixel size. This is now compatible with the SBIG extension definition but sure the old files are not compatible.

Issue History

Date Modified Username Field Change
19-01-22 00:19 han New Issue
19-01-22 10:14 Patrick Chevalley Assigned To => Patrick Chevalley
19-01-22 10:14 Patrick Chevalley Status new => resolved
19-01-22 10:14 Patrick Chevalley Resolution open => fixed
19-01-22 10:14 Patrick Chevalley Target Version => 1.0
19-01-22 10:14 Patrick Chevalley Note Added: 0005265