View Issue Details

IDProjectCategoryView StatusLast Update
0002092CCdciel[All Projects] Generalpublic19-02-27 18:35
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002092: Meridian flip done too close to the meridian resulting in a sync mount problem
DescriptionThis night, the automatic flip was executed, one of the first times. Due to imperfect polar alignment and so on, after the flip, the telescope was actual pointing about 2 degrees east of the meridian. So the sync failed since Eqmod can't sync across the meridian. See attached log. The sequence tried once to sync and then continued imaging at the wrong place.

1) This could be avoid by more tries to sync (why didn't it happen?). Would take about 2/15 hours= 8 minutes equal waiting.
or
2) Execute meridian flip later. E.g 10 minutes later after meridian crossing. Delaying meridian flip up to one hour after the meridian is normally not a problem.

I think 2) is a nicer solution since no time is lost.
TagsNo tags attached.

Activities

han

19-02-25 00:52

reporter  

log meridian flip.txt (9,791 bytes)
2019-02-24T23:39:24.921 2: Autoguider: Guiding
2019-02-24T23:39:26.684 1: Starting Light exposure 16/999 for 120 seconds
2019-02-24T23:41:34.994 1: Saved file C:\ccdciel\m81\m81_120s_20190224_224134.fits
2019-02-24T23:41:35.009 1: Starting Light exposure 17/999 for 120 seconds
2019-02-24T23:43:43.007 1: Saved file C:\ccdciel\m81\m81_120s_20190224_224342.fits
2019-02-24T23:43:43.116 1: Starting Light exposure 18/999 for 120 seconds
2019-02-24T23:45:51.520 1: Saved file C:\ccdciel\m81\m81_120s_20190224_224551.fits
2019-02-24T23:45:51.536 1: Starting Light exposure 19/999 for 120 seconds
2019-02-24T23:47:59.783 1: Saved file C:\ccdciel\m81\m81_120s_20190224_224759.fits
2019-02-24T23:47:59.861 1: Starting Light exposure 20/999 for 120 seconds
2019-02-24T23:49:31.823 1: Image median hfd=1.9  Tilt indication=23%  Curvature=24%
2019-02-24T23:50:08.374 1: Saved file C:\ccdciel\m81\m81_120s_20190224_225008.fits
2019-02-24T23:50:09.014 1: Starting Light exposure 21/999 for 120 seconds
2019-02-24T23:52:17.277 1: Saved file C:\ccdciel\m81\m81_120s_20190224_225217.fits
2019-02-24T23:52:17.511 1: Starting Light exposure 22/999 for 120 seconds
2019-02-24T23:54:25.680 1: Saved file C:\ccdciel\m81\m81_120s_20190224_225425.fits
2019-02-24T23:54:25.868 1: Starting Light exposure 23/999 for 120 seconds
2019-02-24T23:56:33.616 1: Saved file C:\ccdciel\m81\m81_120s_20190224_225633.fits
2019-02-24T23:56:33.632 1: Starting Light exposure 24/999 for 120 seconds
2019-02-24T23:58:41.630 1: Saved file C:\ccdciel\m81\m81_120s_20190224_225841.fits
2019-02-24T23:58:41.645 1: Starting Light exposure 25/999 for 120 seconds
2019-02-25T00:00:50.220 1: Saved file C:\ccdciel\m81\m81_120s_20190224_230050.fits
2019-02-25T00:00:50.220 1: Starting Light exposure 26/999 for 120 seconds
2019-02-25T00:02:58.421 1: Saved file C:\ccdciel\m81\m81_120s_20190224_230258.fits
2019-02-25T00:02:58.421 1: Starting Light exposure 27/999 for 120 seconds
2019-02-25T00:05:06.887 1: Saved file C:\ccdciel\m81\m81_120s_20190224_230506.fits
2019-02-25T00:05:06.887 1: Starting Light exposure 28/999 for 120 seconds
2019-02-25T00:07:15.166 1: Saved file C:\ccdciel\m81\m81_120s_20190224_230715.fits
2019-02-25T00:07:15.166 1: Starting Light exposure 29/999 for 120 seconds
2019-02-25T00:09:23.710 1: Saved file C:\ccdciel\m81\m81_120s_20190224_230923.fits
2019-02-25T00:09:23.741 1: Starting Light exposure 30/999 for 120 seconds
2019-02-25T00:11:32.180 1: Image median hfd=2.0  Tilt indication=16%  Curvature=28%
2019-02-25T00:11:39.013 1: Saved file C:\ccdciel\m81\m81_120s_20190224_231138.fits
2019-02-25T00:11:41.524 2: Wait meridian flip for 1 minutes
2019-02-25T00:13:07.075 2: Autoguider: Stopped
2019-02-25T00:13:07.199 2: Autoguider: Lock Position Lost
2019-02-25T00:13:08.947 1: Meridian flip now
2019-02-25T00:13:09.009 3: EQMOD.Telescope: Meridian flip
2019-02-25T00:13:09.025 3: EQMOD.Telescope: Slewing to 10h56m58s/+69d15m33s
2019-02-25T00:13:21.801 3: EQMOD.Telescope: Slew is complete
2019-02-25T00:13:21.817 3: EQMOD.Telescope: Slewing to 08h56m58s/+69d15m33s
2019-02-25T00:14:14.045 3: EQMOD.Telescope: Slew is complete
2019-02-25T00:14:14.045 3: EQMOD.Telescope: Slewing to 09h56m58s/+69d15m33s
2019-02-25T00:14:25.324 3: EQMOD.Telescope: Slew is complete
2019-02-25T00:14:27.383 2: Meridian flip done
2019-02-25T00:14:27.399 2: Recenter on last position
2019-02-25T00:14:27.399 3: EQMOD.Telescope: Slewing to 09h56m55s/+69d15m11s
2019-02-25T00:14:31.377 3: EQMOD.Telescope: Slew is complete
2019-02-25T00:15:01.438 3: Take control exposure for 15.0 seconds
2019-02-25T00:15:01.454 3: ASCOM.QHY8.Camera: Set binning 2x2
2019-02-25T00:15:02.577 2: Camera frame x=0 y=0 width=1520 height=1008
2019-02-25T00:15:20.923 3: ASCOM.QHY8.Camera: Set binning 1x1
2019-02-25T00:15:22.030 2: Camera frame x=0 y=0 width=3040 height=2016
2019-02-25T00:15:24.183 3: Resolve control exposure
2019-02-25T00:15:24.214 2: Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2019-02-25T00:15:24.214 3: Resolving using ASTAP ...
2019-02-25T00:15:26.679 2: Open file C:\Users\admin\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2019-02-25T00:15:26.679 2: ASTAP resolve successful. Solved in 2 seconds
2019-02-25T00:15:26.710 3: Distance to target: 120.05066 arcmin
2019-02-25T00:15:26.710 3: EQMOD.Telescope: Sync to 10h19m30s/+69d12m27s
2019-02-25T00:15:26.866 0: EQMOD.Telescope: Sync error: SyncToTarget() RaDec sync was rejected.
2019-02-25T00:15:26.866 0: Mount Sync failed!
2019-02-25T00:15:26.866 0: Precision slew failed!
2019-02-25T00:15:28.988 1: Recenter image error!
distance: 2.0
2019-02-25T00:15:29.003 1: Pause: Recenter image error!
distance: 2.0
2019-02-25T00:17:05.396 2: Restart autoguider
2019-02-25T00:17:15.941 2: Autoguider: Looping Exposures
2019-02-25T00:17:26.206 2: Autoguider: Star Selected
2019-02-25T00:17:28.765 2: Autoguider: Start Guiding
2019-02-25T00:17:33.008 2: Autoguider: Settling
2019-02-25T00:17:42.996 2: Autoguider: Settle Done
2019-02-25T00:17:43.830 2: Autoguider: Guiding
2019-02-25T00:17:45.813 1: Meridian flip completed
2019-02-25T00:17:45.838 1: Starting Light exposure 31/999 for 120 seconds
2019-02-25T00:18:47.978 1: Autoguider: STAR_SATURATED
2019-02-25T00:19:54.448 1: Saved file C:\ccdciel\m81\m81_120s_20190224_231954.fits
2019-02-25T00:19:54.481 1: Starting Light exposure 32/999 for 120 seconds
2019-02-25T00:22:02.543 1: Saved file C:\ccdciel\m81\m81_120s_20190224_232202.fits
2019-02-25T00:22:02.553 1: Autofocus now
2019-02-25T00:22:02.557 2: Stay at the current position for autofocus
2019-02-25T00:22:02.561 2: Pause autoguider
2019-02-25T00:22:02.776 2: Autoguider: Paused
2019-02-25T00:22:04.642 2: Focuser temperature: 1.7C
2019-02-25T00:22:04.658 3: ASCOM.QHY8.Camera: Set binning 2x2
2019-02-25T00:22:05.752 2: Camera frame x=0 y=0 width=1520 height=1008
2019-02-25T00:22:06.774 3: Take control exposure for 5.0 seconds
2019-02-25T00:22:17.102 2: Autofocus start Dynamic curve
2019-02-25T00:22:17.107 2: Focuser temperature: 1.7C
2019-02-25T00:22:17.122 2: AutoFocus started, initial position: 25436
2019-02-25T00:22:24.973 3: Using median of 11 stars
2019-02-25T00:22:24.984 3: Autofocus running, hfd=1.3 peak:65332.2 snr:1558.7
2019-02-25T00:22:25.405 3: ASCOM.USB_Focus.Focuser: Focuser move to 24236 - 400 Backlash compensation
2019-02-25T00:22:35.626 3: ASCOM.USB_Focus.Focuser: Focuser move to 24236
2019-02-25T00:22:46.879 3: Using median of 14 stars
2019-02-25T00:22:46.894 3: Autofocus running, hfd=3.2 peak:17450.6 snr:399.2
2019-02-25T00:22:46.941 3: ASCOM.USB_Focus.Focuser: Focuser move to 24536
2019-02-25T00:22:58.501 3: Using median of 13 stars
2019-02-25T00:22:58.501 3: Autofocus running, hfd=2.5 peak:21637.6 snr:453.1
2019-02-25T00:22:58.532 3: ASCOM.USB_Focus.Focuser: Focuser move to 24836
2019-02-25T00:23:10.544 3: Using median of 13 stars
2019-02-25T00:23:10.560 3: Autofocus running, hfd=1.8 peak:29198.1 snr:657.9
2019-02-25T00:23:10.591 3: ASCOM.USB_Focus.Focuser: Focuser move to 25136
2019-02-25T00:23:20.668 3: Using median of 12 stars
2019-02-25T00:23:20.668 3: Autofocus running, hfd=1.5 peak:37958.3 snr:779.5
2019-02-25T00:23:20.684 3: ASCOM.USB_Focus.Focuser: Focuser move to 25436
2019-02-25T00:23:31.588 3: Using median of 13 stars
2019-02-25T00:23:31.620 3: Autofocus running, hfd=1.5 peak:60447.7 snr:1322.5
2019-02-25T00:23:31.635 3: ASCOM.USB_Focus.Focuser: Focuser move to 25736
2019-02-25T00:23:42.399 3: Using median of 9 stars
2019-02-25T00:23:42.415 3: Autofocus running, hfd=1.3 peak:65333.4 snr:1477.7
2019-02-25T00:23:42.430 3: ASCOM.USB_Focus.Focuser: Focuser move to 26036
2019-02-25T00:23:52.992 3: Using median of 12 stars
2019-02-25T00:23:52.992 3: Autofocus running, hfd=1.5 peak:65317.3 snr:1713.4
2019-02-25T00:23:53.007 3: ASCOM.USB_Focus.Focuser: Focuser move to 26336
2019-02-25T00:24:03.412 3: Using median of 11 stars
2019-02-25T00:24:03.537 3: Autofocus running, hfd=2.1 peak:65337.5 snr:1524.4
2019-02-25T00:24:03.740 3: ASCOM.USB_Focus.Focuser: Focuser move to 26636
2019-02-25T00:24:14.832 3: Using median of 12 stars
2019-02-25T00:24:14.956 3: Autofocus running, hfd=2.7 peak:29899.2 snr:754.6
2019-02-25T00:24:15.034 3: HYPERBOLA curve fitting focus at 5.375,  remaining curve fit error 0.1951,  iteration cycles 4
2019-02-25T00:24:15.081 3: ASCOM.USB_Focus.Focuser: Focuser move to 25548 - 400 Backlash compensation
2019-02-25T00:24:24.519 3: ASCOM.USB_Focus.Focuser: Focuser move to 25548
2019-02-25T00:24:36.141 3: Using median of 10 stars
2019-02-25T00:24:36.266 2: Autofocus finished, POS=25548 HFD=1.4 PEAK:65331.1 SNR:1560.1 TEMP:1.7C
2019-02-25T00:24:36.313 3: ASCOM.QHY8.Camera: Set binning 1x1
2019-02-25T00:24:37.467 2: Camera frame x=0 y=0 width=3040 height=2016
2019-02-25T00:24:39.667 1: AutoFocus successful
2019-02-25T00:24:39.698 2: End preview
2019-02-25T00:24:39.729 2: Resume autoguider
2019-02-25T00:24:39.979 2: Autoguider: Resumed
2019-02-25T00:24:45.002 2: Autoguider: Guiding
2019-02-25T00:24:46.968 1: Starting Light exposure 33/999 for 120 seconds
2019-02-25T00:24:47.139 1: Request to stop the current sequence
2019-02-25T00:24:47.170 3: ASCOM.QHY8.Camera: Abort exposure
2019-02-25T00:24:47.233 3: ASCOM.QHY8.Camera: Abort exposure
2019-02-25T00:24:47.264 2: Abort exposure
2019-02-25T00:24:47.295 2: Stop capture
2019-02-25T00:24:47.342 2: Stop autoguider
2019-02-25T00:24:47.498 1: Sequence stopped by user request, no termination script will be run.
2019-02-25T00:24:47.514 2: Autoguider: Stopped
2019-02-25T00:24:47.576 2: Autoguider: Lock Position Lost
2019-02-25T00:24:47.794 1: Sequence M81 stopped.
2019-02-25T00:24:47.841 1: Plan 120sec stopped.
log meridian flip.txt (9,791 bytes)

Patrick Chevalley

19-02-25 08:48

administrator   ~0005438

The parameter "No flip until past meridian for" already implement 2)
But you have to set it, I cannot give a default value because this is mount and load dependent.

For my HEQ5 with a Newtonian telescope I set "Can track past meridian for"=30 and "No flip until past meridian for"=16
This allow for any polar alignment error and let me do exposure up to 15 minutes without the risk to loss time because it need to wait for meridian flip before to start an exposure.

Probably the documentation need to be improved with more explanation.

And maybe if the parameter "Can track past meridian for" is zero or very small a solution can be to wait for 5 or 10 minutes after the first slew 1 hour east of meridian, or after the second slew 1 hour west. This can be a parameter with a default value of 10 minutes so the meridian flip as more change to success if nothing is configured.
 

Patrick Chevalley

19-02-25 14:22

administrator   ~0005439

I also see there is already a test to retry the slew for up to ten minutes when we are within 2 degrees of the meridian.
Probably it just missed this test for a few arcmin, I need your configured observatory longitude to be sure.
Maybe it is safer to test for 3 or 4 degrees?

han

19-02-25 18:41

reporter   ~0005440

Configured for longitude 6 deg, 30 min east.

I totally missed the settings of meridian. They where all on zero. Must be my deprivation of sleep in these clear nights.

Eqmod reading had just passed the meridian and the offset was a little more then 2 degrees, so maybe it was just too much. 4 degrees will do the trick. Maybe it should retry if the eqmod is west of meridian and plate solve is east of the meridian or the other way around, but just setting it at 4 degrees will do the trick.

han

19-02-25 19:14

reporter   ~0005441

Is it not better to set "no flip until past meridian for" at 10 minutes default? This is equivalent to 2.5 degrees and would have avoided the problem. My problem with "default setting at zero" could happen to any user. You could also add some info in the hints of the setting.

Patrick Chevalley

19-02-26 17:37

administrator   ~0005442

Yes, you are right.
The fact that automatic flip is disabled by default make no problem to configure a small value by default.
I think that 10 and 15 minutes are very safe.

I also change the limit to retry a sync to 4 degree from the meridian.

Patrick Chevalley

19-02-27 18:35

administrator   ~0005445

I change the default value and increase the handling of sync error up to 4 degrees of the meridian.
https://github.com/pchev/ccdciel/commit/1cc728ba9a447cdfe56ad0d2ea9492cf660f8e12

I also make some addition to the documentation:
https://www.ap-i.net/ccdciel/en/documentation/preferences#meridian

Issue History

Date Modified Username Field Change
19-02-25 00:52 han New Issue
19-02-25 00:52 han File Added: log meridian flip.txt
19-02-25 00:52 han File Added: Just after meridian flip.png
19-02-25 08:48 Patrick Chevalley Assigned To => Patrick Chevalley
19-02-25 08:48 Patrick Chevalley Status new => assigned
19-02-25 08:48 Patrick Chevalley Note Added: 0005438
19-02-25 14:22 Patrick Chevalley Note Added: 0005439
19-02-25 18:41 han Note Added: 0005440
19-02-25 19:14 han Note Added: 0005441
19-02-26 17:37 Patrick Chevalley Note Added: 0005442
19-02-27 18:35 Patrick Chevalley Status assigned => resolved
19-02-27 18:35 Patrick Chevalley Resolution open => fixed
19-02-27 18:35 Patrick Chevalley Target Version => 1.0
19-02-27 18:35 Patrick Chevalley Note Added: 0005445