View Issue Details

IDProjectCategoryView StatusLast Update
0002094CCdciel[All Projects] Generalpublic19-03-05 23:27
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionno change required 
PlatformPCOSWindowsOS Version10 64bit
Product Version 
Target Version1.0Fixed in Version 
Summary0002094: Continuous "meridian flip error!"
DescriptionAfter a meridian flip, the program gives continuous and error: "Meridian flip error!" Had the problem in practice and could repeat it in simulation. I used an image of the horsehead in simulation.

The meridian flip starts correctly at 20 minutes past meridian.


2019-03-05T19:21:31.087 1: Starting Light exposure 25/999 for 60 seconds
2019-03-05T19:22:33.294 1: Saved file C:\temp\mouse_06_-2_20190305_182233.fits
2019-03-05T19:22:33.311 1: Starting Light exposure 26/999 for 60 seconds
2019-03-05T19:23:35.755 1: Saved file C:\temp\mouse_06_-2_20190305_182335.fits
2019-03-05T19:23:35.775 1: Starting Light exposure 27/999 for 60 seconds
2019-03-05T19:24:37.990 1: Saved file C:\temp\mouse_06_-2_20190305_182437.fits
2019-03-05T19:24:38.007 1: Starting Light exposure 28/999 for 60 seconds
2019-03-05T19:25:40.464 1: Saved file C:\temp\mouse_06_-2_20190305_182540.fits
2019-03-05T19:25:40.491 1: Starting Light exposure 29/999 for 60 seconds
2019-03-05T19:26:42.941 1: Saved file C:\temp\mouse_06_-2_20190305_182642.fits
2019-03-05T19:26:42.968 1: Starting Light exposure 30/999 for 60 seconds
2019-03-05T19:27:45.445 1: Saved file C:\temp\mouse_06_-2_20190305_182745.fits
2019-03-05T19:27:47.509 1: Meridian flip now
2019-03-05T19:27:47.529 3: ASCOM.Simulator.Telescope: Meridian flip
2019-03-05T19:27:47.545 3: ASCOM.Simulator.Telescope: Slewing to 06h42m21s/-02d19m31s
2019-03-05T19:27:56.678 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:27:56.697 3: ASCOM.Simulator.Telescope: Slewing to 04h42m21s/-02d19m31s
2019-03-05T19:28:11.897 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:28:11.913 3: ASCOM.Simulator.Telescope: Slewing to 05h42m21s/-02d19m31s
2019-03-05T19:28:28.641 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:28:30.693 1: Meridian flip error!
2019-03-05T19:28:30.716 1: Pause: Meridian flip error!
2019-03-05T19:30:30.833 2: Meridian flip done
2019-03-05T19:30:30.847 2: Recenter on last position
2019-03-05T19:30:30.862 3: ASCOM.Simulator.Telescope: Slewing to 05h42m21s/-02d19m31s
2019-03-05T19:30:33.418 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:30:38.505 3: Take control exposure for 10.0 seconds
2019-03-05T19:30:51.186 3: Resolve control exposure
2019-03-05T19:30:51.262 3: Resolving using ASTAP ...
2019-03-05T19:30:58.813 2: Open file C:\Users\h\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2019-03-05T19:30:58.829 2: ASTAP resolve successful. Solved in 8 seconds , offset 0.3149 degree
2019-03-05T19:30:58.860 3: Distance to target: 18.88586 arcmin
2019-03-05T19:30:58.875 2: Precision slew finished.
2019-03-05T19:31:02.947 1: Meridian flip completed
2019-03-05T19:31:02.969 1: Starting Light exposure 31/999 for 60 seconds
2019-03-05T19:32:05.251 1: Saved file C:\temp\mouse_06_-2_20190305_183205.fits
2019-03-05T19:32:07.341 1: Meridian flip now
2019-03-05T19:32:07.359 3: ASCOM.Simulator.Telescope: Meridian flip
2019-03-05T19:32:07.374 3: ASCOM.Simulator.Telescope: Slewing to 06h42m21s/-02d19m31s
2019-03-05T19:32:16.982 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:32:16.998 3: ASCOM.Simulator.Telescope: Slewing to 04h42m21s/-02d19m31s
2019-03-05T19:32:32.204 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:32:32.221 3: ASCOM.Simulator.Telescope: Slewing to 05h42m21s/-02d19m31s
2019-03-05T19:32:47.431 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:32:49.487 1: Meridian flip error!
2019-03-05T19:32:49.503 1: Pause: Meridian flip error!
2019-03-05T19:34:49.537 2: Meridian flip done
2019-03-05T19:34:49.553 2: Recenter on last position
2019-03-05T19:34:49.569 3: ASCOM.Simulator.Telescope: Slewing to 05h42m21s/-02d19m31s
2019-03-05T19:34:52.127 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:34:57.213 3: Take control exposure for 10.0 seconds
2019-03-05T19:35:09.862 3: Resolve control exposure
2019-03-05T19:35:09.948 3: Resolving using ASTAP ...
2019-03-05T19:35:17.640 2: Open file C:\Users\h\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2019-03-05T19:35:17.655 2: ASTAP resolve successful. Solved in 8 seconds , offset 0.3148 degree
2019-03-05T19:35:17.687 3: Distance to target: 18.88383 arcmin
2019-03-05T19:35:17.702 2: Precision slew finished.
2019-03-05T19:35:21.786 1: Meridian flip completed
2019-03-05T19:35:21.810 1: Starting Light exposure 32/999 for 60 seconds
2019-03-05T19:36:24.267 1: Saved file C:\temp\mouse_06_-2_20190305_183624.fits
2019-03-05T19:36:26.345 1: Meridian flip now
2019-03-05T19:36:26.387 3: ASCOM.Simulator.Telescope: Meridian flip
2019-03-05T19:36:26.408 3: ASCOM.Simulator.Telescope: Slewing to 06h42m21s/-02d19m31s
2019-03-05T19:36:36.023 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:36:36.042 3: ASCOM.Simulator.Telescope: Slewing to 04h42m21s/-02d19m31s
2019-03-05T19:36:51.307 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:36:51.324 3: ASCOM.Simulator.Telescope: Slewing to 05h42m21s/-02d19m31s
2019-03-05T19:37:07.403 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:37:09.458 1: Meridian flip error!
2019-03-05T19:37:09.492 1: Pause: Meridian flip error!
2019-03-05T19:39:09.554 2: Meridian flip done
2019-03-05T19:39:09.570 2: Recenter on last position
2019-03-05T19:39:09.586 3: ASCOM.Simulator.Telescope: Slewing to 05h42m21s/-02d19m31s
2019-03-05T19:39:12.141 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:39:17.216 3: Take control exposure for 10.0 seconds
2019-03-05T19:39:29.868 3: Resolve control exposure
2019-03-05T19:39:29.946 3: Resolving using ASTAP ...
2019-03-05T19:39:37.557 2: Open file C:\Users\h\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2019-03-05T19:39:37.572 2: ASTAP resolve successful. Solved in 8 seconds , offset 0.3149 degree
2019-03-05T19:39:37.603 3: Distance to target: 18.88582 arcmin
2019-03-05T19:39:37.618 2: Precision slew finished.
2019-03-05T19:39:41.710 1: Meridian flip completed
2019-03-05T19:39:41.729 1: Starting Light exposure 33/999 for 60 seconds
2019-03-05T19:40:44.202 1: Saved file C:\temp\mouse_06_-2_20190305_184044.fits
2019-03-05T19:40:46.279 1: Meridian flip now
2019-03-05T19:40:46.303 3: ASCOM.Simulator.Telescope: Meridian flip
2019-03-05T19:40:46.319 3: ASCOM.Simulator.Telescope: Slewing to 06h42m21s/-02d19m31s
2019-03-05T19:40:55.915 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:40:55.930 3: ASCOM.Simulator.Telescope: Slewing to 04h42m21s/-02d19m31s
2019-03-05T19:41:11.044 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:41:11.066 3: ASCOM.Simulator.Telescope: Slewing to 05h42m21s/-02d19m31s
2019-03-05T19:41:28.277 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:41:30.308 1: Meridian flip error!
2019-03-05T19:41:30.323 1: Pause: Meridian flip error!
2019-03-05T19:41:36.370 2: Meridian flip done
2019-03-05T19:41:36.386 2: Recenter on last position
2019-03-05T19:41:36.404 3: ASCOM.Simulator.Telescope: Slewing to 05h42m21s/-02d19m31s
2019-03-05T19:41:38.961 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:41:44.051 3: Take control exposure for 10.0 seconds
2019-03-05T19:41:56.690 3: Resolve control exposure
2019-03-05T19:41:56.769 3: Resolving using ASTAP ...
2019-03-05T19:42:04.466 2: Open file C:\Users\h\AppData\Local\ccdciel\tmp\ccdcielsolved.fits
2019-03-05T19:42:04.481 2: ASTAP resolve successful. Solved in 8 seconds , offset 0.3149 degree
2019-03-05T19:42:04.515 3: Distance to target: 18.88583 arcmin
2019-03-05T19:42:04.531 2: Precision slew finished.
2019-03-05T19:42:08.610 1: Meridian flip completed
2019-03-05T19:42:08.637 1: Starting Light exposure 34/999 for 60 seconds
2019-03-05T19:43:11.108 1: Saved file C:\temp\mouse_06_-2_20190305_184311.fits
2019-03-05T19:43:13.172 1: Meridian flip now
2019-03-05T19:43:13.192 3: ASCOM.Simulator.Telescope: Meridian flip
2019-03-05T19:43:13.208 3: ASCOM.Simulator.Telescope: Slewing to 06h42m21s/-02d19m31s
2019-03-05T19:45:06.362 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:45:06.377 3: ASCOM.Simulator.Telescope: Slewing to 04h42m21s/-02d19m31s

TagsNo tags attached.

Activities

han

19-03-05 19:54

reporter  

meridianflip1.png (17,538 bytes)
meridianflip1.png (17,538 bytes)
meridianflip2.png (20,676 bytes)
meridianflip2.png (20,676 bytes)

Patrick Chevalley

19-03-05 20:18

administrator   ~0005453

This message "Meridian flip error!" is from pu_main.pas at line 9545, this is because the mount report SideOfPier=pierWest after the flip, which is wrong.
After this message there is a dialog prompt with a 2 minutes timeout and it continue.
At the end of the next exposure it start a new flip because the meridian time is passed and SideOfPier=pierWest, and so on.

You must check why your mount report SideOfPier=pierWest if it is really on the East.

Maybe the observatory coordinates are not set correctly in the ASCOM driver.
If you use Eqmod you must also be sure that in Eqmod Setup the option SideofPier is set to "Pointing (ASCOM)" which is the default value.





han

19-03-05 20:56

reporter   ~0005455

I will check. But notice also the weird RA positions at 06h, 04h, 05h:

2019-03-05T19:27:47.545 3: ASCOM.Simulator.Telescope: Slewing to 06h42m21s/-02d19m31s
2019-03-05T19:27:56.678 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:27:56.697 3: ASCOM.Simulator.Telescope: Slewing to 04h42m21s/-02d19m31s
2019-03-05T19:28:11.897 3: ASCOM.Simulator.Telescope: Slew is complete
2019-03-05T19:28:11.913 3: ASCOM.Simulator.Telescope: Slewing to 05h42m21s/-02d19m31s

Patrick Chevalley

19-03-05 21:12

administrator   ~0005456

This 3 slew one hour apart are expected. I found this method the safest to be sure any mount do the flip as expected, without relying on setting the SideOfPier property because this is not supported by many mount.

Your target is at 05h42.
It first slew one hour east at 06h42 to get out of the meridian, without a flip.
Then it slew one hour west at 04h42, this force the flip.
And finally it return to the target at 05h42.

This not make any additional movement but ensure the mount do the flip. Some mount can do nothing when asked to slew to 05h42 when already at 05h42.

Patrick Chevalley

19-03-05 21:41

administrator   ~0005457

I test with the simulator. The default longitude in the Ascom simulator, it is 0d17m west, so meridian is 40 minutes later than at your location and this explain the simulator behavior. When setting the right longitude the sideofpier is right.

The mount setting already as options to sync the observatory coordinates when connected.

I must add information about the importance of this point in the meridian flip documentation.

Patrick Chevalley

19-03-05 22:05

administrator   ~0005458

This is not your issue, but I remark a problem if "can track past meridian" is more than one hour.
The first slew must be one hour east of the meridian, not one hour east of the target.
This is fixed by:
https://github.com/pchev/ccdciel/commit/1a1daed135656b9dca724bf04dd8819a72f206cf

han

19-03-05 22:54

reporter   ~0005459

By setting the latitude, longitude position correctly in simulation, the problem is gone.

I also tested live again in my observatory. This time meridian flip was executed correctly after first adjusting the polar axis. The eqmod settings where correct at "Pointing (ASCOM)". I checked the older logs and all problems where caused by refusal to sync and not as earlier reported Meridian flip error. I still don't know why, A meridian flip 20 minutes past meridian (5 degrees) and 2 degrees sync offset should be no problem but it refused to sync. That's why I decided to test it in simulation. Anyhow this is not a problem of CCDCIEL. Sorry for this unnecessary bug report. This issue can be closed.

For me it is also time to start using plate solving to study my mount behavior. A flip causes a too large offset.

Patrick Chevalley

19-03-05 23:27

administrator   ~0005460

I close the issue.
But this is not an unnecessary report, it let me find another issue and I change the error message to be more clear about the sideofpier issue, it is not normal I have to look at the code to know what the error was.

A large offset after the flip is maybe due to cone error, because the optical axis is not perpendicular to the declination axis.

Issue History

Date Modified Username Field Change
19-03-05 19:54 han New Issue
19-03-05 19:54 han File Added: meridianflip1.png
19-03-05 19:54 han File Added: meridianflip2.png
19-03-05 20:18 Patrick Chevalley Assigned To => Patrick Chevalley
19-03-05 20:18 Patrick Chevalley Status new => assigned
19-03-05 20:18 Patrick Chevalley Target Version => 1.0
19-03-05 20:18 Patrick Chevalley Note Added: 0005453
19-03-05 20:56 han Note Added: 0005455
19-03-05 21:12 Patrick Chevalley Note Added: 0005456
19-03-05 21:41 Patrick Chevalley Note Added: 0005457
19-03-05 22:05 Patrick Chevalley Note Added: 0005458
19-03-05 22:54 han Note Added: 0005459
19-03-05 23:27 Patrick Chevalley Status assigned => resolved
19-03-05 23:27 Patrick Chevalley Resolution open => no change required
19-03-05 23:27 Patrick Chevalley Note Added: 0005460