View Issue Details

IDProjectCategoryView StatusLast Update
0002099CCdcielGeneralpublic19-04-27 21:14
ReporterThomas Jaeger Assigned ToPatrick Chevalley  
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLinux 
Product Version0.9 
Target Version1.0 
Summary0002099: Change of binning causes a false image geometrie
DescriptionWith a new version of CCDCiel or possible the INDILib came a new severer issue. I recognized this issue during stacking. My Bias and Dark had a other image geometry than recent imaged lights.

Steps To ReproduceTo reproduce this, change binning to bin4x4, make a image, than change it to bin1x1 an the image geometry does not return to the maximum again.

Press reset in image Frame
1x1 -> Camera frame x=0 y=0 width=5496 height=3672
4x4 -> 1396x... (shown right in status bar, not in log)
1x1 -> Camera frame x=0 y=0 width=5472 height=3672

-----------------------------------------------------------------------------------------------

A second issue it the incorrect logging of the "Camera Frame ..." log.
2019-03-23T13:06:41.732 2: Set Binning 4x4
2019-03-23T13:06:41.732 3: ZWO CCD ASI183MM Pro: Set binning 4x4
2019-03-23T13:06:41.936 2: Start single preview
2019-03-23T13:06:42.350 2: Camera frame x=0 y=0 width=5472 height=3672 <- wrong! should bei 1396x...





TagsNo tags attached.

Activities

Thomas Jaeger

19-03-23 13:25

reporter  

Log_20190323_130330.log (4,634 bytes)   
2019-03-23T13:03:30.592  CCDciel Version beta 0.9.54-1487-56f3bd7 2019/03/20 18:37:31
2019-03-23T13:03:30.592  Compiled with: Lazarus 2.0.0.4 Free Pascal 3.0.4 Linux-x86_64-gtk2
2019-03-23T13:03:30.697 9: System: LinuxMint 19, Kernel: Linux 4.15.0-46-generic x86_64
2019-03-23T13:03:30.699 9: Local INDI Library: 1.7.6, Code 1.7.6-tgz. Protocol 1.7.
2019-03-23T13:03:30.699 1: CCDciel Version beta 0.9.54 Copyright (C) 2019 Patrick Chevalley. This is free software, you can redistribute it under certain conditions.
2019-03-23T13:03:30.699 1: This program comes with ABSOLUTELY NO WARRANTY; for details see Help/About
2019-03-23T13:03:30.699 3: Using configuration file ccdciel_CA300-ASI183-EQMOD.conf
2019-03-23T13:03:35.204 2: Connecting Camera INDI "ZWO CCD ASI183MM Pro" ...
2019-03-23T13:03:35.217 2: Connecting Filter wheel INDI "ASI EFW" ...
2019-03-23T13:03:35.222 2: Connecting Focuser INDI "MoonLite" ...
2019-03-23T13:03:35.231 2: Connecting Mount INDI "EQMod Mount" ...
2019-03-23T13:03:35.410 9: ZWO CCD ASI183MM Pro: Exec: indi_asi_ccd, Version: 1.1, Interface: 2
2019-03-23T13:03:35.415 9: EQMod Mount: Exec: indi_eqmod_telescope, Version: 0.6, Interface: 5
2019-03-23T13:03:35.513 9: MoonLite: Exec: indi_moonlite_focus, Version: 1.0, Interface: 8
2019-03-23T13:03:38.725 1: EQMod Mount: [ERROR] Failed to connect to port (/dev/ttyUSB0). Error: Port failure Error: No such file or directory. Check if device is connected to this port.
2019-03-23T13:03:39.061 2: Connecting Camera INDI "ZWO CCD ASI183MM Pro" ...
2019-03-23T13:03:39.121 2: Connecting Camera INDI "ZWO CCD ASI183MM Pro" ...
2019-03-23T13:03:39.138 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-23T13:03:39.140 2: Camera cooler : True
2019-03-23T13:03:39.726 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-23T13:03:41.509 1: Camera connected
2019-03-23T13:03:42.632 3: ZWO CCD ASI183MM Pro: Set temperature ramp to -20.0C started
2019-03-23T13:03:43.882 1: MoonLite: [ERROR] Failed to connect to port (/dev/ttyUSB1). Error: Port failure Error: No such file or directory. Check if device is connected to this port.
2019-03-23T13:03:51.310 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-23T13:04:28.028 2: Start single preview
2019-03-23T13:04:31.597 2: End preview
2019-03-23T13:04:35.262 0: ASI EFW: Error
2019-03-23T13:04:35.262 0: ASI EFW: Missing property CONFIG_PROCESS
2019-03-23T13:04:35.267 0: MoonLite: Error
2019-03-23T13:04:35.267 0: MoonLite: Missing property FOCUS_MOTION
2019-03-23T13:04:35.269 0: EQMod Mount: Error
2019-03-23T13:04:35.269 0: EQMod Mount: Missing property EQUATORIAL_EOD_COORD or EQUATORIAL_COORD
2019-03-23T13:04:35.377 0: ASI EFW: Server Disconnected
2019-03-23T13:04:35.379 0: MoonLite: Server Disconnected
2019-03-23T13:04:35.380 0: EQMod Mount: Server Disconnected
2019-03-23T13:04:41.852 2: Start single preview
2019-03-23T13:04:45.301 2: End preview
2019-03-23T13:05:01.824 2: Set Binning 1x1
2019-03-23T13:05:01.824 3: ZWO CCD ASI183MM Pro: Set binning 1x1
2019-03-23T13:05:02.028 2: Start single preview
2019-03-23T13:05:02.438 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-23T13:05:09.081 2: End preview
2019-03-23T13:05:16.893 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-23T13:05:29.561 2: Set Binning 4x4
2019-03-23T13:05:29.561 3: ZWO CCD ASI183MM Pro: Set binning 4x4
2019-03-23T13:05:29.768 2: Start single preview
2019-03-23T13:05:30.177 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-23T13:05:33.212 2: End preview
2019-03-23T13:05:46.529 2: Start single preview
2019-03-23T13:05:50.057 2: End preview
2019-03-23T13:06:04.248 2: Set Binning 1x1
2019-03-23T13:06:04.248 3: ZWO CCD ASI183MM Pro: Set binning 1x1
2019-03-23T13:06:04.458 2: Start single preview
2019-03-23T13:06:11.490 2: End preview
2019-03-23T13:06:16.546 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-23T13:06:23.098 2: Start single preview
2019-03-23T13:06:30.062 2: End preview
2019-03-23T13:06:41.732 2: Set Binning 4x4
2019-03-23T13:06:41.732 3: ZWO CCD ASI183MM Pro: Set binning 4x4
2019-03-23T13:06:41.936 2: Start single preview
2019-03-23T13:06:42.350 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-23T13:06:45.378 2: End preview
2019-03-23T13:07:02.418 2: Set Binning 1x1
2019-03-23T13:07:02.418 3: ZWO CCD ASI183MM Pro: Set binning 1x1
2019-03-23T13:07:02.626 2: Start single preview
2019-03-23T13:07:09.670 2: End preview
2019-03-23T13:07:16.798 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-23T13:07:20.482 2: Start single preview
2019-03-23T13:07:27.496 2: End preview
2019-03-23T13:07:34.426 3: ZWO CCD ASI183MM Pro: Set temperature ramp finished
Log_20190323_130330.log (4,634 bytes)   

Patrick Chevalley

19-03-23 18:57

administrator   ~0005479

Hi Thomas,

With INDI the ccdframe value are always in unbinned pixel, so if you only change the binning the box with the frame size must not change, same for the values in the log.

In the log we see the frame size change immediately when the camera is connected:
2019-03-23T13:03:39.121 2: Connecting Camera INDI "ZWO CCD ASI183MM Pro" ...
2019-03-23T13:03:39.138 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-23T13:03:39.140 2: Camera cooler : True
2019-03-23T13:03:39.726 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-23T13:03:41.509 1: Camera connected

Then it change many time between this two values.

Do you have an idea why? what is the correct one?
It is possible this is when loading the default configuration. Can you check in ~/.indi/ for a file with the camera name ending with .xml and .xml.default.
Open each file and look for CCD_FRAME , then WIDTH and HEIGHT, do you find this values?

Also 5472/4=1368 and 5496/4=1374, are you sure you see 1396 for the binned image width?

An interesting test is to change binning and take test exposure using only a simple Indi client, not ccdciel.
From the indi client, connect the camera, in the option tab for Configuration click Load, for Upload click Local.
Then in Main Control set the Expose Duration=1, this take an image.
Repeat after changing the binning in the Image setting tab. Also check for Frame size in this tab.
Check the result in the files ~/IMAGE_xxx.fits

Thomas Jaeger

19-03-23 20:46

reporter   ~0005480

In my case, I changed the binning with the CCDCiel/Preview/Binning
The correct geometry comes when I press CCDCiel/Frame/Reset. It is 5496x3672px.

>Then it change many time between this two values.
This came from my pressing frame/reset to reproduce it again and again.

>Also 5472/4=1368 and 5496/4=1374, are you sure you see 1396 for the binned image width?
I was small on the status bar, I will check this.

I understand the test with the Indi Driver, I will do this tomorrow.

Thomas

Thomas Jaeger

19-03-24 09:27

reporter   ~0005481

An interesting test is to change binning and take test exposure using only a simple Indi client, not ccdciel.
From the indi client, connect the camera, in the option tab for Configuration click Load, for Upload click Local.
Then in Main Control set the Expose Duration=1, this take an image.
Repeat after changing the binning in the Image setting tab. Also check for Frame size in this tab.
Check the result in the files ~/IMAGE_xxx.fits

I did this test.
1. After load in the INDI Client the image geometry was 5496x367px what is the right value for my camera (After reloading defaults.png), I made a image, the result was right.
2. Setting binning 4x4 is crazy, the downloaded image has the right geometry of 1368x918px but the INDI Frame setting changes to 5472x3672px what is wrong. (After switching to 4x4.png)

3. Going back to 1x1 binning results in a Image of 5472x3672px

This is not a failure of CCDCiel but what can I do? Should I report it to Jasem Mutlaq or is there a change to reset a config file in a proper manner?
After reloading defaults.png (59,110 bytes)   
After reloading defaults.png (59,110 bytes)   
After switching to 4x4.png (58,363 bytes)   
After switching to 4x4.png (58,363 bytes)   

Patrick Chevalley

19-03-24 11:37

administrator   ~0005482

I see you report it in the Indi forum, wait for Jasem response.

You can try to save the default when the width is 5472, so it start with this value. But a "reset frame" will set it back to the max reported size of 5496.

Is 1368x918px the camera specification for bin 4x4?
In this case this can explain why it set this size, 4*1368=5472.
Otherwise it must be 1374x918, 4*1374=5496.

Thomas Jaeger

19-03-25 15:39

reporter   ~0005483

I checked this before I reported this. Reset frame works right and set it back to the right bin1x1 size.
I usally take 4x4 frame loops to center my objects. My last photo session was affected with this bug. I had to crop my masterdark and masterbias to rescue this session.
Thomas

Patrick Chevalley

19-03-26 22:16

administrator   ~0005492

I think the origin of the problem is now clear:
https://www.indilib.org/forum/ekos/4517-can-not-calibrate-images-captured-with-ekos-stellarmate-in-pixinsight.html?start=60#37008

But I am not sure if this can be fixed in INDI.
So I make a fix that must work on every case. When the ROI cover almost all the sensor size it do a CCD_FRAME_RESET before to set the new binning. The effect is to reset the binning to 1x1 and the frame to the max size, so the subsequent binning command always start at the same point and not at the value rounded by the previous binning.
https://github.com/pchev/ccdciel/commit/d0d69046e4f3d9cca75ff933c01c350be76ba26e

I make a test version you can try immediately:
https://vega.ap-i.net/tmp/ccdciel_0.9.54-1492_amd64.deb
Can you confirm if this solve the issue.

Thomas Jaeger

19-03-27 18:06

reporter   ~0005505

Thank you very much for your effort.
I tried your test version and it works.
Thomas

Patrick Chevalley

19-03-27 21:24

administrator   ~0005507

Thank you for testing Thomas.

I let the issue open for now to see how this evolve in INDI. It is probably best if this can be solved in driver and not request specific sequence in every application.

Thomas Jaeger

19-03-30 11:23

reporter   ~0005519

Last night it was clear and I took 0.9.54-1492 out in the field. There was only one situation in which your special version fails. Besides this it worked wonderful.
I have commended the log.
Jasem has not yet replied to my bug report,
Log_20190329_194741.log (24,005 bytes)   
2019-03-29T19:47:41.539  CCDciel Version beta 0.9.54-1492-d0d6904 2019/03/26 22:04:23
2019-03-29T19:47:41.539  Compiled with: Lazarus 2.0.0.4 Free Pascal 3.0.4 Linux-x86_64-gtk2
2019-03-29T19:47:41.668 9: System: LinuxMint 19, Kernel: Linux 4.15.0-46-generic x86_64
2019-03-29T19:47:41.671 9: Local INDI Library: 1.7.6, Code 1.7.6-tgz. Protocol 1.7.
2019-03-29T19:47:41.671 1: CCDciel Version beta 0.9.54 Copyright (C) 2019 Patrick Chevalley. This is free software, you can redistribute it under certain conditions.
2019-03-29T19:47:41.671 1: This program comes with ABSOLUTELY NO WARRANTY; for details see Help/About
#
# Thanks Patrick for developing this wonderful software
#
2019-03-29T19:47:41.671 3: Using configuration file ccdciel_NON1k-ASI183.conf
2019-03-29T19:47:43.291 2: Connecting Camera INDI "ZWO CCD ASI183MM Pro" ...
2019-03-29T19:47:43.312 2: Connecting Filter wheel INDI "ASI EFW" ...
2019-03-29T19:47:43.318 2: Connecting Focuser INDI "MoonLite" ...
2019-03-29T19:47:43.401 9: ZWO CCD ASI183MM Pro: Exec: indi_asi_ccd, Version: 1.1, Interface: 2
2019-03-29T19:47:43.404 2: Connecting Camera INDI "ZWO CCD ASI183MM Pro" ...
2019-03-29T19:47:43.406 2: Connecting Camera INDI "ZWO CCD ASI183MM Pro" ...
2019-03-29T19:47:43.508 9: MoonLite: Exec: indi_moonlite_focus, Version: 1.0, Interface: 8
2019-03-29T19:47:43.510 1: Focuser connected
2019-03-29T19:47:43.607 9: ASI EFW: Exec: indi_asi_wheel, Version: 1.1, Interface: 16
2019-03-29T19:47:43.608 1: Filter wheel connected
2019-03-29T19:47:43.718 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-29T19:47:43.719 2: Camera cooler : True
2019-03-29T19:47:46.708 1: Camera connected
2019-03-29T19:47:47.737 3: ZWO CCD ASI183MM Pro: Set temperature -20.0C
2019-03-29T19:49:28.190 3: ZWO CCD ASI183MM Pro: Set frame type Light   
2019-03-29T19:49:28.191 2: Start single preview
2019-03-29T19:49:33.768 2: End preview
#
#  Astrometry and CDC to analyse where the telescope is pointed
#
2019-03-29T19:53:16.700 2: Set Binning 4x4
2019-03-29T19:53:16.700 3: ZWO CCD ASI183MM Pro: Set binning 4x4
2019-03-29T19:53:17.112 2: Start preview loop
2019-03-29T19:53:17.579 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-29T19:53:53.788 1: Planetarium: Cartes du Ciel connected
2019-03-29T19:53:55.395 1: Autoguider: Connecting
2019-03-29T19:53:55.505 1: Autoguider: PHD version: 2.6.5dev7
2019-03-29T19:53:55.505 2: Autoguider: Stopped
2019-03-29T20:00:08.778 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:00:08.778 2: Abort exposure
2019-03-29T20:00:08.783 2: Stop preview loop
2019-03-29T20:02:35.493 2: Start preview loop
2019-03-29T20:02:43.356 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:02:43.357 2: Abort exposure
2019-03-29T20:02:43.360 2: Stop preview loop
2019-03-29T20:02:49.443 2: Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2019-03-29T20:02:49.444 3: Resolving using Astrometry.Net ...
2019-03-29T20:02:52.331 2: Open file /home/starhopper/.config/ccdciel/tmp/ccdcielsolved.fits
2019-03-29T20:02:52.331 2: Astrometry.Net resolve successful. Solved in 3 seconds
2019-03-29T20:02:53.776 1: CCD frame sent to planetarium.
2019-03-29T20:03:13.454 2: Start preview loop
2019-03-29T20:03:47.858 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:03:47.859 2: Abort exposure
2019-03-29T20:03:47.861 2: Stop preview loop
2019-03-29T20:03:51.617 2: Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2019-03-29T20:03:51.618 3: Resolving using Astrometry.Net ...
2019-03-29T20:03:53.057 2: Open file /home/starhopper/.config/ccdciel/tmp/ccdcielsolved.fits
2019-03-29T20:03:53.057 2: Astrometry.Net resolve successful. Solved in 1 seconds
2019-03-29T20:03:54.502 1: CCD frame sent to planetarium.
2019-03-29T20:04:16.753 2: Start preview loop
2019-03-29T20:04:51.259 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:04:51.259 2: Abort exposure
2019-03-29T20:04:51.263 2: Stop preview loop
2019-03-29T20:04:54.004 2: Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2019-03-29T20:04:54.006 3: Resolving using Astrometry.Net ...
2019-03-29T20:04:55.553 2: Open file /home/starhopper/.config/ccdciel/tmp/ccdcielsolved.fits
2019-03-29T20:04:55.553 2: Astrometry.Net resolve successful. Solved in 2 seconds
2019-03-29T20:04:56.988 1: CCD frame sent to planetarium.
2019-03-29T20:05:39.694 2: Start single preview
2019-03-29T20:05:45.794 2: End preview
2019-03-29T20:06:01.125 2: Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2019-03-29T20:06:01.127 3: Resolving using Astrometry.Net ...
2019-03-29T20:06:02.605 2: Open file /home/starhopper/.config/ccdciel/tmp/ccdcielsolved.fits
2019-03-29T20:06:02.605 2: Astrometry.Net resolve successful. Solved in 1 seconds
2019-03-29T20:06:04.049 1: CCD frame sent to planetarium.
2019-03-29T20:06:22.105 2: Start preview loop
2019-03-29T20:06:54.966 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:06:54.966 2: Abort exposure
2019-03-29T20:06:54.970 2: Stop preview loop
2019-03-29T20:06:57.922 2: Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2019-03-29T20:06:57.924 3: Resolving using Astrometry.Net ...
2019-03-29T20:06:59.508 2: Open file /home/starhopper/.config/ccdciel/tmp/ccdcielsolved.fits
2019-03-29T20:06:59.508 2: Astrometry.Net resolve successful. Solved in 2 seconds
2019-03-29T20:07:01.161 1: CCD frame sent to planetarium.
2019-03-29T20:07:23.071 2: Start preview loop
2019-03-29T20:07:46.234 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:07:46.234 2: Abort exposure
2019-03-29T20:07:46.238 2: Stop preview loop
2019-03-29T20:07:47.614 2: Start single preview
2019-03-29T20:07:49.676 2: End preview
2019-03-29T20:07:53.393 2: Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2019-03-29T20:07:53.396 3: Resolving using Astrometry.Net ...
2019-03-29T20:07:55.887 2: Open file /home/starhopper/.config/ccdciel/tmp/ccdcielsolved.fits
2019-03-29T20:07:55.887 2: Astrometry.Net resolve successful. Solved in 2 seconds
2019-03-29T20:07:58.323 1: Send image to planetarium
2019-03-29T20:08:21.669 2: Start single preview
2019-03-29T20:08:23.722 2: End preview
2019-03-29T20:08:27.855 2: Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2019-03-29T20:08:27.857 3: Resolving using Astrometry.Net ...
2019-03-29T20:08:29.444 2: Open file /home/starhopper/.config/ccdciel/tmp/ccdcielsolved.fits
2019-03-29T20:08:29.444 2: Astrometry.Net resolve successful. Solved in 2 seconds
2019-03-29T20:08:32.194 1: CCD frame sent to planetarium.
2019-03-29T20:08:49.847 2: Start single preview
2019-03-29T20:08:51.848 2: End preview
2019-03-29T20:08:54.758 2: Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2019-03-29T20:08:54.759 3: Resolving using Astrometry.Net ...
2019-03-29T20:08:56.637 2: Open file /home/starhopper/.config/ccdciel/tmp/ccdcielsolved.fits
2019-03-29T20:08:56.638 2: Astrometry.Net resolve successful. Solved in 2 seconds
2019-03-29T20:08:58.071 1: CCD frame sent to planetarium.
2019-03-29T20:09:10.211 2: Start preview loop
2019-03-29T20:09:25.129 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:09:25.129 2: Abort exposure
2019-03-29T20:09:25.131 2: Stop preview loop
2019-03-29T20:09:30.502 2: Start single preview
2019-03-29T20:09:36.613 2: End preview
2019-03-29T20:10:01.746 2: Start single preview
2019-03-29T20:10:11.932 2: Autoguider: Looping Exposures
2019-03-29T20:10:12.859 2: End preview
2019-03-29T20:10:14.769 2: Autoguider: Lock Position Set
2019-03-29T20:10:14.847 2: Autoguider: Star Selected
2019-03-29T20:10:15.269 2: Autoguider: Looping Exposures
2019-03-29T20:10:23.762 2: Autoguider: Exposures Stopped
2019-03-29T20:10:24.282 2: Autoguider: Lock Position Lost
2019-03-29T20:10:37.694 2: Start preview loop
2019-03-29T20:11:16.842 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:11:16.842 2: Abort exposure
2019-03-29T20:11:16.846 2: Stop preview loop
2019-03-29T20:11:20.709 3: ZWO CCD ASI183MM Pro: Set binning 4x4
2019-03-29T20:11:20.927 3: Take control exposure for 2.0 seconds
2019-03-29T20:11:20.927 3: ZWO CCD ASI183MM Pro: Set binning 4x4
2019-03-29T20:11:21.539 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-29T20:11:21.951 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-29T20:11:22.460 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-29T20:11:22.774 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-29T20:11:25.519 3: ZWO CCD ASI183MM Pro: Set binning 1x1
2019-03-29T20:11:26.408 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-29T20:11:26.946 2: Autofocus start Dynamic curve
#
#  Finetune the center the object 'SextansA' manually with bin 4x4
#
2019-03-29T20:11:26.946 2: Set Binning 4x4
2019-03-29T20:11:26.947 3: ZWO CCD ASI183MM Pro: Set binning 4x4
2019-03-29T20:11:27.286 2: Focuser temperature: 20.0C
2019-03-29T20:11:27.286 2: AutoFocus started, initial position: 1491
2019-03-29T20:11:27.590 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-29T20:11:30.476 3: Using median of 23 stars
2019-03-29T20:11:30.498 3: Autofocus running, hfd=2.4 peak:28538.3 snr:286.8
2019-03-29T20:11:30.499 3: MoonLite: Focuser move to 1560 + 50 Backlash compensation
2019-03-29T20:11:35.995 3: MoonLite: Focuser move to 1560
2019-03-29T20:11:42.620 3: Using median of 11 stars
2019-03-29T20:11:42.637 3: Autofocus running, hfd=5.1 peak:25614.2 snr:51.4
2019-03-29T20:11:42.637 3: MoonLite: Focuser move to 1537
2019-03-29T20:11:47.821 3: Using median of 21 stars
2019-03-29T20:11:47.838 3: Autofocus running, hfd=3.4 peak:23804.0 snr:74.7
2019-03-29T20:11:47.838 3: MoonLite: Focuser move to 1514
2019-03-29T20:11:53.225 3: Using median of 23 stars
2019-03-29T20:11:53.244 3: Autofocus running, hfd=2.8 peak:28921.6 snr:139.9
2019-03-29T20:11:53.244 3: MoonLite: Focuser move to 1491
2019-03-29T20:11:58.632 3: Using median of 22 stars
2019-03-29T20:11:58.649 3: Autofocus running, hfd=2.5 peak:32417.1 snr:254.8
2019-03-29T20:11:58.649 3: MoonLite: Focuser move to 1468
2019-03-29T20:12:03.948 3: Using median of 22 stars
2019-03-29T20:12:03.964 3: Autofocus running, hfd=2.7 peak:34715.3 snr:251.3
2019-03-29T20:12:03.964 3: MoonLite: Focuser move to 1445
2019-03-29T20:12:09.246 3: Using median of 21 stars
2019-03-29T20:12:09.261 3: Autofocus running, hfd=3.1 peak:26123.5 snr:141.4
2019-03-29T20:12:09.261 3: MoonLite: Focuser move to 1422
2019-03-29T20:12:14.646 3: Using median of 14 stars
2019-03-29T20:12:14.661 3: Autofocus running, hfd=4.5 peak:32762.5 snr:125.7
2019-03-29T20:12:14.683 3: HYPERBOLA curve fitting focus at 4.188,  remaining curve fit error 0.1535,  iteration cycles 3
2019-03-29T20:12:14.683 3: MoonLite: Focuser move to 1487 + 50 Backlash compensation
2019-03-29T20:12:19.579 3: MoonLite: Focuser move to 1487
2019-03-29T20:12:25.974 3: Using median of 21 stars
2019-03-29T20:12:25.992 2: Autofocus finished, POS=1487 HFD=2.1 PEAK:28830.8 SNR:395.1 TEMP:20.0C
2019-03-29T20:12:25.993 3: ZWO CCD ASI183MM Pro: Set binning 4x4
2019-03-29T20:12:26.204 1: AutoFocus successful
2019-03-29T20:12:26.204 2: Set Binning 4x4
2019-03-29T20:12:26.204 3: ZWO CCD ASI183MM Pro: Set binning 4x4
2019-03-29T20:12:26.712 2: End preview
2019-03-29T20:12:26.718 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-29T20:12:27.019 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-29T20:12:27.837 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-29T20:12:28.183 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-29T20:12:53.534 2: Autoguider: Looping Exposures
2019-03-29T20:12:55.201 2: Autoguider: Star Selected
2019-03-29T20:12:56.536 2: Autoguider: Looping Exposures
2019-03-29T20:12:57.642 2: Autoguider: Lock Position Set
2019-03-29T20:12:57.952 2: Autoguider: Star Selected
2019-03-29T20:12:58.205 2: Autoguider: Looping Exposures
2019-03-29T20:13:01.267 2: Autoguider: Lock Position Set
2019-03-29T20:13:01.543 2: Autoguider: Star Selected
2019-03-29T20:13:02.541 2: Autoguider: Looping Exposures
2019-03-29T20:13:04.120 2: Autoguider: Lock Position Set
2019-03-29T20:13:04.211 2: Autoguider: Star Selected
2019-03-29T20:13:05.543 2: Autoguider: Looping Exposures
2019-03-29T20:13:11.740 2: Autoguider: Lock Position Set
2019-03-29T20:13:12.221 2: Autoguider: Star Selected
2019-03-29T20:13:13.223 2: Autoguider: Looping Exposures
2019-03-29T20:13:16.284 2: Autoguider: Lock Position Set
2019-03-29T20:13:16.555 2: Autoguider: Star Selected
2019-03-29T20:13:17.556 2: Autoguider: Looping Exposures
2019-03-29T20:13:30.253 2: Autoguider: Lock Position Set
2019-03-29T20:13:30.570 2: Autoguider: Star Selected
2019-03-29T20:13:31.240 2: Autoguider: Looping Exposures
2019-03-29T20:13:35.370 2: Autoguider: Lock Position Set
2019-03-29T20:13:35.446 2: Autoguider: Star Selected
2019-03-29T20:13:35.572 2: Autoguider: Looping Exposures
2019-03-29T20:13:52.262 2: Autoguider: Star lost
2019-03-29T20:13:52.265 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:13:52.265 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:13:53.426 2: Autoguider: Looping Exposures
2019-03-29T20:13:53.589 2: Autoguider: Star Selected
2019-03-29T20:13:55.266 2: Autoguider: Looping Exposures
2019-03-29T20:14:12.825 2: Autoguider: Lock Position Set
2019-03-29T20:14:13.285 2: Autoguider: Star Selected
2019-03-29T20:14:13.608 2: Autoguider: Looping Exposures
2019-03-29T20:14:15.273 2: Autoguider: Lock Position Set
2019-03-29T20:14:15.287 2: Autoguider: Star Selected
2019-03-29T20:14:15.610 2: Autoguider: Looping Exposures
2019-03-29T20:14:35.631 2: Autoguider: Star lost
2019-03-29T20:14:35.634 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:14:35.634 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:14:37.431 2: Autoguider: Looping Exposures
2019-03-29T20:14:37.632 2: Autoguider: Star Selected
2019-03-29T20:14:39.635 2: Autoguider: Looping Exposures
2019-03-29T20:14:55.650 2: Autoguider: Star lost
2019-03-29T20:14:55.653 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:14:55.653 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:14:57.450 2: Autoguider: Looping Exposures
2019-03-29T20:14:57.652 2: Autoguider: Star Selected
2019-03-29T20:14:59.654 2: Autoguider: Looping Exposures
2019-03-29T20:15:13.668 2: Autoguider: Star lost
2019-03-29T20:15:13.670 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:15:13.670 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:15:15.428 2: Autoguider: Looping Exposures
2019-03-29T20:15:15.670 2: Autoguider: Star Selected
2019-03-29T20:15:17.671 2: Autoguider: Looping Exposures
2019-03-29T20:15:29.682 2: Autoguider: Star lost
2019-03-29T20:15:29.685 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:15:29.686 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:15:31.426 2: Autoguider: Looping Exposures
2019-03-29T20:15:31.683 2: Autoguider: Star Selected
2019-03-29T20:15:33.686 2: Autoguider: Looping Exposures
2019-03-29T20:15:36.367 2: Autoguider: Lock Position Set
2019-03-29T20:15:36.386 2: Autoguider: Star Selected
2019-03-29T20:15:37.688 2: Autoguider: Looping Exposures
2019-03-29T20:15:53.407 2: Autoguider: Star lost
2019-03-29T20:15:53.409 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:15:53.409 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:15:55.445 2: Autoguider: Looping Exposures
2019-03-29T20:15:55.708 2: Autoguider: Star Selected
2019-03-29T20:15:57.709 2: Autoguider: Looping Exposures
2019-03-29T20:16:05.717 2: Autoguider: Star lost
2019-03-29T20:16:05.719 1: Autoguider: StarLost Stern verloren - Größe geändert
2019-03-29T20:16:05.720 1: Autoguider: StarLost Stern verloren - Größe geändert
2019-03-29T20:16:07.719 2: Autoguider: Looping Exposures
2019-03-29T20:16:09.721 2: Autoguider: Star Selected
2019-03-29T20:16:11.429 2: Autoguider: Looping Exposures
2019-03-29T20:16:15.434 2: Autoguider: Star lost
2019-03-29T20:16:15.435 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:16:15.436 1: Autoguider: StarLost Stern verloren - geringe Größe
2019-03-29T20:16:17.728 2: Autoguider: Looping Exposures
2019-03-29T20:16:30.585 2: Autoguider: Lock Position Set
2019-03-29T20:16:30.740 2: Autoguider: Star Selected
2019-03-29T20:16:31.453 2: Autoguider: Looping Exposures
2019-03-29T20:16:34.746 2: Autoguider: Start Calibration
2019-03-29T20:17:33.456 2: Autoguider: Calibration Complete
2019-03-29T20:17:33.524 2: Autoguider: Start Guiding
2019-03-29T20:17:35.519 2: Autoguider: Guiding
2019-03-29T20:18:37.405 2: Autoguider: Stopped
2019-03-29T20:18:37.594 2: Autoguider: Lock Position Lost
2019-03-29T20:18:46.677 2: Start single preview
2019-03-29T20:18:49.672 2: End preview
2019-03-29T20:18:55.819 2: Start single preview
2019-03-29T20:19:06.942 2: End preview
2019-03-29T20:19:33.536 2: Start preview loop
2019-03-29T20:19:59.925 2: Autoguider: Star Selected
2019-03-29T20:20:13.269 2: Autoguider: Lock Position Set
2019-03-29T20:20:13.421 2: Autoguider: Start Guiding
2019-03-29T20:20:14.885 2: Autoguider: Guiding
2019-03-29T20:20:17.703 2: Autoguider: Stopped
2019-03-29T20:20:17.762 2: Autoguider: Exposures Stopped
2019-03-29T20:20:17.893 2: Autoguider: Lock Position Lost
2019-03-29T20:20:18.808 2: Autoguider: Star Selected
2019-03-29T20:20:21.499 2: Autoguider: Lock Position Set
2019-03-29T20:20:21.620 2: Autoguider: Star Selected
2019-03-29T20:20:23.743 2: Autoguider: Lock Position Set
2019-03-29T20:20:23.893 2: Autoguider: Star Selected
2019-03-29T20:20:30.208 2: Autoguider: Lock Position Set
2019-03-29T20:20:30.661 2: Autoguider: Start Guiding
2019-03-29T20:20:31.921 2: Autoguider: Guiding
2019-03-29T20:20:42.875 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:20:42.875 2: Abort exposure
2019-03-29T20:20:42.879 2: Stop preview loop
2019-03-29T20:20:46.609 2: Start single preview
2019-03-29T20:20:57.723 2: End preview
2019-03-29T20:22:23.648 2: Start preview loop
2019-03-29T20:22:28.797 2: Autoguider: Stopped
2019-03-29T20:22:28.915 2: Autoguider: Lock Position Lost
2019-03-29T20:23:03.455 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:23:03.455 2: Abort exposure
2019-03-29T20:23:03.459 2: Stop preview loop
2019-03-29T20:23:07.084 2: Start single preview
2019-03-29T20:23:12.196 2: Autoguider: Looping Exposures
2019-03-29T20:23:13.892 2: Autoguider: Star Selected
2019-03-29T20:23:14.627 2: Autoguider: Lock Position Set
2019-03-29T20:23:14.893 2: Autoguider: Star Selected
2019-03-29T20:23:15.196 2: Autoguider: Looping Exposures
2019-03-29T20:23:18.073 2: End preview
2019-03-29T20:23:18.187 2: Autoguider: Lock Position Set
2019-03-29T20:23:18.279 2: Autoguider: Start Guiding
2019-03-29T20:23:19.898 2: Autoguider: Guiding
#
# Start sequence
#
2019-03-29T20:24:22.659 1: Starting sequence 
2019-03-29T20:24:32.774 3: CCD temperature: -20.0C
2019-03-29T20:24:32.776 1: Starting sequence SextansA
2019-03-29T20:24:32.804 2: Stop autoguider
2019-03-29T20:24:32.925 3: : Stop telescope motion.
2019-03-29T20:24:32.927 1: Initialize target sextansA
2019-03-29T20:24:32.931 1: Object sextansA, start plan LRGB4mGain53
2019-03-29T20:24:32.932 3: ASI EFW: Set filter position 2
2019-03-29T20:24:33.255 2: Autoguider: Stopped
2019-03-29T20:24:33.368 2: Autoguider: Lock Position Lost
2019-03-29T20:24:39.909 1: Start step R4m
2019-03-29T20:24:39.910 2: Start capture
2019-03-29T20:24:39.910 2: Set Binning 1x1
2019-03-29T20:24:39.910 3: ZWO CCD ASI183MM Pro: Set binning 1x1
2019-03-29T20:24:40.126 1: Autofocus now
2019-03-29T20:24:40.126 2: Stay at the current position for autofocus
2019-03-29T20:24:40.126 2: Focuser temperature: 20.0C
2019-03-29T20:24:40.126 3: ZWO CCD ASI183MM Pro: Set binning 4x4
2019-03-29T20:24:40.836 3: Take control exposure for 2.0 seconds
2019-03-29T20:24:40.949 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-29T20:24:41.359 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-29T20:24:45.297 2: Autofocus start Dynamic curve
2019-03-29T20:24:45.297 2: Focuser temperature: 20.0C
2019-03-29T20:24:45.297 2: AutoFocus started, initial position: 1487
2019-03-29T20:24:48.660 3: Using median of 15 stars
2019-03-29T20:24:48.677 3: Autofocus running, hfd=2.3 peak:37950.7 snr:152.3
2019-03-29T20:24:48.677 3: MoonLite: Focuser move to 1556 + 50 Backlash compensation
2019-03-29T20:24:53.908 3: MoonLite: Focuser move to 1556
2019-03-29T20:25:00.778 3: Using median of 7 stars
2019-03-29T20:25:00.795 3: Autofocus running, hfd=4.5 peak:31918.6 snr:34.5
2019-03-29T20:25:00.795 3: MoonLite: Focuser move to 1533
2019-03-29T20:25:06.696 3: Using median of 14 stars
2019-03-29T20:25:06.713 3: Autofocus running, hfd=2.8 peak:35041.1 snr:70.6
2019-03-29T20:25:06.713 3: MoonLite: Focuser move to 1510
2019-03-29T20:25:12.707 3: Using median of 16 stars
2019-03-29T20:25:12.724 3: Autofocus running, hfd=2.2 peak:51876.4 snr:149.1
2019-03-29T20:25:12.724 3: MoonLite: Focuser move to 1487
2019-03-29T20:25:18.602 3: Using median of 14 stars
2019-03-29T20:25:18.619 3: Autofocus running, hfd=2.2 peak:51530.8 snr:138.2
2019-03-29T20:25:18.619 3: MoonLite: Focuser move to 1464
2019-03-29T20:25:24.620 3: Using median of 15 stars
2019-03-29T20:25:24.637 3: Autofocus running, hfd=2.7 peak:46457.5 snr:90.3
2019-03-29T20:25:24.637 3: MoonLite: Focuser move to 1441
2019-03-29T20:25:30.620 3: Using median of 11 stars
2019-03-29T20:25:30.637 3: Autofocus running, hfd=3.9 peak:37558.0 snr:29.9
2019-03-29T20:25:30.637 3: MoonLite: Focuser move to 1418
2019-03-29T20:25:36.619 3: Using median of 6 stars
2019-03-29T20:25:36.634 3: Autofocus running, hfd=5.6 peak:34043.9 snr:24.8
2019-03-29T20:25:36.662 3: HYPERBOLA curve fitting focus at 3.588,  remaining curve fit error 0.1388,  iteration cycles 4
2019-03-29T20:25:36.663 3: MoonLite: Focuser move to 1496 + 50 Backlash compensation
2019-03-29T20:25:42.366 3: MoonLite: Focuser move to 1496
2019-03-29T20:25:49.176 3: Using median of 16 stars
2019-03-29T20:25:49.196 2: Autofocus finished, POS=1496 HFD=2.0 PEAK:60186.1 SNR:221.6 TEMP:20.0C
2019-03-29T20:25:49.196 3: ZWO CCD ASI183MM Pro: Set binning 1x1
2019-03-29T20:25:49.407 1: AutoFocus successful
2019-03-29T20:25:49.408 2: End preview
2019-03-29T20:25:49.408 2: Restart autoguider
2019-03-29T20:25:50.119 2: Camera frame x=0 y=0 width=5496 height=3672
2019-03-29T20:25:50.431 2: Camera frame x=0 y=0 width=5472 height=3672
2019-03-29T20:25:59.019 2: Autoguider: Star Selected
2019-03-29T20:26:00.460 2: Autoguider: Looping Exposures
2019-03-29T20:26:09.348 2: Autoguider: Lock Position Set
2019-03-29T20:26:09.457 2: Autoguider: Looping Exposures
2019-03-29T20:26:12.505 2: Autoguider: Start Guiding
2019-03-29T20:26:14.045 2: Autoguider: Settling
2019-03-29T20:26:23.038 2: Autoguider: Guiding
2019-03-29T20:26:25.081 1: Starting Light exposure 1/7 for 240 seconds
2019-03-29T20:28:41.133 1: Autoguider: STAR_SATURATED
2019-03-29T20:30:30.263 1: Saved file /home/starhopper/CCD/SextansA/Light/sextansA_R_240s_20190329_193030_53.fits
2019-03-29T20:30:30.269 1: Dithering...
2019-03-29T20:30:30.269 9: Enter dithering wait loop,  FDithering=True terminated=False CancelAutofocus=False FStopGuiding=False
2019-03-29T20:30:30.478 2: Autoguider: Settling
#
# I checked the final geometry with Pixinsight, it was width=5472 height=3672 - wrong - aborting sequence
#
2019-03-29T20:30:32.445 1: Request to stop the current sequence
2019-03-29T20:30:32.445 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:30:32.447 3: ZWO CCD ASI183MM Pro: Abort exposure
2019-03-29T20:30:32.447 2: Abort exposure
2019-03-29T20:30:32.448 2: Stop capture
2019-03-29T20:30:32.449 2: Stop autoguider
2019-03-29T20:30:32.572 1: No termination actions configured.
Log_20190329_194741.log (24,005 bytes)   

Patrick Chevalley

19-03-30 22:25

administrator   ~0005523

Thank you for the test.
From the log it look like some messages get delayed and maybe execute in the wrong order.
I will change that to be sure the command to reset the maximum size is executed before to continue.

Sure it will be better if the computation was fixed in the driver without the need to reset the size.

Patrick Chevalley

19-04-01 22:15

administrator   ~0005539

I make a change to be sure the server receive the frame reset before to set the binning:
https://github.com/pchev/ccdciel/commit/aa90c6c4c239ed0681fed5410471b7afbdf5b5b9

A new test version is available with this change and also the zero exposure time if you want to test it:
https://vega.ap-i.net/tmp/ccdciel_0.9.54-1512_amd64.deb

Thomas Jaeger

19-04-02 18:22

reporter   ~0005542

It is not clear at the moment in germany. I have tried to reproduce this issue in the lab (without teleskop) with 0.9.54-1492 but it won't. I will use 0.9.54-1512 as soon as it cleared here.
What can I do to speed the fix in the driver. I recognized that is also present with my old ASI1600.
Thomas

Patrick Chevalley

19-04-02 20:53

administrator   ~0005544

I don't know what to do to get a fix, I cannot work on this myself because I not have an ASI camera.
And no one look interested despite there is also a bug report with Ekos:
https://www.indilib.org/forum/ccds-dslrs/4906-asi183mm-pro-partial-image-download-with-ekos.html
Maybe bump this message and your.

I am confident that 0.9.54-1512 fix the issue but it is bad to have to do this kind of trick at the application level.

Thomas Jaeger

19-04-07 09:48

reporter   ~0005583

>I am confident that 0.9.54-1512 fix the issue but it is bad to have to do this kind of trick at the application level.

Hello,
I was in the field last night and did M97 and SextansA with 0.9.54-1512. Your fix works fine, thanks. I made a new indi forum entry under "CCD and DSLR". My last entry was on general. Unfortunately Jasem and the other developers seem to be on vacation, may on the NEAF.
I don't know.
Thomas

Thomas Jaeger

19-04-19 22:40

reporter   ~0005602

Until now, there is absolutely no response in the INDI Forum. Jasem may be busy. I sent him a message, I will wait.
Is it possible, that you let this fix in further releases after 0.9.54-1512?

Thomas Jaeger

19-04-21 14:51

reporter   ~0005603

After I sent a private message, I got some response from Jasem:
"If there is a solution to be done at the driver level (I looked into that and couldn't find something that is good to implement). Maybe Patrick from SkyCharts has an idea about this?"

Patrick Chevalley

19-04-21 21:54

administrator   ~0005604

I give a response for Jasem in your post in the INDI forum, I think it is better to use the forum to discuss this point.

Thomas Jaeger

19-04-27 12:45

reporter   ~0005616

Thank you for contribute the discussion in the INDI Forum. This entry can be closed.
Thomas

Patrick Chevalley

19-04-27 21:14

administrator   ~0005617

Great, thank you for testing!

The final fix:
https://github.com/pchev/ccdciel/commit/50b9ae2c4d0a9fda28b61c03e3226c9906d7166a

Issue History

Date Modified Username Field Change
19-03-23 13:25 Thomas Jaeger New Issue
19-03-23 13:25 Thomas Jaeger File Added: Log_20190323_130330.log
19-03-23 18:57 Patrick Chevalley Assigned To => Patrick Chevalley
19-03-23 18:57 Patrick Chevalley Status new => feedback
19-03-23 18:57 Patrick Chevalley Note Added: 0005479
19-03-23 20:46 Thomas Jaeger Note Added: 0005480
19-03-23 20:46 Thomas Jaeger Status feedback => assigned
19-03-24 09:27 Thomas Jaeger File Added: After reloading defaults.png
19-03-24 09:27 Thomas Jaeger File Added: After switching to 4x4.png
19-03-24 09:27 Thomas Jaeger Note Added: 0005481
19-03-24 11:37 Patrick Chevalley Note Added: 0005482
19-03-25 15:39 Thomas Jaeger Note Added: 0005483
19-03-26 22:16 Patrick Chevalley Status assigned => feedback
19-03-26 22:16 Patrick Chevalley Note Added: 0005492
19-03-27 18:06 Thomas Jaeger Note Added: 0005505
19-03-27 18:06 Thomas Jaeger Status feedback => assigned
19-03-27 21:24 Patrick Chevalley Note Added: 0005507
19-03-30 11:23 Thomas Jaeger File Added: Log_20190329_194741.log
19-03-30 11:23 Thomas Jaeger Note Added: 0005519
19-03-30 22:25 Patrick Chevalley Note Added: 0005523
19-04-01 22:15 Patrick Chevalley Target Version => 1.0
19-04-01 22:15 Patrick Chevalley Note Added: 0005539
19-04-01 22:15 Patrick Chevalley Status assigned => feedback
19-04-02 18:22 Thomas Jaeger Note Added: 0005542
19-04-02 18:22 Thomas Jaeger Status feedback => assigned
19-04-02 20:53 Patrick Chevalley Note Added: 0005544
19-04-07 09:48 Thomas Jaeger Note Added: 0005583
19-04-19 22:40 Thomas Jaeger Note Added: 0005602
19-04-21 14:51 Thomas Jaeger Note Added: 0005603
19-04-21 21:54 Patrick Chevalley Note Added: 0005604
19-04-27 12:45 Thomas Jaeger Note Added: 0005616
19-04-27 21:14 Patrick Chevalley Status assigned => resolved
19-04-27 21:14 Patrick Chevalley Resolution open => fixed
19-04-27 21:14 Patrick Chevalley Note Added: 0005617