View Issue Details

IDProjectCategoryView StatusLast Update
0002101CCdciel[All Projects] Generalpublic19-06-08 18:18
ReporterhanAssigned ToPatrick Chevalley 
PrioritylowSeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002101: Sequence, skipping an object in a list
DescriptionI'm still struggling with skipping an object in the sequence. I tried two method . See remark 1) in screenshot, skip doesn't work for me. Also changing the repeat interval to 0 doesn't work either. See 2)

TagsNo tags attached.

Activities

han

19-03-25 14:44

reporter  

sequence1.png (43,376 bytes)
sequence1.png (43,376 bytes)

Patrick Chevalley

19-03-25 16:13

administrator   ~0005484

We already discuss this point, skip is not meant for this use but unfortunately there is not enough space in the column header to make the text more explicit.
For the full explanation search for Skip in this page: https://www.ap-i.net/ccdciel/en/documentation/sequence
To make clear it is related to begin/end time or dark night you cannot check Skip alone.

At the moment the Repeat count column is not validated and anything smaller than 1 or non-numeric is considered as 1.

But using 0 to indicate this target must not be processed is a good idea and I can add that to the code.

han

19-03-25 16:47

reporter   ~0005485

Yes this is the second time we discuss it. I couldn't figure out last night how to skip the first step. There was a USB communication problem and the sequence was stopped, so I wanted to continue with object 2 and could figure it out. After I now understand the functionality correctly I could update the documentation. The documentation didn't help me last night.

I now understand (again) the skip is a "don't wait". If so does this text fit in the menu?

Allowing 0 as a repeat setting to skip would be nice. As a suggestion ideally would expect a check-mark at the beginning. But I don't know if you agree or it is possible. See modfied screen shot.

sequence2.png (42,158 bytes)
sequence2.png (42,158 bytes)

Patrick Chevalley

19-03-25 17:13

administrator   ~0005486

Good idea for "don't wait", I make the change.

I also commit a change to skip the target when Repeat is 0.
https://github.com/pchev/ccdciel/commit/bdc79bd4dbdc7c12d17e1c70c1190183fa7690f7

Tell me if this is OK for you.

An additional column is also an option but there is not enough space on small screen, I need the program to work on my 1024x600 netbook.

han

19-03-25 18:08

reporter   ~0005488

No all fine. The zero could be a robust method of skipping a target. I'm happy with it.

Would it make sense to fill the begin and end dropdown list with more choices? For imaging, I try to image an object near the meridian crossing, so when it is at the highest position and seeing is most likely optimal. So for the target begin & end time I would expect something like

begin:=2 hour prior to meridian crossing
begin:=1 hour prior to meridian crossing

end:=2 hour after to meridian crossing
end:=1 hour after to meridian crossing

You could fill a sequence with all Messier objects, Sharpless-2 objects or any other list of interest. The sequence could then automatically start imaging the targets near zenith. If the object is captured, the user has to set the repeat to zero till all object are imaged. That would be a nice automation!

han

19-03-25 18:29

reporter   ~0005489

Abbreviations as follows

-2:00 MC (2 hour prior to meridian crossing )
-1:00 MC
-0:30 MC

or

MC -2.0 hours
MC -1.5 hours
MC -1.0 hours
MC -0.5 hours
MC -0.0 hours
MC +0.5 hours

Patrick Chevalley

19-03-25 21:15

administrator   ~0005490

Yes this is a good option to add.
This can also be mixed with rise/set to force working on a single side of the meridian.

han

19-03-30 21:21

reporter   ~0005521

The repeat=0 works well for skipping.
Having time relative to meridian crossing would be superb.

Patrick Chevalley

19-03-30 22:37

administrator   ~0005526

Good we finally have an option to skip a target.
I am not sure I can add the meridian time this week because I am still traveling and have less time for programming.

Patrick Chevalley

19-03-31 17:35

administrator   ~0005529

The meridian crossing option is implemented:
https://github.com/pchev/ccdciel/commit/216d076d08453f5744bf35ff510b812f8f2bfabf

This was more easy than I expected but I do very limited testing, so test carefully.

han

19-03-31 18:54

reporter   ~0005531

I have quickly created an Messier sequence with all objects and tested it simulation. Unfortunately it tries to image below the horizon. I have set the minimum observatory elevation to 30 degrees and observatory position is correct. The Messier sequence is attached.

messier.zip (2,863 bytes)

Patrick Chevalley

19-03-31 19:15

administrator   ~0005532

Yes, I do the meridian test independent of the rise/set test.
This must be cumulative to not go to object near the meridian but below the horizon.
I fix that.

Patrick Chevalley

19-03-31 19:51

administrator   ~0005533

This was another problem, a test was wrong in my time interval check. But I not find it before because it worked with large interval.
This is fixed:
https://github.com/pchev/ccdciel/commit/eaad238281241f00d18b576b3ada58f491073ab2

Now the full messier run at it take only the objects just before the meridian.
I will add the minimum elevation test now.

Patrick Chevalley

19-04-01 18:42

administrator   ~0005537

I think most of the problem are now fixed, the messier list work fine for me.
It correctly use the rise/set time if this take precedence over the meridian time to respect the minimal elevation.
The objects that never rise above the minimal elevation are excluded.
Also every interval computation for begin/end time are now more robust.
You can test this when you have time.

Now it also show in the sequence tool when a target is excluded by repeatcount=0 by replacing the plan name.

han

19-04-03 09:41

reporter   ~0005547

Yes it works well. I did a short field run and more in simulation. I noticed two minor things:

- Autoscroll is missing in the sequence object list. The objects are marked bold but for the long Messier list the active object it is quickly out of sight.
- Initialise of an object takes time. So going through the Messier list it takes maybe one second for each object. I'm not sure if that is easy to improve.

I think this is a powerful tool and if you agree, I'm considering making a small promotion video and drop it on YouTube.

Patrick Chevalley

19-04-03 16:13

administrator   ~0005553

Good points.
Autoscroll and wait time are fixed by https://github.com/pchev/ccdciel/commit/32f61e438faada3756227639391483dc51f19dbc
I don't know why I added this one second wait...

Other related changes I do today:
Fix stopping a repeat sequence that do nothing:
https://github.com/pchev/ccdciel/commit/57c6d4bdabbb1e0502fb23810b9383d5fe58d896
Add button for "infinite" repeat (about 10 days run when doing nothing):
https://github.com/pchev/ccdciel/commit/9374ff48792e21b15642da800686da3e98625d8b
Put less load on autoguider and mount when quickly looping targets:
https://github.com/pchev/ccdciel/commit/4ccb252f80c1382035f43284aa17a09e797281fb

Yes, it can be interesting to have a demo video with this feature.

han

19-04-04 17:16

reporter   ~0005566

Last edited: 19-04-05 09:48

View 2 revisions

I have created a demonstration video. I hope I pronounce Ciel and Messier correctly:
https://youtu.be/YZQLNEriI04

I think there is still a bug in the object selection. For my position --- north, --- east, I noticed for today two weird object selections:

- At 15:30 hours it goes M28, M39. (Far from meridian)
- At 21:30 hours it doesn't select M81, M82.

And finally, there are two meridian crossing. From east to west and from west to east. Object for the last crossing are at there lowest position not the highest, so there is no need to image them in this position. See attached screenshot



meridian crossing.png (109,486 bytes)
meridian crossing.png (109,486 bytes)

Patrick Chevalley

19-04-04 20:02

administrator   ~0005569

Nice video thank you!
Do you think the wrong wait pop-up is because of the system time change?

The program already consider only the upper meridian transit, the transit below the pole is considered as the rise and set time for the circumpolar objects.
But there was a bug in my time interval computation for this objects when rise time = set time. This explain the issue with M39, M81, M82 I can reproduce the problem.
This bug is fixed by:
https://github.com/pchev/ccdciel/commit/f2c13479a1cea978717e7d93f5d7286feb4133b8

But this not explain the problem with M28, this object is only at an elevation of 12° at the meridian. So this is highly dependent on what you set for "minimum observing elevation", if higher that 12 it must be skipped with message "This object is never above the requested elevation".

han

19-04-04 21:06

reporter   ~0005571

>>Do you think the wrong wait pop-up is because of the system time change?

Yes that was weird. It should have continued with the object visible. I will test it again and probably redo the video.

han

19-04-04 23:27

reporter   ~0005572

This looks good. No problems. I have made a better video. Practicing helps:

https://youtu.be/F-u_mOs27nw

I will delete the previous one. If this CCDCIEL version is released, I will drop the link at an astronomy forum.

Patrick Chevalley

19-04-05 09:28

administrator   ~0005573

Very good.

Looking at the last part of the video it make sens if the new object name prompt is replaced by your search box. I look to do that.
Another addition that may be useful is to sort the object list by RA to image first the objects that will be soon out of the area.
I also need to add a minimal delay to avoid to go to an object that is very near the end time, at least to let the time for one exposure and also not slew by 5 minutes of the meridian to avoid a mount flip because of PA error.

Working on this changes give me an idea how to implement an automatic restart capability for the sequence, automatically skipping the objects and steps already done. Sure this must be an option to make working as on the video still available.
At the moment I have this only on a local branch and this need a bit more work before I can merge.

So I will release a new version soon with this change and after that I can merge the automatic restart.

han

19-04-05 10:10

reporter   ~0005574

>>Another addition that may be useful is to sort the object list by RA to image first the objects that will be soon out of the area.
That could be implemented by adding the option to sort the list on RA (and any other column). I do sorting in my program using Tlistview, and I assume this is possible with Tstringgrid

>>At the moment I have this only on a local branch and this need a bit more work before I can merge.
No hurry, as soon it is clear sky (could take some days/weeks) I intend to make one more complementary video with a real telescope in action, reviewing some basic operations of CCDCIEL.

Patrick Chevalley

19-04-06 22:00

administrator   ~0005581

This must be OK, I fix/add the following:
- new object button use the search box
- sort by ra,dec or name. for other column a click on the header is use to set a global value
- MC start is now 5 minutes after meridian, MC end is 5 minutes before
- fix for circumpolar objects
- test end time to allow for a least one exposure

Patrick Chevalley

19-06-08 18:18

administrator   ~0005681

The "automatic restart" functionality is now implemented and documented:
https://www.ap-i.net/ccdciel/en/documentation/sequence#restarting_a_sequence

So no more need to disable the objects already done when restarting a sequence.

This also add an interesting capability to not redo the objects already completed when using the global repeat option, this way the sequence can use the available time to do the new objects and not repeat the already completed that are still visible.

Issue History

Date Modified Username Field Change
19-03-25 14:44 han New Issue
19-03-25 14:44 han File Added: sequence1.png
19-03-25 16:13 Patrick Chevalley Assigned To => Patrick Chevalley
19-03-25 16:13 Patrick Chevalley Status new => assigned
19-03-25 16:13 Patrick Chevalley Note Added: 0005484
19-03-25 16:47 han File Added: sequence2.png
19-03-25 16:47 han Note Added: 0005485
19-03-25 17:13 Patrick Chevalley Note Added: 0005486
19-03-25 18:08 han Note Added: 0005488
19-03-25 18:29 han Note Added: 0005489
19-03-25 21:15 Patrick Chevalley Note Added: 0005490
19-03-30 21:21 han Note Added: 0005521
19-03-30 22:37 Patrick Chevalley Note Added: 0005526
19-03-31 17:35 Patrick Chevalley Note Added: 0005529
19-03-31 18:54 han File Added: messier.zip
19-03-31 18:54 han Note Added: 0005531
19-03-31 19:15 Patrick Chevalley Note Added: 0005532
19-03-31 19:51 Patrick Chevalley Note Added: 0005533
19-04-01 18:42 Patrick Chevalley Note Added: 0005537
19-04-03 09:41 han Note Added: 0005547
19-04-03 16:13 Patrick Chevalley Note Added: 0005553
19-04-04 17:16 han File Added: meridian crossing.png
19-04-04 17:16 han Note Added: 0005566
19-04-04 20:02 Patrick Chevalley Note Added: 0005569
19-04-04 21:06 han Note Added: 0005571
19-04-04 23:27 han Note Added: 0005572
19-04-05 09:28 Patrick Chevalley Note Added: 0005573
19-04-05 09:48 han Note Edited: 0005566 View Revisions
19-04-05 10:10 han Note Added: 0005574
19-04-06 22:00 Patrick Chevalley Note Added: 0005581
19-06-08 18:18 Patrick Chevalley Status assigned => resolved
19-06-08 18:18 Patrick Chevalley Resolution open => fixed
19-06-08 18:18 Patrick Chevalley Target Version => 1.0
19-06-08 18:18 Patrick Chevalley Note Added: 0005681