View Issue Details

IDProjectCategoryView StatusLast Update
0002103CCdciel[All Projects] Generalpublic19-04-01 16:15
ReporterArieAssigned ToPatrick Chevalley 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002103: Dome Slave indicator not work
DescriptionWhen I connect my Scopedome driver to my mount, the dome slave indicator remains Red.
The slot open indicator does turn Green.
It would be useful to have a button with which you can close the shutter and park the dome.
The option is offered at the end of a sequence, but this can not be initiated by the user.
The "park telescope" script works.
Please provide scripts for the above actions.
Additional InformationScopedome 2m driver
10Micron1000hps mount
TagsNo tags attached.

Activities

Patrick Chevalley

19-03-27 08:58

administrator   ~0005493

The slave indicator is set from the value of the Slaved ASCOM property:
https://ascom-standards.org/Help/Developer/html/P_ASCOM_DeviceInterface_IDomeV2_Slaved.htm

Do you have a way to check the value of this property, for example a VB script? if not I can send you a script.

OK to add a close and park button.

Arie

19-03-27 11:21

reporter   ~0005498

I am sorry Patrick.
I have no knowledge about program code or scripting.
I could ask Han to assist? He's become a good friend of mine and he knows my set-up. We live in the same area.
But if I can do this by running some script, I can try myself. (and learn)
It does work ok in SGP, so the dome ascom driver should be doing what it is supposed to do......

Patrick Chevalley

19-03-27 13:34

administrator   ~0005500

Here is a script to test the dome status.

- download the file testdome.zip attached to this note.
- unzip in your Documents folder
- connect the dome to Ascom driver, open the shutter, slave the telescope.
- open a command prompt
- change to your documents folder, type : cd Documents
- run the script, type: cscript testdome.js
- this open the Ascom chooser, select the dome driver
- click OK
- this print a message in the console:
shutter=0 meant Open, 1 meant Close.
slaved=True or False

See screenshot of the result using the "ASCOM Dome Control" driver.

dome_script1.png (6,859 bytes)
dome_script1.png (6,859 bytes)
testdome.zip (331 bytes)

Arie

19-03-27 14:44

reporter   ~0005501

Tried it. See the results.
The shutter position comes in alright.
The dome and mount being slaved not.
As you can see the mount is connected to the dome.

CCDCiel4.JPG (118,264 bytes)
CCDCiel4.JPG (118,264 bytes)

Patrick Chevalley

19-03-27 17:32

administrator   ~0005503

Yes, this property Slaved do not reflect that state of Scope Sync. This is definitively a bug with the driver.

I installed the ScopeDome driver and I can play with it because it include a simulation mode.

It look like the Slaved property is implemented as WriteOnly, i.e. reading the property do not report the correct status.
if I set "dome.Slaved=true;" in the script it correctly start slaving the telescope, after that from the same script instance I can read dome.Slaved, it is True, correct.
But if I start another script to read dome.Slaved it is always False, but the driver interface still show "Scope Sync ON".
The same occur when you click the "Scope Sync" button, the Slaved property is never reported as True.

So it work with other software probably because they set dome.Slaved=true.

In CCDciel I not want to go to a full management of the dome because every dome will require a different startup sequence and this is almost useless because the dome already have a setup software to do that.
But I can add a Slave button to start scope sync manually from CCDciel.

So the work for me is:
- add a close/park button
- add a slave button

Arie

19-03-27 19:23

reporter   ~0005506

Thank you for this.
I did a brief test with a short test sequence with the options "park scope" and "park dome and close shutter" enabled.
It works OK. So your commands are correct for this.
When I started the sequence I got the message "dome not slaved" I pressed "continue".
The sequence was completed as I mentioned.
These two buttons would be very easy for dome users.
I have been testing ModelCreator's dome control integration in this sky modelling software quite extensively with the author (more than 3 month's :-) )
It is indeed very complicated to get the arithmatic correct. The scopedome driver does this very accurate.

Patrick Chevalley

19-03-28 09:36

administrator   ~0005508

Yes, other ASCOM function look to be correctly implemented by the ScopeDome software.

If you want you can report this bug to the developer. You can include the screenshot CCDCiel4.JPG and the script.
Explain that after you click "Scope Sync" the script still report Slaved=false.

Patrick Chevalley

19-03-28 12:24

administrator   ~0005509

You can install a test version that add the two button for the dome:
https://vega.ap-i.net/tmp/ccdciel-0.9.54-1498-windows-x32.exe

Tell me if this work for you.

Arie

19-03-28 14:48

reporter   ~0005510

Brilliant!
Tested it and it works ok.
Including the green dots.
Thank you very much.

Could you do the same for the mount?
2 buttons Park Mount and Unpark Mount?
I know....the scripts are there. But nevertheless.....

Then at the end of a session I only have to push 2 buttons to put my observatory in a safe state.

Patrick Chevalley

19-03-28 16:54

administrator   ~0005511

You already have a button to park or unpark the telescope.
This is the button next to the declination in the Mount tool:
https://www.ap-i.net/ccdciel/en/documentation/telescope_mount

This make me think I must check the telescope is parked before you can park the dome. This is something we can forget at the end of the night.

Arie

19-03-29 02:20

reporter   ~0005513

If users have a RO/RO roof, it is important in many cases that the mount is parked in a specific position, before the roof closes.
For dome users the sequence is less important, but also both actions need to be performed.
I like to close the shutter first. Then park the mount and dome.

I found the buttons indeed and also found out that the tool blocks can be repositioned.
Both tool blocks are now together. Great!

Arie

19-03-29 02:27

reporter   ~0005515

I reported te bug to Jacek Pala, the author of the driver from Scopedome.
This is his reply:

In my opinion Ascom.Slaved should works well. Please look on the code it is 100% well with ASCOM standard.

If you have a problem please show me it via TeamViewer connection. My be I can help you.
---------

    Private m_slaved As Boolean = False
    Public Property Slaved() As Boolean Implements IDomeV2.Slaved

        Get
            log.AddToASCOMLog("GET", "Slaved", m_slaved.ToString)
            'Throw New PropertyNotImplementedException("Slaved", False)
            Return m_slaved
        End Get

        Set(ByVal Value As Boolean)
            log.AddToASCOMLog("SET", "Slaved", Value.ToString)

            m_slaved = Value

            If My.Settings.Def_ASCOM_Disable_SlewTo_Azimuth Then
                Throw New PropertyNotImplementedException("Slaved is disabled by Dome Config")
                Exit Property
            End If

            If Value = True Then
                DomeAction_List_Add_Command(Action_Command.Dome_SyncWithScope_On, 0, 0, m_ScriptName)
                Mode = Action_Mode.Sync_With_Scope
                m_slaved = True
            Else
                DomeAction_List_Add_Command(Action_Command.Dome_SyncWithScope_Off, 0, 0, m_ScriptName)
                m_slaved = False
                card.ScopeSync = CheckState.Unchecked
                Mode = Action_Mode.Dome_Do_Nothing
                Pause_Soft(3000)
            End If
        End Set
    End Property

--------------

this is ASCOM definition for this function:
---------

IDomeV2. Slaved Property
True if the dome is slaved to the telescope in its hardware, else False.
Namespace: ASCOM.DeviceInterface
Assembly: ASCOM.DeviceInterfaces (in ASCOM.DeviceInterfaces.dll) Version: 6.0.0.0 (6.3.0.2821)
Syntax
C#
VB
C++
Copy
bool Slaved { get; set; }
Property Value

Type: Boolean
Remarks
Slaved Read must be implemented and must not throw a PropertyNotImplementedException.
Slaved Write can throw a PropertyNotImplementedException.

Set this property to True to enable dome-telescope hardware slaving, if supported (see CanSlave). Raises an exception on any attempt to set this property if hardware slaving is not supported). Always returns False if hardware slaving is not supported.
See Also
Reference

IDomeV2 Interface
ASCOM.DeviceInterface Namespace
Copyright © 2010-15, The ASCOM Initiative

Send comments on this topic to Send feedback to ASCOM
---------
Regards,
Jacek Pala
ScopeDome Team
http://www.ScopeDome.com
tel. +48 602 315 947

Patrick Chevalley

19-03-29 09:28

administrator   ~0005516

This probably not need a Teamviewer session because I can reproduce the issue with the simulator.
Can you give me Jacek email because on the ScopeDome web site I not found this name.

Arie

19-03-29 12:04

reporter   ~0005517

I communicate with Jacek through:

info@scopdedome.com

Jacek has beeb very helpful to get me going with my dome.

Patrick Chevalley

19-04-01 16:15

administrator   ~0005536

I receive an email from Jacek.
The problem is now fixed in ScopeDome version 5.1.37 and the CCDciel slave indicator now turn green immediately.
I keep the button in CCDciel because this can be useful.
It is very nice to have such good support for the dome driver, now I just dream every camera manufacturer do the same ...

Issue History

Date Modified Username Field Change
19-03-27 02:26 Arie New Issue
19-03-27 08:58 Patrick Chevalley Assigned To => Patrick Chevalley
19-03-27 08:58 Patrick Chevalley Status new => assigned
19-03-27 08:58 Patrick Chevalley Target Version => 1.0
19-03-27 08:58 Patrick Chevalley Note Added: 0005493
19-03-27 11:21 Arie Note Added: 0005498
19-03-27 13:34 Patrick Chevalley File Added: testdome.zip
19-03-27 13:34 Patrick Chevalley File Added: dome_script1.png
19-03-27 13:34 Patrick Chevalley Note Added: 0005500
19-03-27 14:44 Arie File Added: CCDCiel4.JPG
19-03-27 14:44 Arie Note Added: 0005501
19-03-27 17:32 Patrick Chevalley Note Added: 0005503
19-03-27 19:23 Arie Note Added: 0005506
19-03-28 09:36 Patrick Chevalley Note Added: 0005508
19-03-28 12:24 Patrick Chevalley Note Added: 0005509
19-03-28 14:48 Arie Note Added: 0005510
19-03-28 16:54 Patrick Chevalley Note Added: 0005511
19-03-29 02:20 Arie Note Added: 0005513
19-03-29 02:27 Arie Note Added: 0005515
19-03-29 09:28 Patrick Chevalley Note Added: 0005516
19-03-29 12:04 Arie Note Added: 0005517
19-04-01 16:15 Patrick Chevalley Status assigned => resolved
19-04-01 16:15 Patrick Chevalley Resolution open => fixed
19-04-01 16:15 Patrick Chevalley Note Added: 0005536